Bug Hunting Session
Bug 106853 - LibreOffice convert-to/print-to-file don't use “scale”
Summary: LibreOffice convert-to/print-to-file don't use “scale”
Status: RESOLVED DUPLICATE of bug 65848
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-29 12:59 UTC by Alexander
Modified: 2017-10-28 18:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2017-03-29 12:59:09 UTC
Description:
try to convert xlsx document to pdf like

libreoffice --convert-to pdf  1.xlsx --headless
or

libreoffice --print-to-file  1.xlsx --headless

on an output the file constructed without the scale parameter

Steps to Reproduce:
1.
create new xlsx file by libreoffice calc
insert some data
2.
set prit options:
File->Print Preview -> Format Page-> Sheet -> Scale :
Scale mode: Reduce/enlarge printout
Scaling factor:  50% 
3.
Save file to "xlsx" fromat
4.
convert with "libreoffice --convert-to pdf/print-to-file "
5. open output file to be convinced that scale parameter don't use

Actual Results:  
scale parameter don't use

Expected Results:
slace parameter influences to output file by  -convert-to pdf/print-to-file


Reproducible: Always

User Profile Reset: No

Additional Info:
if itself I generate xlsx file

xl/worksheets/sheet1.xml

<worksheet>
  <sheetPr filterMode="false">
    <pageSetUpPr fitToPage="false"/>
  </sheetPr>
...
...
<pageSetup 
  paperSize="9" 
  scale="50" 
  firstPageNumber="0" 
  fitToWidth="1" 
  fitToHeight="1" 
  pageOrder="downThenOver" 
  orientation="portrait" 
  usePrinterDefaults="false" 
  blackAndWhite="false" 
  draft="false" 
  cellComments="none" 
  useFirstPageNumber="false" 
  horizontalDpi="300" 
  verticalDpi="300" 
  copies="1"/>
...

</worksheet>

this problem reproduce


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.59 Safari/537.36
Comment 1 Xisco Faulí 2017-03-29 13:16:53 UTC Comment hidden (obsolete)
Comment 2 Alexander 2017-03-29 13:56:24 UTC
update libreoffice from https://www.libreoffice.org/download/libreoffice-fresh/ to 
LibreOffice 5.3.1.2 e80a0e0fd1875e1696614d24c32df0f95f03deb2

problem reproduce


OS

Distributor ID:	Ubuntu
Description:	Ubuntu 16.04.2 LTS
Release:	16.04
Codename:	xenial
Linux 4.4.0-62-generic x86_64 x86_64 x86_64 GNU/Linux
Comment 3 Alexander 2017-03-29 14:02:45 UTC
also still I noted the bug connected to it:
1. open libreoffice calc

2. set prit options:
File->Print Preview -> Format Page-> Sheet -> Scale :
Scale mode: Reduce/enlarge printout
Scaling factor: 50% 

3.  save in the "xlsx" format
4. close libreoffice calc
5. open just saved file
6. go to File->Print Preview -> Format Page-> Sheet -> Scale :

Scale mode: Reduce/enlarge printout
Scaling factor: 100% !
Comment 4 Alexander 2017-03-29 14:14:11 UTC
(In reply to Alexander from comment #3)
> also still I noted the bug connected to it:
> 1. open libreoffice calc
> 
> 2. set prit options:
> File->Print Preview -> Format Page-> Sheet -> Scale :
> Scale mode: Reduce/enlarge printout
> Scaling factor: 50% 
> 
> 3.  save in the "xlsx" format
> 4. close libreoffice calc
> 5. open just saved file
> 6. go to File->Print Preview -> Format Page-> Sheet -> Scale :
> 
> Scale mode: Reduce/enlarge printout
> Scaling factor: 100% !

if use fromat Microsof Excel (2007-2013) (.xlsx)  or 
   Office Open XML Spreadsheet (.xlsx) - problem reproduce

if use fromat ODF Spreadsheet (.ods) to save, problem not reproduce
Comment 5 Buovjaga 2017-04-01 18:22:34 UTC
(In reply to Alexander from comment #3)
> also still I noted the bug connected to it:
> 1. open libreoffice calc
> 
> 2. set prit options:
> File->Print Preview -> Format Page-> Sheet -> Scale :
> Scale mode: Reduce/enlarge printout
> Scaling factor: 50% 
> 
> 3.  save in the "xlsx" format
> 4. close libreoffice calc
> 5. open just saved file
> 6. go to File->Print Preview -> Format Page-> Sheet -> Scale :
> 
> Scale mode: Reduce/enlarge printout
> Scaling factor: 100% !

This is the real problem.
..and I found an existing report.

*** This bug has been marked as a duplicate of bug 86396 ***
Comment 6 Alexander 2017-04-02 06:57:48 UTC
(In reply to Alexander from comment #0)
> Description:
> try to convert xlsx document to pdf like
> 
> libreoffice --convert-to pdf  1.xlsx --headless
> or
> 
> libreoffice --print-to-file  1.xlsx --headless
> 
> on an output the file constructed without the scale parameter
> 
> Steps to Reproduce:
> 1.
> create new xlsx file by libreoffice calc
> insert some data
> 2.
> set prit options:
> File->Print Preview -> Format Page-> Sheet -> Scale :
> Scale mode: Reduce/enlarge printout
> Scaling factor:  50% 
> 3.
> Save file to "xlsx" fromat
> 4.
> convert with "libreoffice --convert-to pdf/print-to-file "
> 5. open output file to be convinced that scale parameter don't use
> 
> Actual Results:  
> scale parameter don't use
> 
> Expected Results:
> slace parameter influences to output file by  -convert-to pdf/print-to-file
> 
> 
> Reproducible: Always
> 
> User Profile Reset: No
> 
> Additional Info:
> if itself I generate xlsx file
> 
> xl/worksheets/sheet1.xml
> 
> <worksheet>
>   <sheetPr filterMode="false">
>     <pageSetUpPr fitToPage="false"/>
>   </sheetPr>
> ...
> ...
> <pageSetup 
>   paperSize="9" 
>   scale="50" 
>   firstPageNumber="0" 
>   fitToWidth="1" 
>   fitToHeight="1" 
>   pageOrder="downThenOver" 
>   orientation="portrait" 
>   usePrinterDefaults="false" 
>   blackAndWhite="false" 
>   draft="false" 
>   cellComments="none" 
>   useFirstPageNumber="false" 
>   horizontalDpi="300" 
>   verticalDpi="300" 
>   copies="1"/>
> ...
> 
> </worksheet>
> 
> this problem reproduce
> 
> 
> User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like
> Gecko) Chrome/54.0.2840.59 Safari/537.36


But how about this bug ??
Comment 7 Buovjaga 2017-04-02 07:30:23 UTC
(In reply to Alexander from comment #6)
> But how about this bug ??

LibreOffice is resetting the scaling to 100% always when opening xlsx, so it's the same bug all the time.

*** This bug has been marked as a duplicate of bug 86396 ***
Comment 8 Alexander 2017-04-02 10:16:28 UTC
When this bug will be fixed ?
Comment 9 Buovjaga 2017-04-02 14:10:38 UTC
(In reply to Alexander from comment #8)
> When this bug will be fixed ?

Nobody knows. You are free to find a developer to fix it. https://wiki.documentfoundation.org/Development/GetInvolved
Comment 10 Xisco Faulí 2017-10-28 18:20:38 UTC

*** This bug has been marked as a duplicate of bug 65848 ***