Download it now!
Bug 106873 - [StartCenter] Making visibility of document content optional
Summary: [StartCenter] Making visibility of document content optional
Status: RESOLVED DUPLICATE of bug 74834
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-30 13:28 UTC by Sophia Schroeder
Modified: 2017-03-30 16:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sophia Schroeder 2017-03-30 13:28:15 UTC
Users often work with confidential material, which content should not bee seeable for other people. An example is when you want to show a costumer a document, want to open this via StartCenter, s/he could see content not intended for him/her. Setting a password is one, but not always a good solution. As creator you probably want to see in which document which information are as an overview/thumbnail.

A possible solution could be to create a checkbox in top of the Startcenter to choose the visibility of the below contents.
Comment 1 tommy27 2017-03-30 14:38:28 UTC
I think that there's probably an advanced setting to do what you asked.
Comment 2 Sophia Schroeder 2017-03-30 15:07:22 UTC
"An advanced setting" is surely a bit too much
for an "housewife" like me or other users. ;-)

Need just a simple checkbox or some such
to hide/show documents content
(depending on password protection, of course) ad hoc.

A tooltip may warn about potential risks about this feature, when exist.
Comment 3 V Stuart Foote 2017-03-30 16:27:46 UTC
Simple enough...

Tools -> Options -> Advanced: "Open Expert Configuration"

enter "RecentDocsThumbnail" into the Search field, and search

click the "edit" button to toggle True/False

OK out

exit & restart LibreOffice.


On restart all Thumbnail Views have been replaced by generic ODF icons.

*** This bug has been marked as a duplicate of bug 74834 ***