Bug 74834 - CONFIGURATION: Option to disable documents thumbnails in the Start Center
Summary: CONFIGURATION: Option to disable documents thumbnails in the Start Center
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium enhancement
Assignee: pierre.sauter
QA Contact:
URL:
Whiteboard: target:5.2.0
Keywords:
: 82179 105621 (view as bug list)
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2014-02-11 10:55 UTC by trevor.k.hook
Modified: 2017-02-04 09:55 UTC (History)
21 users (show)

See Also:
Crash report or crash signature:


Attachments
with this .xcu thumbnails are disabled (48.90 KB, text/xml)
2014-06-07 10:49 UTC, tommy27
Details
StartCenter without Welcome screen and thumbnail view pane (33.23 KB, image/png)
2015-04-15 14:57 UTC, V Stuart Foote
Details
LORecentdoc.png (47.19 KB, image/png)
2016-11-07 18:17 UTC, NoOp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description trevor.k.hook 2014-02-11 10:55:59 UTC
Problem Description:
The New Start Screen shows thumbnails for recently used documents.

Thumbnails have the following downsides:
1) Easy to shoulder surf
2) Horrible data density

It would be nice to have an option to disable Thumbnails on the Start Screen by either:

Reverting to the old start screen which was compact and usable
- or -
Providing a textual list of recent documents which could also benefit from additional information (modified date, pathway, etc) and so make use of the screen effectively.
Operating System: All
Version: 4.2.0.4 release
Last worked in: 4.1.5.1 rc
Comment 1 tommy27 2014-02-12 03:09:42 UTC
enhancement request. status --> NEW
Comment 2 bugquestcontri 2014-03-05 11:50:35 UTC
There is also a privacy issue. Please see AskLibO:
http://ask.libreoffice.org/en/question/30702/can-i-supress-the-images-on-the-start-screen/

The proposal of Trevor concerning a list of recent documents with  more information is also a nice one.
Comment 3 crxssi 2014-03-29 06:05:18 UTC
(In reply to comment #2)
> There is also a privacy issue. 

Yes, the privacy issue can be serious.
And it confuses some lesser-savvy users.
And it slows down startup time or time-to-task if you don't want to use a recently used document.
And it encourages new users to not understand proper directory structures and file organization.
And it annoys some of the conservative users.

Really, it is amazing to me something this sweeping and dramatic would be added without any option to control it at all.  To be a world-class program, LO needs to consider all types of users in all types of environments.  And that means having flexibility for configuration. There is currently no reasonable workaround.

Unlike the first posting, I don't think it should be an "-or-" but an "-and-"....  user should be able to turn it off completely, but also having an additional option choice for a textual listing would be nice (although the listing is already available under the "File" menu, so it is probably redundant).  

http://ask.libreoffice.org/en/question/29139/can-the-new-start-screen-in-v42-be-reverted-to-that-in-v41/
http://ask.libreoffice.org/en/question/30702/can-i-supress-the-images-on-the-start-screen/
http://ask.libreoffice.org/en/question/31050/is-there-a-way-to-change-the-initial-screen-in-lo-4211/
Comment 4 tommy27 2014-05-07 05:49:42 UTC
I think that maybe you can workaround the issue by  manually editing the registrymodifications.xcu in the user profile in order to disable thumbnails in the New Start Screen.

I use the portable version of LibO from winPenPack.com and after upgrading from 4.1.x to 4.2.x and migrating my user profile (which comes from 4.1.x) I've noticed that thumbnails in start screen do not show up at all.

If I reset the user profile in 4.2.x the thumbnails show up again and I've identified that the file which triggers the on/off is  registrymodifications.xcu

I'll do further testing to understand which code line can be deleted in 4.2.x xcu file to turn off the thumbails.

probably the .xcu from 4.1.x misses some information that 4.2.x needs to show the thumbs
Comment 5 bugquestcontri 2014-05-13 06:54:10 UTC
tommy 27,
this is very good news. I keep fingers crossed that you will be able to solve this issue.

Until now I was on the save side because my production system was 4.1 but now have to very carefully with what shows up when I am with a client.
Comment 6 bbugs 2014-06-03 05:43:32 UTC
I would be deeply grateful if this bug could be fixed as soon as possible. Please integrate an option that allows to disable the new start screen. Effectively, I cannot use version 4.2 (or later) due to these privacy issues. I would be always in danger that my clients could see something they should not. Sorry, but this is extremely annoying.
Comment 7 crxssi 2014-06-03 11:35:26 UTC
(In reply to comment #6)
> I would be deeply grateful if this bug could be fixed as soon as possible.
> Please integrate an option that allows to disable the new start screen.
> Effectively, I cannot use version 4.2 (or later) due to these privacy
> issues. I would be always in danger that my clients could see something they
> should not. Sorry, but this is extremely annoying.

There are two partial workarounds I can think of:

1) You can clear your recently used history after opening each document or maybe just after each session.

2) You can launch the LO component you want directly, without going through the "main menu" screen.

Neither is very convenient and it is very unfortunate that someone added this ridiculous preview screen without considering all the ramifications.
Comment 8 tommy27 2014-06-07 07:38:16 UTC
not being able yet to understand how to reproduce the tweak of .xcu file explained in comment 4

anyway I just wanted to let you know that in 4.3.x it will be possible at least to selectively delete some documents thumbnails from start center.
see: https://wiki.documentfoundation.org/ReleaseNotes/4.3#GUI
Comment 9 Wolfgang Denk 2014-06-07 08:37:32 UTC
(In reply to comment #8)
> 
> anyway I just wanted to let you know that in 4.3.x it will be possible at
> least to selectively delete some documents thumbnails from start center.
> see: https://wiki.documentfoundation.org/ReleaseNotes/4.3#GUI

Actually that's not much helpful here.  The feature is about deleting
recent documents from the list - but that is some pretty much
different thing.  I want to get rid of the thumbnails, but I still
want to keep my recent list.  Thumbnails and recent list are two
independent things, that should not bbe mixed here.
Comment 10 tommy27 2014-06-07 10:49:35 UTC
Created attachment 100600 [details]
with this .xcu thumbnails are disabled

as said before in my LibO 4.2.4.2 under Win7x64 the thumbnails in start center are completely disabled

I don't know why this happens but it seems related to something inside the registrymodifications.xcu 

feel free to inspect and see what's causing this behaviour which - if reproducible - could be used as a tweak for users who wanna get rid of start center thumbs.

that file should be put inside the user profile folder
Comment 11 Jan Holesovsky 2014-06-17 06:35:23 UTC
Yes, you can completely disable the thumbnails by setting the amount of recent documents to 0:

* Tools -> Options -> Expert Configuration
* Find /org.openoffice.Office.Common/History, property "PickListSize"
* Choose [Edit], and change the value to 0, [OK]
* [OK] in the Expert Configuration
* [OK] in Options

The only bug that is there now is that the Start center is not refreshed when you update this value - so you have to either restart LibreOffice, or open & close Writer again to see the recent documents gone.
Comment 12 trevor.k.hook 2014-06-17 07:30:48 UTC
Does setting PickListSize affect only thumbnails display or are you just setting the recent file list to zero?

If its just setting recent file list to zero then the solution is just a hack, disabling a useful feature to hide an undesirable addition.
Comment 13 crxssi 2014-06-17 11:46:00 UTC
(In reply to comment #12)
> Does setting PickListSize affect only thumbnails display or are you just
> setting the recent file list to zero?
> 
> If its just setting recent file list to zero then the solution is just a
> hack, disabling a useful feature to hide an undesirable addition.

I was going to ask the exact same question.  Simply disabling the recently used text list is NOT the solution to this problem and if that is what is saying, then the title of this enhancement and priority should be reverted back to what it was.

Many of us use the recently used documents list and like it a lot.  We don't want to lose that feature just to get rid of the opening screen recently used documents "preview gallery".
Comment 14 Keith L Terrill 2014-07-05 01:35:28 UTC
I did not see this noted and just want to add this additional point about the Start Center display of the documents in the right hand pane.

In the United States the HIPPA law carrys severe penalties for medical and sensitive data being in a position that those without rights to view it can.

In other words, those that are using the current version of, and the proposed "fix", are in danger of violating HIPPA code if they use the LO Start Center.
Comment 15 Jean-Baptiste Faure 2014-07-05 05:20:27 UTC
(In reply to comment #14)
> I did not see this noted and just want to add this additional point about
> the Start Center display of the documents in the right hand pane.
> 
> In the United States the HIPPA law carrys severe penalties for medical and
> sensitive data being in a position that those without rights to view it can.

I do not understand what is different here from whatever document you are editing; you are not obliged to show your screen to all persons around.

Please do not change the version number, it shows the oldest version in which the bug has been observed.

Best regards. JBF
Comment 16 tommy27 2014-07-05 09:25:07 UTC
> (In reply to comment #12)
> ...
> I was going to ask the exact same question.  Simply disabling the recently
> used text list is NOT the solution to this problem and if that is what is
> saying, ....

that's a temporarily workaround for those who wanna absolutely get rid of start screen thumbs. it's not the final solution, since it has downside effect of turning off the recent document list

> ... then the title of this enhancement and priority should be reverted
> back to what it was.

I agree. I reverted the title to the original description.
Comment 17 crxssi 2014-07-05 11:56:06 UTC
(In reply to comment #15)

> I do not understand what is different here from whatever document you are
> editing; you are not obliged to show your screen to all persons around.

A user will probably not remember all the documents he/she has been working on recently.  If there is someone in their office within visual range of the monitor and that user starts LO, it will expose actual document content for others to see, not just a list of document names.

Another example- imagine your laptop connected to a projector for a meeting with dozens of people watching and you open LO, forgetting that it is going to show actual content of your recently used documents.... or you forgot that you had been working on a sensitive document a few days before and WHAM- everyone can see a part of it now before you fully open the document they are supposed to see.

It is simply a very bad idea for LO to do this and give the user no way to persistently turn it off.  Should I make a sample screenshot that will illustrate the danger, or does everyone understand the issue?
Comment 18 helplibreoffice 2014-07-09 08:04:07 UTC
I would like to turn off the thumbnails as well.
Comment 19 manj_k 2014-07-10 09:08:03 UTC
There's a workaround that disables the thumbnails on the start screen, but doesn't affect the list of the recent documents (PickList):
http://ask.libreoffice.org/en/question/29139/can-the-new-start-screen-in-v42-be-reverted-to-that-in-v41/?answer=36673#post-id-36673 .
Comment 20 Friedmann Bruno 2014-07-10 16:22:52 UTC
Résumé of #19
Work with 4.3.0x

in [install_path]/share/config/soffice.cfg/sfx/ui/startcenter.ui
setting this part allow to no more shown thumbnails etc ..
(often under linux /usr/lib64/libreoffice)

    <child>
      <object class="sfxlo-RecentDocsView" id="all_recent">
        <property name="visible">False</property>
        <property name="can_focus">False</property>
        <property name="hexpand">False</property>
        <property name="vexpand">False</property>
      </object>

Give a way to user to setup it on or off.
Comment 21 crxssi 2014-07-10 19:29:22 UTC
(In reply to comment #20)

> [install_path]/share/config/soffice.cfg/sfx/ui/startcenter.ui

I can confirm this is an excellent workaround and does, indeed, work (in 4.2.3, Linux).  As a bonus it is global (so it will affect all users).  Great suggestion until something more friendly comes along!
Comment 22 tommy27 2014-08-05 06:52:36 UTC
*** Bug 82179 has been marked as a duplicate of this bug. ***
Comment 23 Klaus 2014-09-05 08:35:09 UTC
Does the modification of startcenter.ui only stop the images from being shown, or does it also prevent them from being created?

Also where are these images stored? I want to delete them.
Comment 24 Klaus 2014-09-05 09:39:22 UTC
The thumbnails are stored inside the file
%appdata%\LibreOffice\4\user\registrymodifications.xcu
in the lines that contain the text
['PickList']/ItemList

Neither the change in startcenter.ui nor setting PickListSize to 0 removes these entries.

The file can be edited with Wordpad (Windows) and the offending lines manually removed.

The change in startcenter.ui does not prevent new items from being created. Setting PickListSize to 0 does.

Setting PickListSize to 0 can also be done by editing registrymodifications.xcu.
Go behind the last line of Common/Drawinglayer and before the first line of Common/Cache/Writer. Insert there this on one line:
<item oor:path="/org.openoffice.Office.Common/History"><prop oor:name="PickListSize" oor:op="fuse"><value>0</value></prop></item>
Comment 25 V Stuart Foote 2015-04-14 19:18:35 UTC
Setting to enhancement.

Since 4.3.2 builds, commit
http://cgit.freedesktop.org/libreoffice/core/commit/?id=a628ea1cd72585b889d591052680ebf79887dcef&h=libreoffice-4-3

document derived thumbnail views are not generated nor held in the per-user registrymodifications.xcu, rather generic LibreOffice branding icons are used as place holders in the StartCenter thumbnail view panel.

All talk about security is basically FUD.

For folks with legitimate security concerns, would recommend you simply set a password for your document.

And if you are HIPPA constrained environment, you're already doing that right?

In answer to OPs original request for enhancement, as mentioned you can suppress the Recent Documents list and associated thumbnails by setting from Expert Configuration the value PickListSize to 0--or simply reduce it from its current maximum of 25.  As in comment 10.

The tweak to StartCenter.ui as in comment 19 comment 20 only disables the drawing of the Thumbnail views panel--the thumbnails are generated and recorded for each document to registrymodifications.xcu as base64 encoded images.
Comment 26 crxssi 2015-04-15 02:53:47 UTC
(In reply to V Stuart Foote from comment #25)

> In answer to OPs original request for enhancement, as mentioned you can
> suppress the Recent Documents list and associated thumbnails by setting from
> Expert Configuration the value PickListSize to 0--or simply reduce it from
> its current maximum of 25.  As in comment 10.

Unfortunately, that doesn't address the issue for those who don't want the thumbnails but do want to retain the text listing.  A simple new option in export configuration to suppress just the drawing of the thumbnails would address the issue nicely (even if a bit hidden).... and it requires no UI changes either.

> The tweak to StartCenter.ui as in comment 19 comment 20 only disables the
> drawing of the Thumbnail views panel--the thumbnails are generated and
> recorded for each document to registrymodifications.xcu as base64 encoded
> images.

And that is exactly what it seems most people are asking for- a way to suppress displaying the thumbnails (and without losing any other functionality in the process).

I agree with your moving it away from "major", and one could reasonably argue it should be considered an enhancement.
Comment 27 V Stuart Foote 2015-04-15 14:57:31 UTC
Created attachment 114811 [details]
StartCenter without Welcome screen and thumbnail view pane

Over to UX-advise

Agree it would be a worthwhile UI/UX enhancement to provide option of not showing the Welcome screen and thumbnail view pane--and provide a minimalistic launcher bar for those that prefer to not see the thumbnail views.

If we were to suppress the Thumbnail views panel in StartCenter, guess the UI would work best then if we simply shrink the StartCener to current extent of the sidebar launchers.

Attached mockup of StartCenter launcher bar when welcome screen and thumbnail views are turned off.
Comment 28 Nuno J. Silva 2015-04-15 16:47:53 UTC
What if LibreOffice is started maximized or in an environment where it would be better if LibreOffice did not try to enforce a maximum window width (such as tiling window managers)?

One way to cope better with this would be to either have only a sidebar and then a blank space on the right (perhaps this is the easier to implement?). Another way would be to center the options, instead of making a tall sidebar. Something like the old start screen. http://pclosmag.com/html/issues/201209/images/page13/image03.png
Comment 29 Yousuf Philips (jay) 2015-04-15 19:01:23 UTC
Agree that there should be a mechanism that the recent documents list appears in the start center but doesnt display the thumbnails.
Comment 30 crxssi 2015-04-15 22:23:32 UTC
(In reply to Jay Philips from comment #29)
> Agree that there should be a mechanism that the recent documents list
> appears in the start center but doesnt display the thumbnails.

We do sorta already have that- since one can get to it from File-> Recently Documents.  I like the mockup Foote provided.  But I know what you mean- listing them in the large area, just without the thumbnails.  Another interesting thought is that the option to display or not display thumbnails could be in that new "Recent Files" menu as the first entry with a checkbox next to it... something like "(*) Display recently used document thumbnails"
Comment 31 Yousuf Philips (jay) 2015-04-16 14:01:52 UTC
(In reply to crxssi from comment #30)
> We do sorta already have that- since one can get to it from File-> Recently
> Documents.

The bug report is about the start center, so the menu bar isnt really relevant.

> I like the mockup Foote provided.

Stuart's mockup didnt make sense to me as it would be better to show the empty welcome screen rather than shrinking the windows to just fit the size of the button column, because clicking on a module in such a state would have the window size at that size, so a user would have to resize it to do any type of work.

> But I know what you mean-
> listing them in the large area, just without the thumbnails.

Yes just not showing the thumbnails fixes the primary issue trevor mentioned "Easy to shoulder surf". About "Horrible data density", being able to switch from the present icon view to detailed view, like what is found in file managers.

> Another
> interesting thought is that the option to display or not display thumbnails
> could be in that new "Recent Files" menu as the first entry with a checkbox
> next to it... something like "(*) Display recently used document thumbnails"

I doubt there would be enough users interested in disabling the thumbnails to warrant it being in the 'Recent Files' menu, but if it had to go into the drop down, it would have to be the last entry. I'd assume this option would be present in the Tools > Options dialog.
Comment 32 Andreas Heinlein 2015-05-04 14:29:10 UTC
I have to join in to ask something related to this topic:

We are indeed looking for a way to disable *creation* of these thumbnails in registrymodifications.xcu, without setting the PickListSize to 0.

We are editing sensitive data, and we chose to keep it on encrypted storage to keep it private. The LO user profiles currently reside on the server (NFS-mounted home). 

First there is the fact that these thumbnails indeed added some considerable server load. It looks like every time a new thumbnail is created, the complete file is read from the server and written back, and with each file being around 2-3MB this adds up quickly with 100+ users.

But more important, we are obliged to make sure that these profiles do not contain any sensitive data. We're not talking about "shoulder surfing", we're talking about deliberate attacks. So we will set the PickListSize to 0 for now, but I am looking for a better solution.

Can someone help?
Comment 33 pierre.sauter 2015-12-01 20:41:08 UTC
I just submitted a patch to gerrit to address this bug:

https://gerrit.libreoffice.org/#/c/20338/

I would be happy about comments/reviews.
Comment 34 V Stuart Foote 2015-12-01 21:54:01 UTC
(In reply to Andreas Heinlein from comment #32)

> But more important, we are obliged to make sure that these profiles do not
> contain any sensitive data. We're not talking about "shoulder surfing",
> we're talking about deliberate attacks. So we will set the PickListSize to 0
> for now, but I am looking for a better solution.
> 
> Can someone help?

Simply sign the document, no thumbnail will be produced.
Comment 35 Commit Notification 2015-12-07 13:08:34 UTC
Pierre Sauter committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1a032dcfebc2702f0612c470d6b9c3e3cf4fb637

tdf#74834 Expert Configuration option to disable thumbnails in StartCenter

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 36 Samuel Mehrbrodt (CIB) 2015-12-07 13:09:34 UTC
Option is available in Expert Config (search for RecentDocsThumbnail).
Comment 37 Nil 2016-11-07 12:46:39 UTC
The shoulder surfing concern (see downside #1 in description) still exists and still unpleasant for me too. I recommend reopening this ticket.
Comment 38 V Stuart Foote 2016-11-07 13:22:59 UTC
(In reply to Nil from comment #37)
> The shoulder surfing concern (see downside #1 in description) still exists
> and still unpleasant for me too. I recommend reopening this ticket.

No, it is Resolved Fixed that there will be no GUI based control for this. Rather it is deemed a rarely used configuration that belongs in Expert configuration.

Tools -> Options -> Advanced: Expert Configuration

Thumbnails are not generated when RecentDocsThumbnail value is set false, the count of Thumbnails/documents listed is set by History "PickListSize"

In Expert Configuration search for "RecentDocsThumbnail" click edit to toggle true|false.  And also to not have any icons/previews search for and set "PickListSize" to 0 from its default of 25.
Comment 39 NoOp 2016-11-07 18:17:24 UTC
Created attachment 128550 [details]
LORecentdoc.png

Thumbnail icon and document filename still remains - see attached .png
If "PickListSize" is set to 0, 'File|Recent Documents' is also set to 0 so the user loses all 'recent document' references.
Comment 40 NoOp 2016-11-07 18:20:12 UTC
Sorry, forgot to add the version info:

Version: 5.2.3.3
Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
Locale: en-US (en_US); Calc: group
Comment 41 V Stuart Foote 2017-01-30 19:28:38 UTC
*** Bug 105621 has been marked as a duplicate of this bug. ***
Comment 42 Hans Gerstenkorn 2017-02-04 09:55:17 UTC
Thumbnail icon and document filename still remains like NoOp, me too, I tried it but the same result. 

Is there any possibility that I can configure my system to becom a piclist with filenames instead of thumbnails? 
Thanks for helping :-) hans


LO: Version: 5.3.0.3
Build-ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU-Threads: 4; BS-Version: Windows 6.2; UI-Render: Standard; Layout-Engine: neu; 
Aerea scheme: de-DE (de_DE); Calc: group

Microsoft Windows 10 Pro 64; Version 10.0.14393 Build 14393; Lenovo T430s and same System at DELL Vostro.