Bug 106875 - Find & Replace attribute not self-explanatory
Summary: Find & Replace attribute not self-explanatory
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL: https://help.libreoffice.org/Common/A...
Whiteboard:
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures Find-Search
  Show dependency treegraph
 
Reported: 2017-03-30 13:58 UTC by Thomas Lendo
Modified: 2017-04-05 13:05 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-03-30 13:58:19 UTC
Open Writer, go to the "Find & Replace" dialog window, open "Other options". At the bottom there is an "Attributes..." button. But I don't know what that and its content do. Where is the difference to "Format..." (which also opens a frightening window)?

Maybe the attribute list names itself can be better describe what they are doing.

For example, it was painful to find out what "Page Style" does as it was mentioned in bug 74078. Then I found https://help.libreoffice.org/Common/Attributes#Page_Style with a search engine (not with the search field in the wiki/help site) and it declares: "Finds the Break With Page Style attribute." My goodness! Why not saying exactly that instead of shortening the attribute name to "Page Style" plus creating a hidden help page that must explain what's the meaning of that attribute?!

Or "Font Posture" and "Font Weight" ...

Or "Split Paragraph" means the opposite of itself, namely "Finds the DO NOT SPLIT paragraph attribute." (emphasis by me)

Suggestions how the examples above could be named in the Attributes dialog:
- Find Break With Page Style
- Find Italic or Bold and Italic
- Find Bold or Bold and Italic
- Find Do not split paragraph
Comment 1 LibreTraining 2017-04-05 02:16:23 UTC
One of the most difficult things I have found in moving to LibreOffice is the often confusing, or ambiguous, or just plain wrong text in some of the dialogs.

And then it is near impossible to find the documentation.
I too gave up on the online web search.
The results are usually useless.
Using search engines usually works better, and finds other websites too.

The integrated help search is equally bad.
It appears there is no human enhanced indexing at all.
Common terms return nothing.
So again - off to the search engine.


Your comments are valid. 
The dialog is very confusing, and in some places just wrong.

"Font Posture" - no user is going to search for this, and it makes no sense.
Normal and Italics are both font postures.
Users may want to search for "Italics"
Or give them the option to actually search for either font posture.

"Font Weight" - does not = Bold by definition or any other measure.
Users may want to search for "Bold"
Or let them actually search by weight - text or number.

Kerning - does not = spacing (tracking) so lumping spacing and kerning in together makes no sense.

And why is this dialog so small it requires scrolling?
Whose screen would this entire list not fit on?

Does anyone here actually use this software?

Does anyone here actually talk to real users? 
(that is a rhetorical question)
Comment 2 Buovjaga 2017-04-05 04:10:49 UTC
(In reply to LibreTraining from comment #1)
> Does anyone here actually use this software?
> 
> Does anyone here actually talk to real users? 
> (that is a rhetorical question)

In addition to triaging thousands of bugs, I do use it every day at work just like my boss does. In addition I give support to a bunch of other users in meatspace.

I once asked you to join the design team. I assure you that should you join, your questions will get answered, even the rhetorical ones.
Comment 3 V Stuart Foote 2017-04-05 13:05:02 UTC
With current 5.3 release the built-in help and the on-line help provide the related articles [1-3]:

Find & Replace
Searching for Attributes
Attributes

As the actual attributes are composites (not individual settings) their description is conceptual in Technical-English. Their terseness is a requirement of restraining the panel size for labeling check-box widget elements (and tool-tips) in the GUI. The linkage from the dialog is correct.

The help articles here might be cleaned up a bit, but they provide the appropriate framework for the l10n translation effort.

In that context, edits/revisions are always welcome, but this is not a bug.

And of course, for emerging features, the Documentation team is always in need of good technical writers to incorporate content into the "published" User Guides.

=-ref-=
[1] http://opengrok.libreoffice.org/xref/help/source/text/shared/01/02100000.xhp

[2] http://opengrok.libreoffice.org/xref/help/source/text/shared/guide/find_attributes.xhp

[3] http://opengrok.libreoffice.org/xref/help/source/text/shared/01/02100200.xhp