Bug Hunting Session
Bug 106880 - PPT/PPTX files with slide transitions having specific duration are imported with wrong duration
Summary: PPT/PPTX files with slide transitions having specific duration are imported w...
Status: RESOLVED DUPLICATE of bug 115394
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:ppt, filter:pptx
Depends on:
Blocks: Slide-Transitions PPTX PPT
  Show dependency treegraph
 
Reported: 2017-03-30 18:40 UTC by Aron Budea
Modified: 2018-02-09 05:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Checkerboard, 0.75s (PPTX) (30.39 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-03-30 18:40 UTC, Aron Budea
Details
Checkerboard, 0.75s (PPT) (98.00 KB, application/vnd.ms-powerpoint)
2017-03-30 18:40 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-03-30 18:40:26 UTC
Created attachment 132288 [details]
Checkerboard, 0.75s (PPTX)

The attached PPT/PPTX files have Checkerboard slide transition with 0.75s duration.
When they are opened in LibreOffice, they are shown with 2s duration.

I'm not sure what the number depends on, a PPTX with a 1.75s-duration transition opens with 3s duration in LO, just like a 10.75s one.

The behavior might be originating from the old, predefined Slow/Medium/Fast values (in 5.1).

Observed with v5.3.0.3 / Windows 7.
Comment 1 Aron Budea 2017-03-30 18:40:59 UTC
Created attachment 132289 [details]
Checkerboard, 0.75s (PPT)
Comment 2 Aron Budea 2017-03-30 22:27:31 UTC
For checkerboard slide transition the basic transition speeds are: fast/med/slow = 0.5s/0.75s/1s.
It seems to be different for different transitions.

If the speed fits a predefined option, it's saved like this:

<p:transition spd="fast">
  <p:checker dir="vert"/>
</p:transition>


If the speed is different, it's saved like this:

<mc:AlternateContent xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006">
<mc:Choice xmlns:p14="http://schemas.microsoft.com/office/powerpoint/2010/main" Requires="p14">
  <p:transition spd="slow" p14:dur="1050">
	<p:checker dir="vert"/>
  </p:transition>
</mc:Choice>
<mc:Fallback>
  <p:transition spd="slow">
	<p:checker dir="vert"/>
  </p:transition>
</mc:Fallback>
</mc:AlternateContent>

It's fairly easy to get a list of predefined values for each of the transitions, just have to have a transition with each of the predefined durations, and switching between transitions will show the exact value in the Duration field.
Comment 3 Xisco Faulí 2017-04-04 09:02:46 UTC
Confirmed in

- Version: 5.4.0.0.alpha0+
Build ID: 6152bf9ee9b2e348dee854921a5a5db1cfc72995
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

- Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

- Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

- LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 Aron Budea 2018-02-04 00:19:28 UTC
I was wrong about this, slow/med/fast always seems to be 1/0.75/0.5 s, it's just the defaults on the UI that are different, eg. Fade is 0.7 s, while Reveal is 3.4 s.

So with an irregular default timing, the exact timing is saved together with the closest predefined timing.

Szymon is working on a very similar bug report (bug 115394), if that covers PPT as well, this can be closed as duplicate.
Comment 5 Aron Budea 2018-02-09 05:31:28 UTC
Szymon's taken care of the PPT part as well, let's close this as duplicate.

*** This bug has been marked as a duplicate of bug 115394 ***