Bug Hunting Session
Bug 115394 - FILEOPEN: slide transition times are not imported correctly
Summary: FILEOPEN: slide transition times are not imported correctly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Szymon Kłos
URL:
Whiteboard: target:6.1.0
Keywords:
: 106880 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-02 09:19 UTC by Szymon Kłos
Modified: 2018-02-10 10:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
sample presentation (30.55 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-02-02 09:19 UTC, Szymon Kłos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Szymon Kłos 2018-02-02 09:19:58 UTC
Created attachment 139521 [details]
sample presentation

1. Open attached file
2. Open transitions pane in the sidebar
3. Check presented time of transition for each slide

Results:
- two last slides have directly specified time: 0.25s and 4.25s but are imported with 1s and 3s.

Expected:
- presented time for last two slides is equal to 0.25s and 4s

This is limited by our 3 standard time values (1s, 2s, 3s), bug is present in all versions probably.

Wersja: 5.4.3.2
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU threads: 4; OS: Windows 6.2; UI render: domyślny; 
Ustawienia regionalne: pl-PL (pl_PL); Calc: group
Comment 1 Szymon Kłos 2018-02-02 10:48:41 UTC
Also first three slides have different values in MSO:
- slow 1s
- medium 0.75s
- fast 0.5s
Comment 2 Aron Budea 2018-02-04 00:15:17 UTC
Ha, I had a similar bug report (bug 106880), but I also seem to have misunderstood something about this:
On the PowerPoint UI the default timing for the different slide transitions often don't fall in any of the predefined settings, so I thought the predefined ones also depend on the transition, but no, there's only one set of predefined timings, the values you have here.

This seems to similarly affect PPTs, are you planning to take care of those as well? If so, I'll close my bug report as dupe.
Comment 3 Szymon Kłos 2018-02-05 09:13:06 UTC
As I see there are only 3 predefined values available in the PPT. I saved my PPTX file with different duration time but values were converted to the closest, standard one (I used MSO).
PPT shouldn't be a big problem to handle then, I will take a look.
Comment 4 Commit Notification 2018-02-07 09:29:07 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a8a3e6a7fee5ac23bc2155b9391ead9402211147

tdf#115394 import custom slide transition time in PPTX

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-02-07 09:29:13 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fa85592c0efba65f4a1b09fea950ec1c311bdd4c

tdf#115394 export custom transition time in PPTX

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-02-07 19:26:06 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ba9a42009a6e712aea8646956bd711afb058db24

tdf#115394 export correct slide transition time in PPT

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Aron Budea 2018-02-09 05:31:28 UTC
*** Bug 106880 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2018-02-09 06:04:15 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=df835773fa8d66a1bd534c5b374ac27552751941

tdf#115394 correct transition in case of 0s

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.