Bug Hunting Session
Bug 106994 - Text next to enlarged bullet point gets cropped when using older version of OpenSymbol
Summary: Text next to enlarged bullet point gets cropped when using older version of O...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: commit:34d7602954d4483b3bc9db700e7df2...
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Font-Rendering Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2017-04-06 15:10 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-06-07 19:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screencast (1.04 MB, video/webm)
2017-04-06 15:10 UTC, Yousuf Philips (jay) (retired)
Details
Text-to-text alignment example (12.27 KB, application/vnd.oasis.opendocument.text)
2017-04-07 14:32 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-04-06 15:10:15 UTC
Created attachment 132379 [details]
screencast

Steps:
1. Open Writer
2. Insert a bullet point and some text next to it
3. Click at bullet character and the notice the gray highlight color will appear around the bullet
4. Change the bullet font size from 12 to 32
5. Notice that the text has been cropped 

Regression as this doesnt happen in 5.2.

Version: 5.4.0.0.alpha0+
Build ID: 0c551c86f701c1f1865760e122d901c933b8fbe5
CPU threads: 2; OS: Linux 3.19; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-04-06_00:40:42
Locale: en-US (en_US.UTF-8); Calc: group

Version: 5.2.4.0.0+
Build ID: ab64ae2a828f4acd6d118abc14193c543d04b940
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-2, Time: 2016-11-07_16:55:16
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Xisco Faulí 2017-04-06 15:45:26 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: 6152bf9ee9b2e348dee854921a5a5db1cfc72995
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

nor in

Version: 5.4.0.0.alpha0+
Build ID: 156f778593ca9c57845076a88c6b544a63e12e7a
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-05_06:30:54
Locale: es-ES (es_ES); Calc: group
Comment 2 Regina Henschel 2017-04-07 14:32:46 UTC
Created attachment 132399 [details]
Text-to-text alignment example

The attachments contains a group of lines with a huge character in line, and a second group with a huge bullet. Each group has the four kinds of text-to-text alignment.

The problem is not the bullet itself, but the font "OpenSymbol". If you set the character style "Huge" to use the font "OpenSymbol", then you can notice, that the blue background does not fill the whole line height. And the other way round, if you set character style "Bullets" to use font "Liberation Serif", then the line height is increased and the text in the line no longer reaches into the next line.
Comment 3 Regina Henschel 2017-04-07 14:40:46 UTC
OK in Version: 5.2.6.2
Build ID: a3100ed2409ebf1c212f5048fbe377c281438fdc
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: de-DE (de_DE); Calc: group

Broken in Version: 5.3.0.0.beta1
Build-ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU-Threads: 4; BS-Version: Windows 6.1; UI-Render: Standard; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE); Calc: group

OK in Version: 5.3.0.0.alpha0+
Build ID: 423c67150631545b512e40d8c1e716b3ba8b6569
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-09-25_23:57:54
Locale: de-DE (de_DE); Calc: group
Comment 4 Xisco Faulí 2017-04-07 20:20:25 UTC
Regression introduced by:

author	Khaled Hosny <khaledhosny@eglug.org>	2016-11-09 13:22:43 (GMT)
committer	Khaled Hosny <khaledhosny@eglug.org>	2016-11-22 15:32:11 (GMT)
commit	34d7602954d4483b3bc9db700e7df2c15348947a (patch)
tree	8dcfb93fc29815fd89481a7840d64d6c187534db
parent	c855aec445628f96d3d32cfde6efd4e51e4489c9 (diff)
tdf#55469 Consistent line spacing across platforms

Bisected with bibisect-linux-64-5.3

Adding Cc: to Khaled Hosny
Comment 5 Khaled Hosny 2017-04-08 14:55:00 UTC
No idea what is going on, what font is used for the bullets?
Comment 6 Regina Henschel 2017-04-08 16:32:50 UTC
Khaled: OpenSymbol. I think, I have found the reason for me. I had got OpenSymbol version 102.7 installed. Now I have changed it to version 102.10. Now the text-to-text setting "baseline" (which is the default) works for OpenSymbol.

Yousuf: Can you please look what version your OpenSymbol is?
Comment 7 Khaled Hosny 2017-04-08 17:08:37 UTC
Sounds plausible, older versions of OpenSymbol had bad line spacing settings and I fixed them before introducing the new line spacing code which is sensitive to such badness. As a general rule, one should always use the version of OpenSymbol that comes with a given version of LibreOffice (I think it was a mistake to install OpenSymbol in the first place since we can load it uninstalled).
Comment 8 Yousuf Philips (jay) (retired) 2017-04-09 15:39:36 UTC
(In reply to Regina Henschel from comment #6)
> Now the text-to-text setting "baseline" (which is the default) works for
> OpenSymbol.

So does the new font work fine with older LO versions?

> Yousuf: Can you please look what version your OpenSymbol is?

My package manager has it as 102.7, which comes with Linux Mint 17.3 (Ubuntu 14.04 base), which also ships with Ubuntu 16.04 LTS.

I run daily builds by extracting the DEBs so i can run multiple versions without installation, so unfortunately it doesnt utilize the bundled fonts with it, but adding the new opensymbol font into ~/.fonts and refreshing the font cache didnt solve the issue for me. :(
Comment 9 Khaled Hosny 2017-04-09 20:32:38 UTC
(In reply to Yousuf Philips (jay) from comment #8)
> (In reply to Regina Henschel from comment #6)
> > Now the text-to-text setting "baseline" (which is the default) works for
> > OpenSymbol.
> 
> So does the new font work fine with older LO versions?

Does it matter?