Bug Hunting Session
Bug 105860 - VIEWING: line spacing is too small compared to older versions and other programs
Summary: VIEWING: line spacing is too small compared to older versions and other programs
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Font-Rendering Cell-Line-Spacing Universal-Line-Spacing
  Show dependency treegraph
 
Reported: 2017-02-08 14:34 UTC by Thomas Lendo
Modified: 2017-10-02 17:33 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Line spacing in 5.1.4.2 and 5.3.0.3 (87.55 KB, image/png)
2017-02-08 14:35 UTC, Thomas Lendo
Details
Test file made with 5.3.0.3 (14.28 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-02-08 14:38 UTC, Thomas Lendo
Details
Test file made with 5.1.4.2 (14.32 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-02-08 14:38 UTC, Thomas Lendo
Details
Second test: file made with LibO 5.3.0.3 (35.55 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-02-10 13:57 UTC, Thomas Lendo
Details
Second test: file made with Excel 2010 (9.97 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-02-10 13:59 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-02-08 14:34:16 UTC
Description:
The line spacing in Calc has changed between LibO 5.3.0.3 and previous releases (tested with 5.1.4.2).

Steps to Reproduce:
From new to old:
1. Open Calc with LibO 5.3.0.3.
2. Write text with line breaks in a cell.
3. Save it and open the file in an older LibO version.
4. The line spacing is different (bigger) and therefore the first line of the text is partially hidden.

Other direction from old to new:
1. Open Calc with LibO 5.1.4.2 or another old version.
2. Write text with line breaks in a cell.
3. Save it and open the file in LibO 5.3.0.3.
4. The line spacing is different (smaller) and therefore the first line of the text has more padding to the upper border of the cell.

Direct comparison:
1. Write text with line breaks in a cell in both LibO 5.3.0.3 and an older version.
2. Compare the documents side by side.
3. You will see that the line spacing in LibO 5.3.0.3 is much smaller than in the older version.

Actual Results:  
Line spacing differs between versions. LibO 5.3.0.3 has a much smaller spacing than older versions. The text looks crowded together and not so good readable in LibO 5.3.0.3.

Expected Results:
There should be no difference in line spacing if the same font on the same OS version is used. Maybe in the future a line spacing option should be available for the users to change it by themselves.


Reproducible: Always

User Profile Reset: Yes. The test in version 5.3.0.3 was made with a new profile.

Additional Info:
[Information automatically included from LibreOffice and me]
Locale: de
Module: SpreadsheetDocument
OS version: Windows 6.2
UI render: Standard
Layout engine: neu (new)
[Information guessed from browser]
OS is 64bit: yes
Builds ID: LibreOffice 5.3.0.3
Builds ID: LibreOffice 5.3.0.3


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Comment 1 Thomas Lendo 2017-02-08 14:35:19 UTC
Created attachment 131016 [details]
Line spacing in 5.1.4.2 and 5.3.0.3
Comment 2 Thomas Lendo 2017-02-08 14:38:12 UTC
Created attachment 131017 [details]
Test file made with 5.3.0.3
Comment 3 Thomas Lendo 2017-02-08 14:38:29 UTC
Created attachment 131018 [details]
Test file made with 5.1.4.2
Comment 4 Timur 2017-02-08 15:10:28 UTC
Nicely prepared bug report.
I don't see why this would be a bug, maybe some change from https://wiki.documentfoundation.org/ReleaseNotes/5.3. 
I'm not an expert, and I won't change the status.
Comment 5 Thomas Lendo 2017-02-09 10:16:53 UTC
Bug 55469 is mentioned at the 5.3 release notes wiki page. But I don't see why changes in Math visualization should have effected spreadsheet visualization. Is this possible? I will add Khaled Hosny to CC list, maybe he knows more about this.

Timur:
I think this is a bug because the new behavior disturb the continuity of OpenDocument file presentation. Users are rightly assuming that their files looks the same in different LibO versions (especially when NO file format changes were made as in ODF 1.0 > ODF 1.2 or DOC > ODF). Apart from that the new line spacing looks ugly (too small/crowded).
Comment 6 Xisco Faulí 2017-02-09 12:13:59 UTC
Regression introduced by:

author	Khaled Hosny <khaledhosny@eglug.org>	2016-11-09 13:22:43 (GMT)
committer	Khaled Hosny <khaledhosny@eglug.org>	2016-11-22 15:32:11 (GMT)
commit	34d7602954d4483b3bc9db700e7df2c15348947a (patch)
tree	8dcfb93fc29815fd89481a7840d64d6c187534db
parent	c855aec445628f96d3d32cfde6efd4e51e4489c9 (diff)
tdf#55469 Consistent line spacing across platforms
Comment 7 Khaled Hosny 2017-02-09 13:06:21 UTC
We were already using different spacing on Linux and Mac, so at least we are now consistent across platforms.

I don’t consider this a regression, it is by design to fix how line spacing is calculated once and for all, which fixes issues like bug 55469.

This is not a bug AFAIC, however if we think strongly about preserving backward compatibility here (including the bugs, of course) then I think a flag needs to be set somewhere for old documents and propagated to VCL that signals calculating line spacing the old way.
Comment 8 Thomas Lendo 2017-02-10 13:55:01 UTC
Khaled, thanks for your work on making spacing consistent across platforms. Overall, that's good and makes things easier in the future.

Based on your statement I would rephrase my bug report:
The line spacing is too small now (it seems that this was true in the past on Linux/Mac). Multi-line content looks crowded together and not so good readable. Other programs use line spacing that facilitates readability in a better way.
Comment 9 Thomas Lendo 2017-02-10 13:57:51 UTC
Created attachment 131075 [details]
Second test: file made with LibO 5.3.0.3
Comment 10 Thomas Lendo 2017-02-10 13:59:35 UTC
Created attachment 131076 [details]
Second test: file made with Excel 2010
Comment 11 Heiko Tietze 2017-02-26 20:54:56 UTC
(In reply to Thomas Lendo from comment #9)
> The line spacing is too small now (it seems that this was true in the past
> on Linux/Mac). 
> ..
> Created attachment 131075 [details]

Looks not bad to me. But there must not be such a difference to Excel, depending on how you create the examples. @Stuart What's your opinion?
Comment 12 Xisco Faulí 2017-03-05 21:47:59 UTC
*** Bug 106111 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2017-03-05 21:50:49 UTC
(In reply to Khaled Hosny from comment #7)
> We were already using different spacing on Linux and Mac, so at least we are
> now consistent across platforms.
> 
> I don’t consider this a regression, it is by design to fix how line spacing
> is calculated once and for all, which fixes issues like bug 55469.
> 
> This is not a bug AFAIC, however if we think strongly about preserving
> backward compatibility here (including the bugs, of course) then I think a
> flag needs to be set somewhere for old documents and propagated to VCL that
> signals calculating line spacing the old way.

After bug 106111, which is introduced by 34d7602954d4483b3bc9db700e7df2c15348947a, this can be considered a regression in my humble opinion...
Comment 14 OfficeUser 2017-03-05 22:10:22 UTC
*** Bug 106111 has been marked as a duplicate of this bug. ***
Comment 15 OfficeUser 2017-03-05 22:15:08 UTC
@Xisco: Thank you very much for the successful bibisect!

This patch makes so much trouble and must be revoked asap with effect for the next  bugfix release. Is it already revoked from the branch?
Comment 16 Thomas Lendo 2017-03-20 08:54:30 UTC
Are comment 12 to 15 obsolete for this bug?

I change the bug title from "VIEWING: line spacing different between program versions" to "VIEWING: line spacing is too small compared to older versions and other programs".
Comment 17 Yousuf Philips (jay) (retired) 2017-06-03 15:04:33 UTC
Seems bug 107249 is also linked to the same commit by Khaled, so lets link these together.

(In reply to Khaled Hosny from comment #7)
> I don’t consider this a regression, it is by design to fix how line spacing
> is calculated once and for all, which fixes issues like bug 55469.

I would consider there is a bug in the calculation if it is cropping letters from labels as mentioned in bug 107249, or do you consider this a bug in the fonts (Noto Sans, Ubuntu) themselves?
Comment 18 Heiko Tietze 2017-06-15 15:07:54 UTC
ESC decided to keep the patch with the new calculation. So this ticket is a WONTFIX and we can talk about new defaults.
Comment 19 Dale 2017-06-26 04:58:20 UTC
More details: Changing the zoom affects the line spacing - quite significantly between 100% and 110%.

This zoom effect is plainly evident in the multi-line entry of the test file provided with this bug (Comment 2) - look at the vertical fit of the row 1 text within that row as the zoom is changed.

This I believe is the same issue as described in my Bug 108710 for Writer.

Word and Excel do not exhibit this problem when viewing these files.
Comment 20 Buovjaga 2017-06-26 18:19:09 UTC
*** Bug 108710 has been marked as a duplicate of this bug. ***
Comment 21 Dale 2017-07-02 02:57:26 UTC
The problem has not been resolved.

Khaled has done good work to "fix how line spacing is calculated once and for all". I am sure he has achieved that for the issues he was dealing with.

However, his work appears to only address the rendering of text onto a page.

The problem many of us are seeing, is when the text is being rendered in abstraction - where the text is NOT being shown in the context of a physical page. In that situation there seems to be a completely different calculation being used for line spacing, and it is affected by the zoom percentage. The calculation differences become particularly noticeable when there are associated elements that are assigned a physical size e.g. row height.

THIS line-spacing calculation problem has existed for a long time, but has become worse and much more noticeable from version 5.3
Comment 22 Heiko Tietze 2017-07-02 07:54:44 UTC
(In reply to Dale from comment #21)
> The problem has not been resolved.

The OP closed this ticket as superseded by bug 108891. Please comment there.