Download it now!
Bug 108710 - Line spacing is too small in web view
Summary: Line spacing is too small in web view
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Web-Layout Paragraph-Line-Spacing Universal-Line-Spacing
  Show dependency treegraph
 
Reported: 2017-06-23 07:43 UTC by Dale
Modified: 2017-10-02 17:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Line spacing display test (16.21 KB, application/vnd.oasis.opendocument.text)
2017-06-23 07:43 UTC, Dale
Details
before and after comparison (324.54 KB, image/png)
2017-08-17 12:45 UTC, Xisco Faulí
Details
before and after comparison on Windows 7 (182.80 KB, image/png)
2017-08-17 12:50 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dale 2017-06-23 07:43:08 UTC
Created attachment 134217 [details]
Line spacing display test

In Normal View (page view), line spacing is unchanged regardless of zoom level - as expected.
In Web View, line spacing is always less than in normal view, and the spacing changes depending on the zoom level. 100% zoom is particularly bad.
This problem got much worse from version 5.3

In the example file I have added a rectangle to left of the text so that one can easily see the relative size changes between text and graphic object.
To view the problem, change zoom level while in Web View, then do the same in Normal View.
Comment 1 Dale 2017-06-26 04:43:49 UTC
This looks to be to be the same problem as reported in Bug 105860 for Calc.
Examining that Calc problem, it too exhibits the same behaviour in that 
(a) the line spacing at 100% zoom reduced in LibO 5.3.0.3 compared to previous
(b) the line spacing changes depending on the zoom
(c) 100% zoom seems to have the smallest line spacing

Depending on the document and font, the visual difference between 5.3.0.3 and previous is very obvious. A document that once had nicely spaced lines now looks cramped.
Comment 2 Buovjaga 2017-06-26 18:19:09 UTC
Ok, let's close as dupe then.

*** This bug has been marked as a duplicate of bug 105860 ***
Comment 3 Thomas Lendo 2017-07-01 21:51:53 UTC
Dale, I think zooming is another problem which is older than the 5.3 regressions. Make a search or you find a bug in https://bugs.documentfoundation.org/showdependencytree.cgi?id=107923&hide_resolved=1
Comment 4 Dale 2017-07-02 11:20:26 UTC
This bug was closed shortly after being created, marked as a duplicate of Bug 105860. That bug has been superseded by Bug 108891 - which no longer addresses the problem reported here. Therefore I am reopening this bug.
Comment 5 Dale 2017-07-02 11:37:39 UTC
Khaled Hosny has done good work to fix how line spacing is calculated - implemented in version 5.3. I am sure he has achieved that for the issues he was dealing with.

However, his work appears to only address the rendering of text onto a page.

The problem I and many Calc users are seeing appears to be in the calculation of line spacing when the text is being rendered in abstraction - where the text is NOT being shown in the context of a physical page. In that situation there seems to be a completely different calculation being used for line spacing, and it is affected by the *zoom percentage*. The calculation differences become particularly noticeable when there are associated elements that are assigned a physical size e.g. row height in a Writer table or Calc cell.

*This* line-spacing calculation problem has existed for a long time, but has become worse and much more noticeable from version 5.3
Comment 6 Buovjaga 2017-07-02 14:49:55 UTC
Confirmed.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: 98befbb26217b0bf3f35354e418a355280c52cfc
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 29th 2017
Comment 7 Xisco Faulí 2017-08-17 12:45:48 UTC
Created attachment 135621 [details]
before and after comparison

Comparison before and after commit 34d7602954d4483b3bc9db700e7df2c15348947a at 100%
Comment 8 Xisco Faulí 2017-08-17 12:46:32 UTC
The zooming problem is another issue and it's inherit from OOo.
Comment 9 Xisco Faulí 2017-08-17 12:50:26 UTC
Created attachment 135622 [details]
before and after comparison on Windows 7
Comment 10 V Stuart Foote 2017-09-06 13:20:56 UTC
Hey, with Caolán's work on bug 107249 please recheck with a current master > 20170906. Think this is also resolved now with backports in works for 5.4 and 5.3

=-ref-=

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0c8b749e602b6743857a9bc4efb24b6183690311
Comment 11 V Stuart Foote 2017-09-06 13:39:13 UTC
(In reply to V Stuart Foote from comment #10)
Just checked and with the 20170906 TB39 Windows x86 build of master, the web view holds its formatting. Does not exactly match the left rectangles, but not sure the line heights would as there are multiple roundings of text to one of the rectangle when canvas is scaled.

I'd say Resolved Fixed.
Comment 12 Xisco Faulí 2017-09-06 14:35:56 UTC
Yes, let's put it to RESOLVED FIXED

Checked in

Version: 6.0.0.0.alpha0+
Build ID: 383aab7ed63bf30931c1cf89138707d2228b5dce
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 13 Dale 2017-09-07 04:52:16 UTC
(In reply to Dale from comment #0)
> Created attachment 134217 [details]
> Line spacing display test
> 
> In Normal View (page view), line spacing is unchanged regardless of zoom
> level - as expected.
> In Web View, line spacing is always less than in normal view, and the
> spacing changes depending on the zoom level. 100% zoom is particularly bad.
> This problem got much worse from version 5.3

As the OP, I can say the problem I reported has not been fixed.

The behaviour has been restored to be very similar to what it was pre version 5.3
This is definitely an improvement.

However, the faithful, near perfect handling of scaling, line size etc that exists in normal view has not been implemented in web view.
Comment 14 Buovjaga 2017-09-07 07:24:20 UTC
(In reply to Dale from comment #13)
> As the OP, I can say the problem I reported has not been fixed.
> 
> The behaviour has been restored to be very similar to what it was pre
> version 5.3
> This is definitely an improvement.
> 
> However, the faithful, near perfect handling of scaling, line size etc that
> exists in normal view has not been implemented in web view.

In Bugzilla, we deal with one issue per report. Let's agree that this was about the regression in 5.3 and you can open a new report for the older, underlying issue.

In the new report, you don't even have to re-upload your test file: simply refer to it like this: download attachment 134217 [details] and open it.

A nice-to-have in the new report would be a comparison screenshot of normal view vs. web view.