Bug 107027 - Templates are not correctly localized
Summary: Templates are not correctly localized
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Laurent BP
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.4
Keywords:
: 107571 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-08 08:51 UTC by Laurent BP
Modified: 2017-05-03 16:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Modified template (42.61 KB, application/vnd.oasis.opendocument.presentation-template)
2017-04-08 10:26 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2017-04-08 08:51:40 UTC
Description: LibO 5.3 introduced new template chooser. Unfortunately, each template is localized in a specific language according to contributor (mostly English or German). Spell checking, autocorrection cannot directly work. User needs to modify styles of slide master.

Steps to reproduce:
In a non-German user interface:
1. Create new Impress document from template
2. In template selector, choose Bright Blue template

Actual behavior:
Language of all element is German, and no spell checking is made if German dictionary is not installed

Expected behavior:
Language of Presentation should follow User Interface Language.

Way to fix it:
Modify XML code of each template to remove language specific references.

Same occur with all templates I've tested:
- Alizarin: en-US
- Bright Blue: de-DE
- DNA: de-DE
- Focus: en-US
- Impress: de-DE
- Inspiration: de-DE
- Lush Green: de-DE
- Metropolis: de-DE
- Midnight blue: en-US
- Pencil: en-US
- Sunset: de-DE
- Vintage: de-DE
- Vivid: spanish-Argentina
Comment 1 Laurent BP 2017-04-08 10:26:22 UTC
Created attachment 132405 [details]
Modified template

Proposed new version of BrightBlue template:
- language independent
- remove grid parameters
- remove printer parameters
- remove Spanish text "número"

To test it:
- save and replace {LOInstall}/share/template/common/presnt/BrightBlue.otp
- start LibO with a new profile
Comment 2 Jacques Guilleron 2017-04-10 12:44:01 UTC
Hi Laurent,

I reproduce this behaviour with:
LO 5.3.1.1 Build ID: 72fee18f394a980128dc111963f2eefb05998eeb
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; Moteur de mise en page : nouveau; Locale : fr-FR (fr_FR); Calc: CL
and upper versions.

All templates, I confirm the found languages, have this behavour.
Trying new Brightblue from the desk, Impress opens it into the locale language, with no underscore from the spellchecker.

I will try with others languages.

Jacques
Comment 3 Commit Notification 2017-04-21 08:26:19 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=59cf94fac8e53d7f098eb2fbdf59d3a6aff254ce

tdf#107027 Remove language specific tags in templates

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2017-04-21 08:29:17 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=37b91d3f3a332ae7540c556751d39836b1f3d622&h=libreoffice-5-3

tdf#107027 Remove language specific tags in templates

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Adolfo Jayme 2017-04-21 11:48:59 UTC
I think it’d be a good idea to put up in a wiki page some instructions for future template contributors on how to edit/create them so that this issue doesn’t resurface :-)
Comment 6 Laurent BP 2017-04-22 22:28:42 UTC
(In reply to Adolfo Jayme from comment #5)
> I think it’d be a good idea to put up in a wiki page some instructions for
> future template contributors on how to edit/create them so that this issue
> doesn’t resurface :-)

done:
https://wiki.documentfoundation.org/Development/I18nTemplates
Comment 7 Laurent BP 2017-05-03 16:00:56 UTC
*** Bug 107571 has been marked as a duplicate of this bug. ***