Bug 107084 - add menubar xml stuff to notebookbar
Summary: add menubar xml stuff to notebookbar
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Groupedbar
  Show dependency treegraph
 
Reported: 2017-04-10 23:03 UTC by andreas_k
Modified: 2017-10-18 08:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
menubar drop down thing for group labels (83.77 KB, image/png)
2017-04-10 23:03 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2017-04-10 23:03:54 UTC
Created attachment 132463 [details]
menubar drop down thing for group labels

notebookbar is great and labeling the different groups is nice but can I extend the group label to something like a menubar. 

e.g. the group label file will open the same drop down menu like when you open the file section from the menubar.
Comment 1 Adolfo Jayme 2017-04-13 22:41:27 UTC
For me, it just adds busyness (Office’s ribbon is OK since it only allows a single “⇲” button there). And it’ll really get hairy unless you ensure somehow that this will work well with long translations.
Comment 2 andreas_k 2017-04-14 06:25:09 UTC
this bug report isn't for the icons right to the labels and yes I also thought only have the ⇲ button.

My bug report is for the label I'd like to have an drop down menu like in the menubar for each group label and the input of each drop down menu should be stored in an xml file. why, because I will add the menubar functionality.
Comment 3 Xisco Faulí 2017-10-17 09:07:38 UTC
Any reason why it was moved to RESOLVED FIXED? Normally the status RESOLVED FIXED is used when the commit fixing the issue is known, otherwise RESOLVED WORKSFORME should be used