Bug 107158 (Notebookbar-Groupedbar) - [META] Notebookbar Groupedbar
Summary: [META] Notebookbar Groupedbar
Status: NEW
Alias: Notebookbar-Groupedbar
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: andreas_k
URL:
Whiteboard: target:5.4.0 target:6.0.0 target: 6.1...
Keywords:
Depends on: 115469 117689 117690 118335 122235 123056 123415 123844 124258 124394 107083 107084 108146 112457 113101 114001 114296 114297 114299 114425 114496 114713 114972 115364 115484 115496 116534 117251 118351 118353 118763 118958 119734 119736 119737 120919 122154 122208 122989 124082 124392 124811 124851
Blocks: Notebookbar
  Show dependency treegraph
 
Reported: 2017-04-14 11:42 UTC by andreas_k
Modified: 2019-04-22 11:27 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
different groupedbar layouts (83.67 KB, image/png)
2017-04-14 11:42 UTC, andreas_k
Details
Screenshot for patch #2 (SAL_USE_VCLPLUGIN=gtk3) (32.16 KB, image/png)
2017-04-17 15:52 UTC, Heiko Tietze
Details
visual problems noticed (53.20 KB, image/png)
2017-04-18 03:25 UTC, Yousuf Philips (jay) (retired)
Details
Screenshot LibreOffice Draw 6.2.2.2 release (40.85 KB, image/png)
2019-03-22 21:21 UTC, renet.vol.sys
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2017-04-14 11:42:32 UTC
Created attachment 132562 [details]
different groupedbar layouts

Groupedbar full
---------------
The idea is to combine the top level structure from the main menu with grouped toolbar sections.Sections always start with one big labeled icon followed by two rows with 24px icons and labels if needed. Next to the section label a menu is placed at bottom right that provides access to less often used functions from this group. Furthermore small buttons open dialogs from the group (e.g. Paragraph settings on the Format section). The label is also a drop down menu like in the menubar.

So I have the benefit of a toolbar where you can show the main actions for different groups by one click. Advanced actions for a group via smaller icons and a group label to support orientation in the UI. With the bottom menu you get all actions for one group with two clicks.

The drawback of this solution is that 10 sections or more exceeds the common width of 1280px. Ribbons solve this problem  with tabs, I’ll do it per contextually showing sections, depending on the screen resolution. he extended grouped toolbar was designed with 1920px (full HD screen resolution) in mind, but will also work on 1280px and on 2560px Screens.

Groupedbar compact
------------------
The design is the same as for the extended grouped toolbar but with only one icon row and a second row with the group labels. For users how don’t need the section labels, those can be hidden to save even more space.

https://kdeonlinux.wordpress.com/2017/04/12/libreoffice-the-better-office/
Comment 1 V Stuart Foote 2017-04-15 14:54:27 UTC
Very MUFFIN I like it!
Comment 2 Heiko Tietze 2017-04-15 22:00:54 UTC
Why is it made for Writer only?
Comment 3 andreas_k 2017-04-15 22:05:24 UTC
because I start with writer and didn't had the time for calc, impress, ... sorry. will come. first I'd like to have feedback from writer before someone say NO and I developed to long.
Comment 4 Heiko Tietze 2017-04-17 15:44:54 UTC
Tested https://gerrit.libreoffice.org/#/c/36546/ successfully, at least it compiles when unit tests are switched off. However some observations that might not be intentionally designed:

* underlined labels of section headers are not interactive (neither gtk nor qt); either the underscore should be removed or the label have to be interactive
* strong vertical lines under gtk
* no horizontal alignment for section headers
* at least 1750px screen real estate needed (I prefer ~1200px on my FullHD res)
* no repaint at, for instance, context switch -> requires manual resizing
* transparency? issues for several items (becomes visible with SAL_USE_VCLPLUGIN=gen)
* no icon for print (breeze_dark/tango is ok), index (breeze works but not B_dark), zoom, spelling (something is shown with Breeze), table (Breeze okay); smaller button size for table => obviously the fallback is broken here
* missing vertical padding between buttons as there is some space horizontally
* section headers are not easy to discriminate from NB buttons
* "Print" button is cropped

That's for GB_full. The GB_Compact variant looks much cleaner but works differently in respect to alignment (all buttons are left aligned in contrast to the "gap" in the full version) and section headers do not look like clickable menus (not sure if that's only missing).

Good start anyway. Looks very promising.
Comment 5 Heiko Tietze 2017-04-17 15:52:54 UTC
Created attachment 132638 [details]
Screenshot for patch #2 (SAL_USE_VCLPLUGIN=gtk3)

Icons seems to be okay after restart. 

Version: 5.4.0.0.alpha0+
Build ID: 846415f0bfb0a56782e5767f3c60e2c3db29c967 (latest master + cherrypick)
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group

LXQt/Kwin/Breeze and Breeze-gtk
Comment 6 andreas_k 2017-04-17 15:59:54 UTC
(In reply to Heiko Tietze from comment #5)
> Created attachment 132638 [details]
> Screenshot for patch #2 (SAL_USE_VCLPLUGIN=gtk3)
> 
> Icons seems to be okay after restart. 

This is an issue when you use an specific icon instead of the action related icon. Issue is also available in the existing notebookbar implementations. After restart it works fine.

Thanks for your feedback will have a look at it. Hope i get the initial patch into master that i can update the ui files very easy.
Comment 7 Yousuf Philips (jay) (retired) 2017-04-18 03:25:55 UTC
Created attachment 132646 [details]
visual problems noticed

Grabbed the ui file from the gerrit patch and added it to a daily build and here is some feedback.

1. Wasnt able to view the default groups on my 1440x900 resolution, so had to move to 1080p to see everything. Space can be saved if you changed many of the GtkButtons to GtkToolButtons like page break, draw functions, bookmark, reference, etc.

2. Some groups are longer than others which is caused by the large button at the beginning of a grouop, resulting in their section labels not being aligned, so the best thing would be to have 3 rows + 1 row for the section label. For example, you could move the non-dialog opening buttons from the section label area into the button area, like cut and copy going below redo.

3. Label for print preview button was cropped

4. Padding is needed at top of each group as the top controls seem to be touching the line of the menubar

5. There was a large empty space between the paragraph and insert groups

6. Would be good to swap View and Review

7. In the paragraph group, there shouldnt be such large gaps between the alignment buttons, also you could remove the background color button and replace outline list with numbering list

8. In references group, hyperlink and footnote are more important than Index and Cross Reference

9. In view group, marks should likely be in the section label section and rulers should replace it

10. In review, thesaurus should be in the section label section and track changes should replace it

This is what i have for now, maybe i'll suggest more in the future.
Comment 8 andreas_k 2017-04-18 06:20:35 UTC
Awesome for all the feedback. I will implement whatever is usefull. The main bug i have is now that priority didn`t work in a context group, this hase to be fixed that the scaling for smaller sizes will work.
The second bug is the repainting bug.
Do someone know how to add a vertical separator that was shown on gtk and qt? Now it was only shown in windows.
Comment 9 Commit Notification 2017-04-18 09:35:58 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e7cd5953c3df5904cbcf07cc1b017cf3b7138d56

tdf#107158 Groupedbar variant of the Notebookbar for Writer

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Roman Kuznetsov 2017-05-02 19:18:16 UTC
How to back from your Groupedbar to toolbar view or display menu bar?!
Comment 11 V Stuart Foote 2017-05-02 20:05:43 UTC
(In reply to kompilainenn from comment #10)
> How to back from your Groupedbar to toolbar view or display menu bar?!

Use Toolbar Layout to take GUI out of Notebookbar mode; or use Notebookbar to set a different mode.

The "Groupedbar Compact" mode is a dead end at the moment. The "hamburger" in the Tools block on far right has no configurations, and Main Menu can not be toggled active. So presently you have to exit LO and kill the user profile to reopen with defaults.

That needs to be fixed need to be able to navigate the layouts.  Enabling the configuration controls in the "hamburger" for the compact flavor--but also by providing a toggle for the main menu (bug 107343) so there is a consistent control for moveing in and out of the MUFFIN interfaces.
Comment 12 andreas_k 2017-05-02 21:22:51 UTC
> How to back from your Groupedbar to toolbar view or display menu bar?!

Groupedbar_compact
there is a burger menu on the right (hope your screen is big enough)

Groupedbar_full
there is a burger menu drop down item called manu on the right where you can show/hide the menubar, and switch between different layouts

this work in master at my pc (linux, kde neon)
Comment 13 V Stuart Foote 2017-05-02 21:41:30 UTC
(In reply to andreas_k from comment #12)
> > How to back from your Groupedbar to toolbar view or display menu bar?!
> 
> Groupedbar_compact
> there is a burger menu on the right (hope your screen is big enough)
> 

Unfortunately, the "burger" configuration menu in the "Groupedbar Compact" layout is not functional on the 2017-05-01 build of master for Windows, a mouse over or click or right-click does nothing.

The "Groupedbar Full" is fine, and the "Menubar" Main menu toggle works there so can get back to View -> Toolbar Layout.

Version: 5.4.0.0.alpha1+
Build ID: c454fbb9b62164d5f047990ae63522c9fb932086
CPU threads: 8; OS: Windows 6.29; UI render: GL; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-05-01_04:48:39
Locale: en-US (en_US); Calc: CL
Comment 14 Roman Kuznetsov 2017-05-03 17:54:05 UTC
(In reply to V Stuart Foote from comment #13)
> (In reply to andreas_k from comment #12)
> > > How to back from your Groupedbar to toolbar view or display menu bar?!
> > 
> > Groupedbar_compact
> > there is a burger menu on the right (hope your screen is big enough)
> > 
> 
> Unfortunately, the "burger" configuration menu in the "Groupedbar Compact"
> layout is not functional on the 2017-05-01 build of master for Windows, a
> mouse over or click or right-click does nothing.
> 
> The "Groupedbar Full" is fine, and the "Menubar" Main menu toggle works
> there so can get back to View -> Toolbar Layout.
> 
> Version: 5.4.0.0.alpha1+
> Build ID: c454fbb9b62164d5f047990ae63522c9fb932086
> CPU threads: 8; OS: Windows 6.29; UI render: GL; 
> TinderBox: Win-x86@39, Branch:master, Time: 2017-05-01_04:48:39
> Locale: en-US (en_US); Calc: CL

"burger" doesn't work for both variants for me

Version: 5.4.0.0.alpha1+ (x64)
Build ID: 097bec4b78160d688f3afc7e0cd87b21aad51e4e
CPU threads: 4; OS: Windows 6.1; UI render: GL; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2017-04-30_22:03:49
Locale: ru-RU (ru_RU); Calc: CL
Comment 15 V Stuart Foote 2017-06-18 16:06:07 UTC
@Andreas, *

The Menu button (i.e. the Hamburger on the Groupedbar, just labeled Menu on the Groupedbar Compact) split button control for "Menubar" is not correctly firing the .uno:Menubar visibility toggle.

The main menubar can not be made visible from either Groupedbar UI

With current master on Windows 10 Pro 64-bit en-US
Version: 6.0.0.0.alpha0+ (x64)
Build ID: d6c4c576ef71f2294ec8eefc6576a797220e6809
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-06-18_00:32:25
Locale: en-US (en_US); Calc: CL

=-ref-=
https://gerrit.libreoffice.org/#/c/28044/
Comment 16 Commit Notification 2017-09-05 04:42:58 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=342622d51f457c5a7d5026814a323d1deece4681

tdf#107158 Groupedbar variant of the Notebookbar for Calc

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Xisco Faulí 2017-10-06 08:34:18 UTC
A polite ping to andreas_k: is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Thanks
Comment 18 Yousuf Philips (jay) (retired) 2017-10-13 20:40:45 UTC
Lets have this as a meta bug now, as it has dependent bugs.
Comment 19 Shavuah 2018-09-29 09:48:10 UTC
PDF button in Groupedbar is musthave. Please add it.
Comment 20 andreas_k 2018-09-29 19:20:04 UTC
(In reply to Shavuah from comment #19)
> PDF button in Groupedbar is musthave. Please add it.

good point I thought also about it. In general I would drop print and have there pdf instead. -> don't print save our forest. What do you think?
Comment 21 Heiko Tietze 2018-10-01 08:23:57 UTC
(In reply to andreas_k from comment #20)
> (In reply to Shavuah from comment #19)
> > PDF button in Groupedbar is musthave. Please add it.
> 
> good point I thought also about it. In general I would drop print and have
> there pdf instead. -> don't print save our forest. What do you think?

I tend to vote against "Export to PDF". The GroupedBar is meant to be as simple as possible with only the most relevant and most familiar functions. PDF export can be handled in so many ways (we talk about cross-plattform app) that it's less needed than Print. 

OTOH there are some other functions that always are shown in toolbars. Open, save, print, copy, paste etc. are not necessarily needed but it might be weird when not available. Just in case we talk also about removing Print (though no hard feeling when we do this likewise not totally scared from adding PDF export).
Comment 22 renet.vol.sys 2019-03-22 21:21:42 UTC
Created attachment 150208 [details]
Screenshot LibreOffice Draw 6.2.2.2 release
Comment 23 andreas_k 2019-03-22 21:26:02 UTC
(In reply to renet.vol.sys from comment #22)
> Created attachment 150208 [details]
> Screenshot LibreOffice Draw 6.2.2.2 release

I know it's not done. Only an emty file. Good thing it's available only in experimental.