Bug 144227 - Inconsistent method of user interface selection in Calc's Groupedbar Compact format
Summary: Inconsistent method of user interface selection in Calc's Groupedbar Compact ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.3.0
Keywords:
: 146008 (view as bug list)
Depends on:
Blocks: Notebookbar-Groupedbar
  Show dependency treegraph
 
Reported: 2021-08-31 20:22 UTC by Steve Fanning
Modified: 2021-12-03 08:12 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screen grab showing User Interface menu in Calc's Groupedbar Compact layout. (30.60 KB, image/png)
2021-08-31 20:22 UTC, Steve Fanning
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Fanning 2021-08-31 20:22:32 UTC
Created attachment 174684 [details]
Screen grab showing User Interface menu in Calc's Groupedbar Compact layout.

In most cases within Calc, user interface selection is achieved via the Select Your Preferred User Interface dialog. In the default "Standard Toolbar" user interface layout, this dialog is accessed via View > User Interface...

However, after selecting the "Groupedbar Compact" layout, Calc doesn't make the dialog avaiable but instead provides a cascading User Interface menu accessed via the Menu button on the right of the layout. This inconsistency seems unnecessary and potentially confusing for the user. (See attachment)

A big advantage of using the Select Your Preferred User Interface dialog is the description and preview of a layout before you select it. And, as often happens when the same function is implemented in two ways, the cascading menu does not offer one of the options that is available through the dialog (i.e. Contextual Single").

Please review and check whether consistency would be desirable?

My LO informtion:

Version: 7.2.0.4 (x64) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 6; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-US
Calc: CL
Comment 1 V Stuart Foote 2021-09-01 01:53:08 UTC
So you would rather see the new 'User Interface...' dialog than the cascading menu with the UI selections.

Of course at the top of the 'Menu' button for the 'Gropedbar Compact' Notebook Bar mashup you can select the 'Menubar' button to expose the Standard menu and the View -> User Interface... control to launch the dialog.
Comment 2 Heiko Tietze 2021-09-01 08:35:19 UTC
Yes, let's have uno:ToolbarModeUI where previously uno:ToolbarMode was used.m Patch in WIP (cannot edit the huge sw/... notebookbar_groupedbar_full.ui directly in Gerrit).
Comment 3 Commit Notification 2021-09-02 11:57:53 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f773e7aa8c96e070085ece95889f02590ed65f89

Resolves tdf#144227 - Default command to switch UI

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 BogdanB 2021-09-05 10:54:09 UTC
It's ok now. It's using the same option to choose the User Interface.

Verified with
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 34a9f93018804044b756e0e49c7ea759a65d3dc4
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 5 Heiko Tietze 2021-12-03 08:12:45 UTC
*** Bug 146008 has been marked as a duplicate of this bug. ***