Download it now!
Bug 120919 - Make AutoFormat Table Styles icon more visible in all UIs, move it closer to other Styles actions
Summary: Make AutoFormat Table Styles icon more visible in all UIs, move it closer to ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Main-Menu Notebookbar-Groupedbar Notebookbar-Tabbed Table-AutoFormat
  Show dependency treegraph
 
Reported: 2018-10-25 18:33 UTC by Pedro
Modified: 2018-12-18 00:34 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Where to include the icon. (504.58 KB, image/png)
2018-10-25 18:33 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2018-10-25 18:33:03 UTC
Created attachment 146010 [details]
Where to include the icon.

The Table Styles button is not visible in many of the UIs of LibreOffice Calc.
I would like to propose the following:

1 - that the icon location in the traditional UIs is changed from the Format Menu to the Styles Menu (it is about Styles after all.

2 - That the icon becomes visible in the Groupedbar Notebookbar since I could not find it anywhere.

3 - That in the TabbedBar it is moved from the Layout tab to the Home tab occupying the posision to open the Styles Sidebar.
Comment 1 Thomas Lendo 2018-10-27 21:39:53 UTC
I'm strongly against this request as AutoFormat technically has nothing to do with Styles. We want get rid of AutoFormat in other LibreOffice components (bug    113558, bug 116091).

Instead of AutoFormat we should promote cell styles (available via Sidebar).

PS: For me, the position of the requested AutoFormat command in the Groupedbar was intended to be the "Edit cell style" command as in all Notebookbars style commands are very underrepresented.
Comment 2 Pedro 2018-10-30 18:28:50 UTC
I didn't know that about AutoFormat Lendo....

However, Table Styles and Cell Styles are different things. That's why I was proposing this.
Comment 3 Pedro 2018-10-30 18:43:12 UTC
Excel offers options for Table AND Cell Styles. I would not remove AutoFormat Table Styles while a new option for Table Styles is available...
Comment 4 Thomas Lendo 2018-10-30 19:07:59 UTC
(In reply to Pedro from comment #2)
> However, Table Styles and Cell Styles are different things.
You're right. AutoFormat table styles are different from cell styles.

Nevertheless I vote against moving the command to the Style main menu as it's no classic style, strictly speaking, and not available in the sidebar and I assume it's a feature that is not so often used.

Adding it to toolbars and notebookbars is up to people that are using this command (I never needed it). My concern is the risk of confusion with cell styles.

BTW it would be cool to get rid of the AutoFormat feature and to convert it into a new "Table style" in Calc as it is underway in Writer.
Comment 5 Pedro 2018-11-09 10:38:35 UTC
Wait there are Table Styles in Writer but not in Calc??
Really? Sigh. This stuff is MORE important in Calc than Writer.
Comment 6 Pedro 2018-11-09 10:53:00 UTC
Thomas, actually there's a much superior option to Table Styles from Writer.
Table Design from Impress should be present in the Styles section and available in all modules.
It is by far the best option. I'll open a new bug about it.
Comment 7 Heiko Tietze 2018-11-09 11:33:52 UTC
Table Styles are some kind of template applied to a full table (Writer, Impress/Draw) or a selection (Calc). In the past it was done per "Autoformat" but a GSoC project allows now to have a preview of TS in Writer from the styles sidebar using the rightmost icon on top (not available in Calc). Another issue is that the new TS are different between Writer/Calc and Impress/Draw. Work is in progress to improve the situation. But there are some other issues.
Comment 8 andreas_k 2018-11-09 11:36:44 UTC
In context menu I already add table design stuff (writer and calc) in the Notebookbar I will think to better promote styles. The biggest issue is that styles work in each app different (writer, impress, ...)
Comment 9 Pedro 2018-11-09 11:46:45 UTC
I opened a new bug. Impress has an awesome feature in the Properties section of the Sidebar named Table Design that could be used in Calc and Writer as Table Styles.
Comment 10 Thomas Lendo 2018-11-30 20:43:41 UTC
What's this bug, Pedro?
Comment 11 andreas_k 2018-12-18 00:34:10 UTC
I will close this bug as long as styling is better supported for calc.