Bug Hunting Session
Bug 114001 - [UI] [NotebookBar] [Groupedbar] Functions that invoke the sidebar must be toggleable in Impress
Summary: [UI] [NotebookBar] [Groupedbar] Functions that invoke the sidebar must be tog...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Notebookbar-Groupedbar
  Show dependency treegraph
 
Reported: 2017-11-23 07:30 UTC by Bastián Díaz
Modified: 2018-06-25 21:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bastián Díaz 2017-11-23 07:30:22 UTC
Description:
Some functions available in Groupedbar (full or compact) invoke the sidebar, but to return to the previous state you have to hide the sidebar manually.

My proposal is that these functions (Slide transition, Slide layout and Animation) allow the sidebar to be toggled, similar to how "show the styles sidebar" button works in Writer (the same principle is seen in "show draw functions" even though it is related to a toolbar).

Steps to Reproduce:
1. In GroupedBar (Full or compact) select Slide transition, Slide layout or Animation button.
2. Click again.

Actual Results:  
The sidebar expands showing the selected function. When you click the button again, nothing happens.

Expected Results:
When you click on the function button the sidebar expands and when you make a second click the sidebar collapses.


Reproducible: Always


User Profile Reset: No



Additional Info:
Within the previous listing would include the "master slide" button even if it is not related to the sidebar (it would benefit other layouts such as tabbed NotebookBar).


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Heiko Tietze 2017-11-28 10:16:58 UTC
Sounds reasonable. But taking the Slide Transition as example it also means to make .uno:SlideChangeWindow a toggle function, to show a checkmark in the main menu, and to close the sidebar when this feature is unchecked. That's likely unwanted in non-Notebookbar modes. So the request is either a) a WONTFIX or b) we accept possible drawbacks for different visualizations. I tend to a) because of simplicity.
Comment 2 andreas_k 2018-06-25 21:07:04 UTC
Thanks for the bug report to give the possibility to talk about this topic.

As there are a lot of different NB implementations and at the same implementation there are different behavior I would close this bug with wantfix.

Example:
Ordinary NB give the users the possibility to use the sidebar. In Impress you NEED the sidebar for transition and some other stuff. Also draw functions would be a good example, cause first the sidebars are an big improvement for transition and draw functions have transition stuff in a horizontal toolbar is not that intuitive than in the sidebar. So from the designer point of view (groupedbar and tabbedbar NB) I tend to use the NB as much as possible, BUT if the sidebar layout is more useful, I would use the existing sidebar instead of reimplement (and maintain) a NB.