Bug 107114 - UI not shown after update to 5.3.2
Summary: UI not shown after update to 5.3.2
Status: RESOLVED DUPLICATE of bug 107166
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-12 10:11 UTC by guido.eli@treofan.com
Modified: 2017-05-02 17:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screeshot of the safe-mode startup (26.46 KB, image/png)
2017-04-12 10:11 UTC, guido.eli@treofan.com
Details

Note You need to log in before you can comment on or make changes to this bug.
Description guido.eli@treofan.com 2017-04-12 10:11:36 UTC
Created attachment 132510 [details]
screeshot of the safe-mode startup

After the update from 5.2.4 to 5.3.2 is the UI not longer shown. Most of the words and icons are gone. The program can not longer be used.
- happens also in safe-mode
- in all office parts
- without opened documents
going back to 5.2 solves the issue

All affected PC's have 
- Windows 10, 64 bit
- 4 GB RAM
- Model HP Compaq 8000 Elite SFF PC
Comment 1 Jacques Guilleron 2017-04-12 14:34:59 UTC
The translated user interface change at each mDid you download also the offline help corresponding to LO 5.3.2?
Comment 2 guido.eli@treofan.com 2017-04-12 14:56:45 UTC
No, I never install an offline help.
Comment 3 V Stuart Foote 2017-04-12 17:07:38 UTC
Please identify the GPU chip and driver. 

Are you using OpenGL rendering? Please describe effect of enabling/disabling OpenGL rendering (if supported on your GPU), and also of disabling Hardware acceleration to use just CPU rendering.
Comment 4 guido.eli@treofan.com 2017-04-20 15:35:24 UTC
The systems are "HP Compaq 8000 Elite SFF PC" with the integrated "Intel(R) Q45/Q43 Express Chipset", using the latest "Intel driver Q45/Q43 Express Chipset Graphics Driver 8.15.10.2702 for Windows 10"

The driver allows not to disable OpenGL at all, only several OpenGL features

I tried to change everything described on http://www.intel.eu/content/www/eu/en/support/graphics-drivers/000005575.html

without influence to the Libreoffice GUI. If I remove the Intel driver and went back to the "Microsoft basic driver", everything is fine. But the screen resolution/quality is too bad to stay with this driver
Comment 5 V Stuart Foote 2017-04-20 16:47:31 UTC
Suspect this will end up duplicate of bug 107166, but as this is on Windows 10, with old GMA X4500 graphics, will keep it separate for now. See also bug 107166
Comment 6 V Stuart Foote 2017-04-20 17:03:35 UTC
(In reply to guido.eli@treofan.com from comment #4)
> The systems are "HP Compaq 8000 Elite SFF PC" with the integrated "Intel(R)
> Q45/Q43 Express Chipset", using the latest "Intel driver Q45/Q43 Express
> Chipset Graphics Driver 8.15.10.2702 for Windows 10"


Please check result when you disable OpenGL rendering--restart, and then disable (uncheck) Use hardware acceleration. Both from the Tools -> Options -> View menu.

If text is not visible in the UI, the accelerators still should get you there.

F10 -> <alt>+T -> <alt>+O -> then just V, in the right hand column clear the top three check boxes.
Comment 7 V Stuart Foote 2017-04-20 17:31:25 UTC
You might also test using the Intel Q45 graphics driver 15.17.19.2869 (11/16/2012) for any improvement, Windows 7 (WDDM 1.1). 

But, note that there are no Windows 10 (WDDM 2.0) certified drivers for that GPU, so the Microsoft Basic driver is probably going to be the most stable--but limited--choice.

Issue we seem to be having with these older GPUs at 5.3.2 is with LibreOffice's move to more DirectWrite/Direct2D based rendering away from GDI based rendering.

=-ref-=

Intel Q45 WDDM 1.1 accelerated drivers
32-bit
https://downloadcenter.intel.com/download/22163

64-bit
https://downloadcenter.intel.com/download/22166
Comment 8 guido.eli@treofan.com 2017-04-21 08:28:14 UTC
LO OpenGL options
- disabling "Use OpenGL for all rendering" has no influence, the problem is still the same
- activating the second option "Ignore OpenGL blacklist" can not be saved, it's automatically removed after the LO restart. 

different drivers
- there is no other/newer driver available for Windows 10, the Win 7 drivers on the Intel page can not be installed
- a check on a Win 7 PC was okay, LO 5.3.2 starts fine with the same hardware
- the actual "Windows Basic Driver" is no option, the resolution is to bad to use needed applications

A switch "Do not use OpenGL rendering at all", to return to the old GDI rendering, seams to be the best option to solve the problem on this PC's. My VM without GL support works fine, so LO 5.3 has everything to go without OpenGL. 
Is there any way to turn the GL-usage off, or put this hardware on the OpenGL blacklist?
Comment 9 V Stuart Foote 2017-04-21 13:20:21 UTC
(In reply to guido.eli@treofan.com from comment #8)

Sorry, there are 3 "modes", each with or without anti-alaising

-- no Hardware acceleration (all unchecked, CPU does all the work)
-- with Hardware acceleration (calls to GPU are made, just not OpenGL)
-- OpenGL rendered (also hardware accelerated, using OpenGL calls)

Use of OpenGL depends on the graphics driver, but so does using Hardware acceleration.

> - activating the second option "Ignore OpenGL blacklist" can not be saved,
> it's automatically removed after the LO restart. 

The "ignore blacklist" does little more than bypass the black-list process to enable the GPUs use of OpenGL including generation of the diagnostic logs (written to /Users/<username>/AppData/Roaming/LibreOffice/4/cache) 

OpenGL *is* disabled when its check-box is cleared and LibreOffice restarted.

> A switch "Do not use OpenGL rendering at all", to return to the old GDI
> rendering, seams to be the best option to solve the problem on this PC's.

While there is no way to revert to the "old GDI" you could open Expert Configuration (Tools -> Options -> Advanced) and search for--then edit--the "TextLayoutEngine" stanza from "new" -> "old".  That might get you functional, but it is a deadend as that code will be purged at the 5.4 release.
Comment 10 V Stuart Foote 2017-05-02 17:34:45 UTC

*** This bug has been marked as a duplicate of bug 107166 ***