Download it now!
Bug 107177 - The footnote number doesn't use a small type
Summary: The footnote number doesn't use a small type
Status: RESOLVED DUPLICATE of bug 82173
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Footnote-Endnote
  Show dependency treegraph
 
Reported: 2017-04-15 07:44 UTC by ouzo
Modified: 2017-06-27 08:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of a footnote correctly displayed in Word (37.10 KB, image/png)
2017-04-15 07:45 UTC, ouzo
Details
Screenshot of a footnote in Libreoffice (38.39 KB, image/png)
2017-04-15 07:45 UTC, ouzo
Details
docx document that is displayed correctly in Word but not in Writer (27.77 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-04-15 14:12 UTC, ouzo
Details
This is a document created in Writer with the same problem (8.24 KB, application/vnd.oasis.opendocument.text)
2017-04-15 14:14 UTC, ouzo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ouzo 2017-04-15 07:44:18 UTC
Description:
When a footnote is inserted, the number of it in the note should use a small type. Instead, the normal formatting is used, which looks non-standard, ugly, and different from what generally happens in other office suites.
I have attached two screenshots, one showing some footnotes in Word, the other showing the same document in Libreoffice.

Actual Results:  
Insert a footnote or open a document with footnotes.

Expected Results:
The number of the footnote should be smaller than the rest of the text.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36
Comment 1 ouzo 2017-04-15 07:45:12 UTC
Created attachment 132580 [details]
Screenshot of a footnote correctly displayed in Word
Comment 2 ouzo 2017-04-15 07:45:39 UTC
Created attachment 132581 [details]
Screenshot of a footnote in Libreoffice
Comment 3 m.a.riosv 2017-04-15 11:59:07 UTC
Please attach a sample file with the issue.
Comment 4 ouzo 2017-04-15 14:12:07 UTC
Created attachment 132588 [details]
docx document that is displayed correctly in Word but not in Writer

This is a document that Word displays correctly while Writer doesn't. The footnote number should be displayed as a superscript, and not as a normal type.
Comment 5 ouzo 2017-04-15 14:14:27 UTC
Created attachment 132589 [details]
This is a document created in Writer with the same problem

This is a .odt document created in Writer with the same problem, to prove that the issue happens independently of the document format. It is very easy to reproduce it: just insert a footnote and the number of it will be written as a normal type and not as a superscript (as shown in the screenshot).
Comment 6 RGB 2017-04-15 14:21:43 UTC
You can very easily obtain that effect by editing the character style called "Footnote characters": on the "Position" tab select "Superscript". So this is not really a bug, it's just a matter of default options. Maybe this report should be set as an "enhancement request"?
Comment 7 ouzo 2017-04-15 14:31:41 UTC
Thanks, I will do it, when creating a document in Libreoffice.
Still, the problem remains for documents created in Office, like the one I've attached: the footnotes are displayed differently in Libreoffice.
Comment 8 ouzo 2017-04-15 14:35:04 UTC
I have tried your solution, but it is not actually functional: with it, the WHOLE footnote becomes superscript, while only the number has to.
Comment 9 ouzo 2017-04-15 14:37:01 UTC
Nevermind, I apologise, I edited the style "Footnote" and not "Footnote characters". I can confirm that this solves it. Only the issue of properly opening Word documents remains.
Comment 10 Xisco Faulí 2017-04-18 09:00:37 UTC
Hello ouzo,

Thanks for reporting the bug.
It seems to be a duplicate of bug 82173

*** This bug has been marked as a duplicate of bug 82173 ***