Bug Hunting Session
Bug 107388 - [UI] Allow users to turn off toolbar auto-hiding
Summary: [UI] Allow users to turn off toolbar auto-hiding
Status: RESOLVED DUPLICATE of bug 103240
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Toolbars
  Show dependency treegraph
 
Reported: 2017-04-24 13:54 UTC by dieweltherrschaft
Modified: 2019-09-25 13:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the missing toolbar (56.00 KB, image/png)
2017-04-24 13:55 UTC, dieweltherrschaft
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dieweltherrschaft 2017-04-24 13:54:42 UTC
Description:
Upgrading from LO 3.something to LO 5.2.6.2 and continuing to work on my Presentation with Impress, I noted how the text formatting toolbar is gone by default. Assuming it was deselected, I reselected it from the View → toolbars menu. However, it disappeared again after I clicked a textbox and then clicked somewhere else.

I note that this is intended behaviour of LO and was introduced somewhere en route from LO3 to LO5. However, I do not approve of this intended behaviour. Auto-removing the toolbar in my layout leaves a large grey area between the standard toolbar and the presentation slides which is not used for anything. This is both visually unappealing and a waste of screen real estate.
I do note that some (if not many or most) users prefer to have the text formatting toolbar free-floating rather than fixed in the layout. They obviously profit from the toolbar’s auto-hiding behaviour. To me, it is counter-productive, and a quick Google search (and searching the bug pages here) shows me I am not the only one.

A hacky work-around has been suggested on various sites: to create a custom toolbar and have it replace the text formatting toolbar. I do not like the approach because it requires additional work from my side that could be spent on the actual things I have to do.
Instead, I wish to suggest a customisation possibility: give users a checkbox for each auto-hiding toolbar, which allows them to select whether they desire the behaviour or not. I hope that this will bring together the best of both worlds: auto-hiding toolbars by default and the ability to turn off the feature if one finds it irritating.

Steps to Reproduce:
1. Select View → Toolbars → Text formatting (Toolbar shows up)
2. Click a text box
3. Click somewhere else (Toolbar disappears)

Actual Results:  
The text formatting toolbar is gone, leaving a vast grey area in the toolbar space

Expected Results:
Leave the text formatting toolbar where it is after I select an option for it to do so.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
Comment 1 dieweltherrschaft 2017-04-24 13:55:56 UTC
Created attachment 132786 [details]
Screenshot of the missing toolbar
Comment 2 Thomas Lendo 2017-04-25 09:53:19 UTC
Hi, this behavior is indeed intended so that a user can't destroy the settings and to avoid complex configuration.

I created a similar bug 106846 "CONFIGURATION: Means to make custom bars context-sensitive" but for custom (tool) bars and not for default toolbars. I will add keyword needsUXEval.
Comment 3 Maxim Monastirsky 2017-04-25 11:31:04 UTC
The old behavior was to replace the "Text Formatting" toolbar with the "Line and Filling" toolbar when leaving text edit mode. If you also enable the "Line and Filling" toolbar and dock it to the same place where the "Text Formatting" toolbar shows, they will replace one another like in LO 3.
Comment 4 dieweltherrschaft 2017-04-25 13:55:33 UTC
Turns out, if Line and Filling is set to visible they do replace each other. I didn’t find any documentation that this should actually be a replacement, not a simple turn on/off.

I’m now debating whether I should turn this into an ‘improve documentation, please’ issue. Adding whatever one might want to see from Line and Filling or Text Formatting to the respective other is much shorter and a much better hack (if it is even a hack at all) than all the other suggestions out there.
Comment 5 stefan 2017-05-12 09:05:34 UTC Comment hidden (no-value)
Comment 6 Heiko Tietze 2017-07-18 12:21:34 UTC
Setting to NEW. UX team will look into the issue.
Comment 7 Heiko Tietze 2017-07-20 12:21:31 UTC
The idea to disable context dependency for toolbars and to manually make it visible or not makes sense (and has been used in some variants of the Notebookbar). The enhancement request was reported before so this one is a duplicate.

(And Maxim explained in comment 3 how to deal with the current situation.)

*** This bug has been marked as a duplicate of bug 103240 ***
Comment 8 Sweet-Brain 2019-08-07 08:13:36 UTC Comment hidden (spam)
Comment 9 mygeekday 2019-09-25 12:29:01 UTC Comment hidden (spam)
Comment 10 mygeekday 2019-09-25 12:44:26 UTC Comment hidden (obsolete, spam)