Download it now!
Bug 107465 - EDITING: Go to next change from Changes tracking toolbar skips one change
Summary: EDITING: Go to next change from Changes tracking toolbar skips one change
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-26 23:02 UTC by Andi
Modified: 2017-05-03 13:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andi 2017-04-26 23:02:48 UTC
If two changes are one after another, a strange behavior is observed when the cursor is sitting just between both changes. A simple variant of the problem is easily reproduced this way:
a) create a document and write four words.
b) turn on Changes Tracking
c) Delete the third word and write some other word instead. Now an "addition" change should be next to an "deletion" change
d) delete the fourth word, so there is one more change after the changes that are together
e) Move the cursor to the begining of the document and select "next change" from the changes toolbar. The first change is selected
f) Accept the change. Now the cursor should be sitting in front of the second change.

  At this point the bug can be tested: the "Accept change" and "Reject change" toolbar buttons are grayed out, so we can not accept the next change. If we press the "Next change" button, the change right next to the cursor is skipped and we are taken to the final change. This behavior is particularly annoying when small changes (one-word changes, etc) are made to a document.

This was tested in 5.2.6.2 release in Debian. LibreOffice installed on Spanish (I guess it's language independent)

I hope this is clear, I can attach an example if needed
Comment 1 Buovjaga 2017-04-30 12:12:14 UTC
Not reproduced. After the grayed out phase, Next change selects the added word and does not skip it.

You might want to try with 5.3: https://wiki.documentfoundation.org/Installing_in_parallel/Linux

Arch Linux 64-bit
Version: 5.4.0.0.alpha1+
Build ID: aca48f46895811009ec90665d816ef835f0694be
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on 30th April 2017
Comment 2 Timur 2017-05-03 13:26:57 UTC
Also not reproduced, if I understood well. Report should say exactly what's expected at some step where different from observed. 
Maybe similar to Bug 84300 that is resolved on master. 
Please test in the latest development LO versions, now it's 5.3 and 5.4 master.
I recommend using Separate Install GUI tool from https://flosmind.wordpress.com/si-gui/ which downloads and extracts different LO versions, without installing.
I'll close as WFM. If you disagree, please explain and set back to Unconfirmed.
Comment 3 Timur 2017-05-03 13:32:15 UTC
I meant: not reproduced on master 5.4+ but reproduced with 5.2.6.
Since it's Linux, for arallel LO you may use Bash Script from http://pastebin.com/L6SFSYFR (just run /bin/LO-extract.sh) to Extract Parallel LO (no installation) from downloaded and unzipped LO folder with DEBS.