Bug 107584 - Background transparency not preserved over FILESAVE
Summary: Background transparency not preserved over FILESAVE
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: All All
: medium normal
Assignee: Katarina Behrens (CIB)
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.1
Keywords:
: 101340 (view as bug list)
Depends on:
Blocks: ODF-import
  Show dependency treegraph
 
Reported: 2017-05-03 10:17 UTC by chris.hoe
Modified: 2017-07-17 20:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chris.hoe 2017-05-03 10:17:24 UTC
When loading a saved DRAW or IMPRESS document, a transparency set to the background is lost (always "No transparency" after reload).
Steps to reproduce the bug:
* create an new empty Drawing or Presentation document
* right click in the new empty document and select "Page->Page Properties..."
* select a color or bitmap as background in the "Background" tab
* select a transparency in the "Transparency" tab - e.g. 90% to make the change easy to see
* "File->Save" the document, close the document and "File->Open" it again
==> Transparency is gone!

I can reproduce that bug in the DRAW and the IMPRESS component but not in WRITER - WRITER documents are keeping the transparency of the background correctly.

I guess that bug #104743 (FILESAVE: PPTX Transparent % background not exported) and bug #103489 (Transparency for slide background is not taken account of) are somehow related to this bug but as they describe other effects of what I expect to be the same problem, I decided to file a new bug - I hope that this was the right decision.
Bug #101341 describes the same problem for sure but the way it describes it leads in the wrong direction: it has nothing to do with PPTX import, it's simply the ODG/ODP file save process which fails to write the transparency property "draw:opacity" correctly (could not find in styles.xml at all...) no matter which way it was set. PPTX import is just one way to set it.

I noticed the bug in a 64bit Windows build of release 5.3.2.2 but from the other bug reports it seems that the bug is much older. Seems to be present at least since the 5.2.x releases.

Would be great if it could be fixed in one of the next releases. It looks like a simple "forgotten to save an attribute" bug and it is kind of annoying to have to re-set the transparency each time such a document is loaded.
Comment 1 Shinji Enoki 2017-05-04 06:57:26 UTC
I was reproduced it with Draw, but i was not reproduced it with Impress.


I checked in the following two versions.

OS: Debian jessie
Version: 5.3.2.2
Build ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
CPU Threads: 4; OS Version: Linux 3.16; UI Render: default; VCL: gtk2; Layout Engine: new; 
Locale: en-US (ja_JP.utf8); Calc: group

OS: Debian jessie
Version: 5.4.0.0.alpha1+
Build ID: 9632aa6372174a66c5d8789192d264fb335307b5
CPU threads: 4; OS: Linux 3.16; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-03_14:37:08
Locale: ja-JP (ja_JP.utf8); Calc: group
Comment 2 Commit Notification 2017-06-25 09:33:15 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7562c5f37ca03267da5873143601811bebf6d620

tdf#107584: Load/save page background transparency

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Katarina Behrens (CIB) 2017-06-25 09:46:19 UTC
*** Bug 101340 has been marked as a duplicate of this bug. ***
Comment 4 Katarina Behrens (CIB) 2017-07-17 08:37:56 UTC
I've cherry-picked for 5.4

Shout if anyone wants it also in 5.3
Comment 5 Commit Notification 2017-07-17 20:49:52 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d9feaf67be30e7a2aa729db93e489c61f57bb580&h=libreoffice-5-4

tdf#107584: Load/save page background transparency

It will be available in 5.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.