Bug Hunting Session
Bug 107589 - Addition of a description field to the Frame, Image and Object dialogs
Summary: Addition of a description field to the Frame, Image and Object dialogs
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Gülşah Köse
URL:
Whiteboard: target:5.5.0 target:5.4.0.1
Keywords:
: 90169 (view as bug list)
Depends on:
Blocks: Image-Dialog
  Show dependency treegraph
 
Reported: 2017-05-03 11:57 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-08-15 03:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-05-03 11:57:28 UTC
It is possible to edit the name and title (aka alternative text) of an frame, image and object but not the description within the properties dialog of these elements, so this should be added to the Options tab of these dialogs.

@muhammet, @gulsah: Do either of you have time to copy this field from the description dialog (.uno:ObjectTitleDescription) into these dialogs (.uno:FrameDialog, .uno:GraphicDialog).
Comment 1 Muhammet Kara 2017-05-05 11:18:43 UTC
(In reply to Yousuf Philips (jay) from comment #0)
> It is possible to edit the name and title (aka alternative text) of an
> frame, image and object but not the description within the properties dialog
> of these elements, so this should be added to the Options tab of these
> dialogs.
> 
> @muhammet, @gulsah: Do either of you have time to copy this field from the
> description dialog (.uno:ObjectTitleDescription) into these dialogs
> (.uno:FrameDialog, .uno:GraphicDialog).

I'll have time after the end of the next week.

--

Some code pointers for the interested ones until that time, just in case:

Frame dialog designed in: sw/uiconfig/swriter/ui/frmaddpage.ui
Implemented in: sw/source/ui/frmdlg/frmpage.cxx

Description dialog designed in: cui/uiconfig/ui/objecttitledescdialog.ui
Implemented in: cui/source/dialogs/dlgname.cxx
Comment 2 Gülşah Köse 2017-05-24 07:32:36 UTC
I will take a look at this.
Comment 3 Commit Notification 2017-05-30 06:51:13 UTC
Gulsah Kose committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=61ff1d919e317947c769e61eeda7f1bb8132f273

tdf#107589 Make description editable from Options tab.

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Yousuf Philips (jay) (retired) 2017-06-01 14:16:22 UTC
Verified

Version: 5.5.0.0.alpha0+
Build ID: b08217989558addbcaded122a4e7211ae24bbcff
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-31_06:36:03
Locale: en-US (en_US.UTF-8); Calc: group
Comment 5 Commit Notification 2017-06-01 14:31:36 UTC
Gulsah Kose committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=509029dd9583a4b3328ad72b91054ff8b54d5535&h=libreoffice-5-4

tdf#107589 Make description editable from Options tab.

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Yousuf Philips (jay) (retired) 2017-08-14 09:43:59 UTC
*** Bug 90169 has been marked as a duplicate of this bug. ***
Comment 7 Yousuf Philips (jay) (retired) 2017-08-15 03:34:43 UTC Comment hidden (obsolete)