Download it now!
Bug 90169 - DIALOG: field Description should be available in dialog Image
Summary: DIALOG: field Description should be available in dialog Image
Status: RESOLVED DUPLICATE of bug 107589
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Image-Dialog
  Show dependency treegraph
 
Reported: 2015-03-23 08:50 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-08-15 03:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-03-23 08:50:19 UTC
Presently you need to open Format > Object > Description... in order to get access to the description field, though the title field in the same dialog is accessible in the options tab of the image dialog. So it would be ideal to also include the description field in the same options tab.
Comment 1 Cor Nouws 2015-03-23 09:36:21 UTC
Hi Jay,

in dialog Image, on tab Options,
the field 'Alternative (text only)' (Alternative? looking at Dutch version ATM)
is the same as Format > Object > Description.
The latter dialog is directly related to accessibility and probably the same for all kind of objects?
Comment 2 Cor Nouws 2015-03-23 09:37:08 UTC
(In reply to Cor Nouws from comment #1)
> is the same as Format > Object > Description.

  Format > Object > Description .. Title
Comment 3 Yousuf Philips (jay) (retired) 2015-03-23 09:58:57 UTC
Hey Cor,

The description dialog contains two fields, title and description, and in the image dialog only the title field is included as 'alternative text', but the description field isnt, which is why i'm asking that the description field also be added. :D
Comment 4 Cor Nouws 2015-03-23 10:16:01 UTC
Ah, now I read your initial description properly. Good :)
Comment 5 Robinson Tryon (qubit) 2016-08-25 05:26:59 UTC Comment hidden (obsolete)
Comment 6 Yousuf Philips (jay) (retired) 2017-08-14 09:43:59 UTC

*** This bug has been marked as a duplicate of bug 107589 ***
Comment 7 Heiko Tietze 2017-08-14 09:47:55 UTC
Format > Description (since 5.4) leads to the dialog which allows to set title and description. Format > Image > Properties contains of a tab options that holds name, alternative (text only), and description. 

> So it would be ideal to also include the description field in the same options tab.

This works for me, no idea if it was fixed.

However I see room for improvements for the text and suggest to change 'Alternative (Text only)' into 'Title'.

Furthermore I'd remove the description dialog as we have everything in the properties dialog. However, there is no such properties dialog in Impress nor we have it for other objects like shapes. So the alternative is to have the title/description in the position/size dialog (and call it properties).
Comment 8 Yousuf Philips (jay) (retired) 2017-08-15 03:34:43 UTC
(In reply to Heiko Tietze from comment #7)
> This works for me, no idea if it was fixed.

Yes it was already fixed which is why i already set it to be a duplicate.

> However I see room for improvements for the text and suggest to change
> 'Alternative (Text only)' into 'Title'.

Please open a new bug report for this and CC stuart so to make sure we get an appropriate label that is suitable for a11y.

> Furthermore I'd remove the description dialog as we have everything in the
> properties dialog. However, there is no such properties dialog in Impress
> nor we have it for other objects like shapes. So the alternative is to have
> the title/description in the position/size dialog (and call it properties).

See bug 96355.

*** This bug has been marked as a duplicate of bug 107589 ***