Download it now!
Bug 107662 - Firebird: Attempt to reclose a closed cursor when inserting table from Calc by copy/insert
Summary: Firebird: Attempt to reclose a closed cursor when inserting table from Calc b...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paste Database-Tables
  Show dependency treegraph
 
Reported: 2017-05-06 16:41 UTC by Helmut Leininger
Modified: 2019-01-06 08:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Leininger 2017-05-06 16:41:04 UTC
When trying to import (create a table) by copying data from Calc and inserting them to Base an error is issued:

firebird_sdbc error:
*Attempt to reclose a closed cursor caused by 'isc_dsql_free_statement: close cursor'

If this error is accepted, the resulting tale is left empty.
If this  error is ignored, then only every second row (from Calc) is inserted into  the table. The other rows are lost.
Comment 1 Buovjaga 2017-05-07 15:59:56 UTC
Repro.

Steps:
1. In Calc, input some data, a, b, c, 1, 2, 3. Copy it.
2. Create new Firebird db
3. Being in the Tables view, just hit paste
4. Select create, yes to primary key

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha1+
Build ID: 6e4cba99bb35e6697b94309eedd1a08ebea2dc68
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on May 5th 2016
Comment 2 Robert Großkopf 2018-01-05 15:34:07 UTC
Isn't this the same bug?
https://bugs.documentfoundation.org/show_bug.cgi?id=114711
Comment 3 QA Administrators 2019-01-06 04:19:35 UTC Comment hidden (obsolete)
Comment 4 Helmut Leininger 2019-01-06 08:03:14 UTC
Version: 6.2.0.1 (x64)
Build-ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-AT (de_AT); UI-Sprache: de-DE
Calc: threaded