Bug 114711 - produces an error (code 1) if I copy an paste a table in firebird (base)
Summary: produces an error (code 1) if I copy an paste a table in firebird (base)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-27 11:45 UTC by dieter.reiser@aon.at
Modified: 2018-01-08 19:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
a base-document with firebird, 2 tables, the second, a copy of the first, is empty. (3.06 KB, application/vnd.oasis.opendocument.database)
2018-01-08 19:24 UTC, dieter.reiser@aon.at
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dieter.reiser@aon.at 2017-12-27 11:45:40 UTC
Description:
*****
Fehlercode: 1

firebird_sdbc error:
*Attempt to reclose a closed cursor
caused by
'isc_dsql_free_statement: close cursor'
*****
Only every 2nd line will be copied if I accept the error and go on.


Steps to Reproduce:
1. Open LibreOffice Base
2. Create a table with firebird and more than 3 lines
3. Save it, copy it, insert it in the same window

Actual Results:  
The result is the error-message, described above.

Expected Results:
If I accept the error-message -> the new table will not be created. If I ignore it -> the new table will be created, but only every 2nd line.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
There should be created a new table (i.e.: "table1") with exactly the same content. I tested this in LibreOffice 6RC1 too, with the same result.

By use of secure-mode (LibreOffice) there came an error-message:
*****
SQL-Status: HY000

Die Verbindung zur externen Datenquelle konnte nicht hergestellt werden. Es wurde kein SDBC-Treiber für die URL 'sdbc:embedded:firebird' gefunden.
*****
in english: It was not possible to connect to the extern data source. No SCBC-driver was found for URL 'sdbc:embedded: firebird'

OpenGL is not possible to enable


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Comment 1 Julien Nabet 2017-12-27 19:01:56 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this.

Here the steps I tried:
- created a brand new file with a table with 2 columns:
id : Integer
describ : Varchar

- inserted 3 lines.

- On main window (the one which shows the 3 panels: "Database", "Tasks" and "Tables", I right-clicked on the brand new table, then selected "Copy".

- Right-clicked and selected "Paste"
=> a dialog box appearead

- I clicked on "Create"
=> A new table has been created and it contained the same lines.

Could you attach an example file?
Comment 2 Julien Nabet 2017-12-30 18:56:12 UTC
Let's put this one to NEW since it's been reproduced with tdf#114755
Comment 3 Terrence Enger 2018-01-01 15:08:42 UTC
I observe the problem fixed in daily Linux dbgutil bibisect repository
2018-01-01.  I am setting status VERIFIED FIXED.

The program also copied a table with 4 rows without problem.  So,
tdf#114755 seems to be fixed as well.

Thank you, Julien.
Comment 4 Terrence Enger 2018-01-01 15:09:48 UTC
Sorry, wrong bug report.
Comment 5 Julien Nabet 2018-01-02 08:46:47 UTC
It should be fixed in future 6.1.0 with the following Tamas' patches:
- https://cgit.freedesktop.org/libreoffice/core/commit/?id=9585521c28b74dec36522a6501ca670b8e14c7ca
- https://cgit.freedesktop.org/libreoffice/core/commit/?id=032a3e3713af3e308229bd8e1ada17d6d24072f3

Tamas/Lionel: would it be ok to backport the patches concerning tdf#70425 on 6.0 branch?
Comment 6 Tamas Bunth 2018-01-05 15:59:34 UTC
(In reply to Julien Nabet from comment #5)
> It should be fixed in future 6.1.0 with the following Tamas' patches:
> -
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=9585521c28b74dec36522a6501ca670b8e14c7ca
> -
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=032a3e3713af3e308229bd8e1ada17d6d24072f3
> 
> Tamas/Lionel: would it be ok to backport the patches concerning tdf#70425 on
> 6.0 branch?

I put these lines back and made it output a warning (instead of an error) with this commit:

032a3e3713af3e308229bd8e1ada17d6d24072f3

It indicates that something is wrong in the background. I would rather find the actual problem before backporting anywhere. But if you want, then pick the above commit as well.

I would gladly look at it, but there is a surprisingly time-consuming degree exam waiting for me. :)
Comment 7 dieter.reiser@aon.at 2018-01-08 19:24:06 UTC
Created attachment 138984 [details]
a base-document with firebird, 2 tables, the second, a copy of the first, is empty.
Comment 8 Julien Nabet 2018-01-08 19:52:08 UTC
(In reply to dieter.reiser@aon.at from comment #7)
> Created attachment 138984 [details]
> a base-document with firebird, 2 tables, the second, a copy of the first, is
> empty.

It's fixed on master (future 6.1.0) and the patch is on review for 6.0 branch.
So if you don't use a recent build from master, it's normal you reproduce the problem.