Download it now!
Bug 107672 - EDITING: Pressing 'Delete' only deletes table contents - unless other elements selected
Summary: EDITING: Pressing 'Delete' only deletes table contents - unless other element...
Status: RESOLVED DUPLICATE of bug 78326
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-07 10:04 UTC by Eyal Rozenberg
Modified: 2018-02-01 07:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2017-05-07 10:04:41 UTC
I occasionally work with tables in Impress (and sometimes Draw).

When I select a table (e.g. selection rectangle around the table), and press the 'Delete' key - all the cells get cleared, but the table is not deleted. Pressing Delete again doesn't help.

This is already, I believe, a bug (and it is certainly inconsistent with the behavior of other objects on a slide).

If I select an additional object/element on the slide, however, and then press the Delete key - both elements get properly deleted. This is an additional inconsistency. It does not make sense that adding _more_ elements to a selection causes _less_ elements to remain from that selection after a keypress.
Comment 1 Eyal Rozenberg 2017-05-07 10:05:35 UTC
I don't think is very version-specific or platform-specific, but just in case:

I'm using LO 5.3.2.2 on Linux Mint 18.1, on an x86_64 machine.
Comment 2 Buovjaga 2017-05-07 16:16:34 UTC

*** This bug has been marked as a duplicate of bug 90518 ***
Comment 3 Buovjaga 2018-02-01 07:17:35 UTC

*** This bug has been marked as a duplicate of bug 78326 ***