Bug 107820 - FORMATTING: Load styles from another document or template is not working
Summary: FORMATTING: Load styles from another document or template is not working
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Styles Styles-Load
  Show dependency treegraph
 
Reported: 2017-05-13 13:40 UTC by Wagner Schalch Mendes
Modified: 2020-12-28 10:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example document (23.89 KB, application/vnd.oasis.opendocument.text)
2017-05-14 12:59 UTC, Wagner Schalch Mendes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wagner Schalch Mendes 2017-05-13 13:40:40 UTC
I have a template file from which I would like to load the styles into a document of mine. It is not working as I expected. For instance, in the template file I have the title styles (Title 1, Title 2, etc) and they have an specific formatting. The document I'm working on has the same styles (same names), but with different formatting (bold, numbering, etc). When I load the styles from the template with the 'Substitute' flag checked, I do notice little change in the styles, like spacing or other minor things. However, the numbering part, which is what I really want, is not updated.

Thanks for the support
Best regards
Wagner
Comment 1 Terrence Enger 2017-05-13 18:19:12 UTC
Wagner,

Thank you for taking the time to help us improve LibreOffice.

This bug looks to me like it could be the same as bug 76526.  If you
think your problem is different, please set the status back to
UNCONFIRMED.

Terry.

*** This bug has been marked as a duplicate of bug 76526 ***
Comment 2 Wagner Schalch Mendes 2017-05-13 18:41:12 UTC
The previously duplicating bug seems to be fixed and the problems reported there don't happen when check boxes of the 'Load Style' dialog window are checked.
In my case, I'm using version 5.2.6.2, I'm using all check boxes checked and the problem seems a little bit diferente.
In the document I was working on, I had na style named "Título 5", which was not configured to have numberings. On the template I had, this stype was properly configured to have numberings at level 5.
When I loaded the styles from the template to the document I was working on, nothing happened. The style "Título 5" remained exactly as it was, meaning, without numberings.
So, I'm putting the bug back to UNCONFIRMED for further analysis.
Comment 3 Buovjaga 2017-05-14 12:06:52 UTC
Ok, we need an example document.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 4 Wagner Schalch Mendes 2017-05-14 12:59:46 UTC
Created attachment 133311 [details]
Example document

Example document with some styles for titles.
Comment 5 Wagner Schalch Mendes 2017-05-14 13:01:15 UTC
1) Make a copy of the attached document.
2) In this copy, change the style 'Título 5' (under style 'Título'), so it has numberings at level 5.
3) In the original document, replace the styles by the ones coming from the copy of the document.
4) Check that 'Título 5' style has not been updated accordingly.
Comment 6 Buovjaga 2017-05-14 13:10:42 UTC
Reproduced.

Título == Heading

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha1+
Build ID: c0968aa4673a8ac9a8a09a0e291b58b94bdbb35e
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on May 13th 2016

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 7 QA Administrators 2018-06-08 02:47:43 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2020-06-08 03:45:51 UTC Comment hidden (obsolete)
Comment 9 sdc.blanco 2020-12-28 10:44:22 UTC
Closing as Worksforme  -- Reopen if still a problem.

Steps to show that it works.

1.  Open attachment 133311 [details] 
2.  (F11 - for Styles sidebar), Modify Heading 5, choose Outline & Numbering tab, then change Outline Level to Level 5.
3.  File - Templates - Save as Template  (free choice of category).
4.  Open new attachment 133311 [details]
5.  Choose "Styles-Load Styles"
6.  Select the template that you just saved, and make sure that "Text" and "Overwrite" are checked in dialog box.

Result:  Outline Level in Heading 5 is updated to Outline Level 5.

As I understand, this "result" was expected in OP, but was not happening.  But now it works.  Therefore closing as WFM.

Tested with:

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 4041c68ea59181f1c4774c356809066d2051db41
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Locale: da-DK (en_DK); UI: en-US
Calc: threaded