Bug 76526 - [writer] loading styles from file corrupts existing styles
Summary: [writer] loading styles from file corrupts existing styles
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Styles Styles-Load
  Show dependency treegraph
 
Reported: 2014-03-23 18:58 UTC by Milos Sramek
Modified: 2020-12-28 11:05 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test file (45.89 KB, application/vnd.oasis.opendocument.text)
2014-03-23 18:58 UTC, Milos Sramek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milos Sramek 2014-03-23 18:58:07 UTC
Created attachment 96252 [details]
test file

Hi,

I observe that existing styles are corrupted when loading styles by "Styles and Formating > Load Styles > From file"

Case 1:
To repeat:
- Open the attached file - it contains both a bulleted and a numbered list
- load styles from the same file by "Styles and Formating > Load Styles > From file" (Check Overwrite). Two of three bulleted items loose their bullets, all numbered items loose the numbers. Styles of these items do not change, so I think that the styles themselves were broken.


Case 2:
- Create a new document from the default template (may be empty)
- Open the attached file and check style OOoHeading2 of the green heading - its Outline & numbering > Outline level is "Level 2"
- load styles from the new file by "Styles and Formating > Load Styles > From file
- check now the style OOoHeading2 of the green heading - its Outline & numbering > Outline level has changed to "Body text". The same happens with other OOoHeading styles. 
In this case, since the new file does not contain the OOoheading2 style I would expect that this style it remains unchanged after loading style from there.

The problem is present in LO40, LO41, LO42 and Apache OO 3.4 and AOO 4.0

--
milos
Comment 1 Thomas Hackert 2014-04-21 14:38:23 UTC
Hello Milos, *,
thanks for reporting this bug :) I can confirm your bug with LO Version: 4.1.5.3
Build-ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24 (with Germanophone lang- as well as helppack), Version: 4.1.6.1 Build ID: a59ce81388f477fc89db57f0c27f222f31884eb, Version: 4.2.3.3 Build-ID: 882f8a0a489bc99a9e60c7905a60226254cb6ff0, Version: 4.2.4.1 Build ID: d4c441391e20647b3d2e8dde4d20aa868e77e515 (the last three parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel, and with Germanophone lang- as well as helppack) and LO Version: 4.3.0.0.alpha1+ Build ID: 58fdcd262bf3476b6917c71e76ca6e49d0978c5f
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-04-20_23:10:06 (also parallel installed, but this one with en_US lang- as well as helppack) on Debian Testing i686 ... :( As I can reproduce it on an older version of LO 4.2.2.1, I will change the version adequately. And as I am using a 32 bit system, I will also change the platform entry to all ... ;)
HTH
Thomas.
Comment 2 QA Administrators 2015-06-08 14:41:25 UTC Comment hidden (obsolete)
Comment 3 Milos Sramek 2015-06-09 10:22:17 UTC
Hi,
the bug according to Case 1 is still present in 4.4.3.2 and 5.0.0.0
I cannot however confirm Case 2 - "Level 2" remains there even for older versions LO 4.0 4.2 and 4.4. So, this information was probably not correct when reporting the bug)

The bug is present in OOo33
--
milos
Comment 4 QA Administrators 2016-09-20 10:00:17 UTC Comment hidden (obsolete)
Comment 5 Milos Sramek 2016-09-25 20:21:47 UTC
Hi,

I confirm Case 1 in Version: 5.3.0.0.alpha0+ but I cannot repeat the problem described in Case 2.

Additional comments to Case 1: The problem occurs only if Numbering is unchecked in the Load Styles dialog. If it is checked, no problem occurs. However, according to the help, numbering styles should be loaded if "Numbering" is checked, so the styles should not change if not checked.

There seems to be a similar problem also with the Text checkbox. Works if checked. If unchecked (nothing checked except Overwrite), I expect that nothing changes on style loadin. However, the whole file is loaded, even the text.

Milos
Comment 6 Terrence Enger 2017-05-13 18:19:12 UTC
*** Bug 107820 has been marked as a duplicate of this bug. ***
Comment 7 QA Administrators 2018-06-08 02:47:48 UTC Comment hidden (obsolete)
Comment 8 Mike 2020-05-31 06:46:11 UTC
Seems fixed IMHO

Case 1:

Can't repro.

I followed the instructions, applied the style and nothing happened. There was quite some bug fixing with bullets and numberings in the last releases, so maybe it's fixed.

Case 2:

Can't repro.

I imported the style OOoHeading2 into the new file and its outline level is 2.

The reporter himself and another forum member could not reproduce case 2 after the original posting - Maybe it was fixed shortly after creating the report?

Version: 7.0.0.0.beta1+ (x64)
Build ID: 94c217984e456196047ce41096d4a6f05bf66382
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc: threaded
Comment 9 sdc.blanco 2020-12-28 11:05:02 UTC
Cannot repro Case 1 and Case 2  (or in positive terms, using Load Styles results in the expected behavior in relation to the two cases).

Tested with: 

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 4041c68ea59181f1c4774c356809066d2051db41
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Locale: da-DK (en_DK); UI: en-US
Calc: threaded

Based on this test and the test in comment 8, closing as WORKSFORME

(if there are still problems, then reopen and gives steps to show the problem)