Bug 107867 - Crash when working with form
Summary: Crash when working with form
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha1+
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.5
Keywords: haveBacktrace
Depends on:
Blocks: Form-Controls
  Show dependency treegraph
 
Reported: 2017-05-15 13:37 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-11-29 09:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
5.4 backtrace (42.66 KB, text/x-log)
2017-05-15 13:37 UTC, Yousuf Philips (jay) (retired)
Details
screencast (2.03 MB, video/ogg)
2017-05-21 18:27 UTC, Xisco Faulí
Details
object is defunctional backtrace (19.21 KB, text/x-log)
2017-05-21 20:40 UTC, Xisco Faulí
Details
gdb bt (17.91 KB, text/plain)
2018-06-02 22:33 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-05-15 13:37:05 UTC
Created attachment 133333 [details]
5.4 backtrace

Steps:
1) Open attachment 133321 [details]
2) Add data to the various fields
3) Enable Edit > Design Mode and then adjust the various field sizes
4) Disbale Edit > Design Mode and repeat steps 2, 3, 4
5) It will crash sometimes when enabling or disabling design mode

Got it to crash with a 5.3 release build, but it didnt fully crash and halted my session by disabling the use of my mouse, so i manually killed the process and when i launched it again, it didnt give me the option to send a crash report. :(

Version: 5.4.0.0.alpha1+
Build ID: b82c9439287f58a02a2b42d737fcf110fbfb1244
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-14_01:01:26
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Buovjaga 2017-05-19 16:57:03 UTC
Tried multiple cycles, also with gtk2 VCL backend, but could not get it to crash.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.5.0.0.alpha0+
Build ID: cee02e81cd3b55fb46eacf5db5713e8bf4363bcd
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on May 19th 2017
Comment 2 Xisco Faulí 2017-05-21 18:16:47 UTC
Testing with

Version: 5.3.3.2
Build ID: 1:5.3.3~rc2-0ubuntu0.16.10.1~lo0
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

I got the error: 'object is defunctional' when I resize the forms many times... I'll try to create a video.
@Jay, did you get the same error message?
Comment 3 Yousuf Philips (jay) (retired) 2017-05-21 18:20:20 UTC
(In reply to Xisco Faulí from comment #2)
> I got the error: 'object is defunctional' when I resize the forms many
> times... I'll try to create a video.
> @Jay, did you get the same error message?

Nope no error, just crash.
Comment 4 Xisco Faulí 2017-05-21 18:27:38 UTC
Created attachment 133439 [details]
screencast
Comment 5 Xisco Faulí 2017-05-21 20:40:38 UTC
Created attachment 133441 [details]
object is defunctional backtrace
Comment 6 QA Administrators 2018-05-22 02:34:28 UTC Comment hidden (obsolete)
Comment 7 Julien Nabet 2018-06-02 22:33:22 UTC
Created attachment 142489 [details]
gdb bt

On pc Debian x86-64 with master sources updated today, I got an assert.
Comment 8 Julien Nabet 2018-06-02 22:35:03 UTC
Eike: concerning bt, I "git-searched" sKeyword[eType] and found this old commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=9b419039d9d967ab0d15d1142b27d24851baebeb
thought you might have some opinion here.
Comment 9 Eike Rathke 2018-06-04 15:14:35 UTC
I doubt that is related to the original problem, which nowhere has some number formatter stuff in the backtrace but loads of accessibility things. This latest "crash" here is an assert() in a debug build (which I'll investigate anyway, apparently an attempt to copy one more character than there are in rStr, which should do no harm in non-debug because that should be the terminating 0-char).
Comment 10 Commit Notification 2018-06-04 20:31:30 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bfe6e9ecb18e8a3d9da368a1eb48e807ab9041cf

Handle English vs locale's General keyword, tdf#33689 follow-up, tdf#107867

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2018-06-04 21:37:40 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b75110c87e24d972c98edcb9af91866a41cf1b56&h=libreoffice-6-1

Handle English vs locale's General keyword, tdf#33689 follow-up, tdf#107867

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2018-06-07 12:08:06 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b203abbc50e57105bca654d024b30f7fff129456&h=libreoffice-6-0

Handle English vs locale's General keyword, tdf#33689 follow-up, tdf#107867

It will be available in 6.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2018-06-18 10:22:39 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-0-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=14d7816072104eac67fa9c09915c7803067b7877&h=libreoffice-6-0-5

Handle English vs locale's General keyword, tdf#33689 follow-up, tdf#107867

It will be available in 6.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Julien Nabet 2018-06-24 09:31:27 UTC
Just for info, I don't reproduce the assert.

Any update with 6.0.5?
Comment 15 Buovjaga 2018-06-24 09:37:12 UTC
Let's not risk oblivion through NEEDINFO.
Comment 16 Xisco Faulí 2018-06-24 15:33:46 UTC
@Eike, should it be closed as RESOLVED FIXED instead?
Comment 17 Eike Rathke 2018-06-25 17:29:55 UTC
I've done nothing for/against the originally reported crash, just the assert() abortion mentioned in comment 7.
Comment 18 yuchun 2018-11-29 09:01:26 UTC
Bug not reproducible in version.

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Calc: threaded