Download it now!
Bug 107893 - EDITING: Not able to re-add a textbox into a shape after a undo
Summary: EDITING: Not able to re-add a textbox into a shape after a undo
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha1+
Hardware: All All
: lowest trivial
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: target:7.1.0
Keywords:
: 129320 (view as bug list)
Depends on:
Blocks: Undo-Redo Shape-Textbox
  Show dependency treegraph
 
Reported: 2017-05-16 13:21 UTC by Telesto
Modified: 2020-10-06 13:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (8.96 KB, application/odt)
2017-05-16 13:21 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-05-16 13:21:43 UTC
Description:
It isn't possible to re-add a textbox after undoing.

Steps to Reproduce:
1. Open the attached file
2. Add a textbox into the shape: right click the shape -> Add text box
3. Undo the adding of the textbox (CTRL+Z)
4. Re-add the textbox by right clicking the shape -> Add text box

Actual Results:  
The textbox won't appear (again)

Expected Results:
The textbox should appear


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.4.0.0.alpha1+
Build ID: 8c0be54a7da6262dffe04357121814dd22b5d7fe
CPU threads: 4; OS: Windows 6.2; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-05-15_01:35:45
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-05-16 13:21:57 UTC
Created attachment 133360 [details]
Example file
Comment 2 Xisco Faulí 2017-05-16 14:37:53 UTC
Confirmed in

Version: 5.4.0.0.alpha1+
Build ID: 74d2e606fd3605fe0a585f596eaa215ae4e20d18
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: fo-FO (ca_ES.UTF-8); Calc: group
Comment 3 QA Administrators 2018-05-17 02:32:48 UTC Comment hidden (obsolete)
Comment 4 Dieter 2019-12-11 06:54:48 UTC
*** Bug 129320 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2020-10-06 06:32:03 UTC
Attila Bakos (NISZ) committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e2a2165f27d2e5f9b6ac2d349e8b588921667ba4

tdf#107893 sw: fix broken "Add Text Box" after Undo

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.