Bug Hunting Session
Bug 108089 - Writer does not have a "insert signature line"
Summary: Writer does not have a "insert signature line"
Status: RESOLVED DUPLICATE of bug 83877
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-25 18:17 UTC by Rodrigo Zimmermann
Modified: 2017-12-12 12:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Insert Signature Line in Microsoft Word 2010 (61.11 KB, image/png)
2017-05-26 11:15 UTC, Rodrigo Zimmermann
Details
Siganture Line MsWord English (40.57 KB, image/png)
2017-05-28 09:10 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rodrigo Zimmermann 2017-05-25 18:17:03 UTC
In Microsoft Word, there is a feature called "insert signature line" that includes a placeholder for signature.

In Writer, you must reserve space manually using the _ (underline) character.

The idea is to implement this feature in Insert -> Signature Line.
Comment 1 Rodrigo Zimmermann 2017-05-25 18:17:31 UTC
Occasionally, this feature can be deployed across all suite applications.
Comment 2 Cor Nouws 2017-05-25 18:53:42 UTC
Hi Rodrigo,

Can you please submit a picture/example of what you mean?

Thanks,
Cor
Comment 3 Rodrigo Zimmermann 2017-05-26 11:15:18 UTC
Created attachment 133615 [details]
Insert Signature Line in Microsoft Word 2010
Comment 4 Cor Nouws 2017-05-28 09:10:22 UTC
Created attachment 133665 [details]
Siganture Line MsWord English

thanks - found the same now indeed.
It is a basic feature, that can be combined with third party digital signing software.
Did you look as File > Digital Signatures in LibreOffice, and what that can offer?
Comment 5 Rodrigo Zimmermann 2017-05-29 11:21:51 UTC
You can not insert signature line as in Word Ms. 
It is necessary that you have a certificate, whereas in MS Word this is not necessary. What I want is the feature of drawing the line in the document without having to be done manually, not the digital certification (already exists in LibreOffice).
Comment 6 Cor Nouws 2017-05-29 19:52:50 UTC
(In reply to Rodrigo Zimmermann from comment #5)
> You can not insert signature line as in Word Ms. 
> It is necessary that you have a certificate, whereas in MS Word this is not
> necessary. What I want is the feature of drawing the line in the document
> without having to be done manually, not the digital certification (already
> exists in LibreOffice).

That looks just as a line with an X and the name & function below.
From what I remember, combined with a third party application, the cross is replaced by a picture of a signature, that also changes if the document is changed, to show the signature is no longer valid.

But for the line and cross and name, would a text block (Autotext) be helpful?
Comment 7 Cor Nouws 2017-05-29 19:53:18 UTC
let me add UX-advise as CC too.
Comment 8 Rodrigo Zimmermann 2017-05-30 19:18:46 UTC
Yes, a block of text would be useful. My suggestion is to create a feature made available to all users, even as a form of autotext or even a drawing autoform.
Comment 9 Cor Nouws 2017-05-31 07:06:12 UTC
OK, thanks for discussing this. So let's set this to an enhancement.

A simple AutoText in combination with a menu entry, could do the work, at least the basics.
Comment 10 Heiko Tietze 2017-05-31 11:54:36 UTC
1. Insert field interactively (~6x3cm)
2. Object properties > Borders > off
3. Insert Field > Name (should be defined in Tools > Options)
4. Change paragraph to spacing 2cm above, borders on top with spacing 0cm except top with 0.5cm

Do we really want to implement a shortcut to this? Or isn't this better handled with an extension. If we go the hard-coded way we should think about an integration with the actual signature feature so that users can insert a signature without a certificate but this input. Sounds similarly strange as having digital signature and another manual signature.
Comment 11 Rodrigo Zimmermann 2017-05-31 12:37:10 UTC
Digital signatures are used for documents that will not be printed, but there are many cases that require manual signature of the document (when printed, for example). In these cases, the "signature line" feature could be welcome, dispensing with the use of underlines and manual markup in the document (the feature would be automated through a textbox containing fields).

It could simply be a menu entry that automates the insert, I think it would require little code to implement (everything is already available in Writer, just need to automate).However, if such a resource is discussed and approved, it matters little whether it will be through extension, new code or macro. The best decision will always be the developer team.
Comment 12 Samuel Mehrbrodt (CIB) 2017-11-23 09:24:13 UTC

*** This bug has been marked as a duplicate of bug 83877 ***