Bug Hunting Session
Bug 108141 - Link to external data sometimes results in HTTP 503
Summary: Link to external data sometimes results in HTTP 503
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Calc-External-Datalink
  Show dependency treegraph
 
Reported: 2017-05-26 19:38 UTC by Joerg
Modified: 2018-11-10 19:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joerg 2017-05-26 19:38:12 UTC
Description:
Some external webpages which worked flawlessly in LO 5.2 cannot be reached using LO 5.3.
Example page: https://www.comdirect.de/inf/musterdepot/pmd/freunde.html?portfolio_key=20988622402053762302148167949227215202483552575810349595866291873600993993993


Steps to Reproduce:
1. Open Calc
2. Select Sheet -> Link to External data...
3. Use URL https://www.comdirect.de/inf/musterdepot/pmd/freunde.html?portfolio_key=20988622402053762302148167949227215202483552575810349595866291873600993993993 and press Enter


Actual Results:  
Error message: "Error reading data from the Internet. Server error message: 503 Service Unavailable"

Expected Results:
An import dialog shoud appear.


Reproducible: Always

User Profile Reset: Yes

Additional Info:
Also tried using Portable Version.
Error exists since the first 5.3xxx-release. Works perfectly fine in 5.2.7.2 and below.


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36
Comment 1 Telesto 2017-06-01 20:28:07 UTC
Repro with
Version: 5.5.0.0.alpha0+
Build ID: ec79f3453471ee9b6ae32e71ff16ea99d9b7751c
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-28_23:21:44
Locale: nl-NL (nl_NL); Calc: CL

but not with:
Version: 5.2.5.0.0+
Build ID: a4d4fbeb623013f6377b30711ceedb38ea4b49f8
CPU Threads: 4; OS Version: Windows 6.2; UI Render: GL; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-2, Time: 2016-12-24_14:43:55
Locale: nl-NL (nl_NL); Calc: CL
Comment 2 raal 2017-06-06 16:01:47 UTC
This seems to have begun at the below commit.
Adding Cc: to Giuseppe Castagno ; Could you possibly take a look at this one?
Thanks

718bf4985ccb11b9236d2a1bff49ce0b6b0785b2 is the first bad commit
commit 718bf4985ccb11b9236d2a1bff49ce0b6b0785b2
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Oct 11 08:44:56 2016 +0200

    source sha:16df731a30917a426df81d751a0bfd0ae5fcdd45

author	Giuseppe Castagno <giuseppe.castagno@acca-esse.eu>	2016-09-12 18:59:09 (GMT)
committer	Giuseppe Castagno <giuseppe.castagno@acca-esse.eu>	2016-10-11 06:06:12 (GMT)
commit	16df731a30917a426df81d751a0bfd0ae5fcdd45 (patch)
tree	e15f608f5942b07c2f576dbf823023c722434b46
parent	086550313260d9fa45b91dc705b21bb9b51ce0b8 (diff)
tdf#102499 (5): Deal with HTTP unofficial response status codes
A reference can be found here:
<https://en.wikipedia.org/wiki/List_of_HTTP_status_codes>
(retrieved 2016-09-13).

Changes done:
Add set of 'HEAD method not available' before using fall back GET method.
Add new method in OPTIONS cache.
Add response status code if fall-back GET didn't succeeded.
Add copy-assignement operator to DAVOptions.
Fix behaviour of GET fall back when HEAD missing.

Change-Id: I6aad0e22bb444abf37b90186588f64f79b03cc3d
Reviewed-on: https://gerrit.libreoffice.org/29680
Tested-by: Jenkins <ci@libreoffice.org>
Reviewed-by: Giuseppe Castagno <giuseppe.castagno@acca-esse.eu>
Comment 3 Eike Rathke 2018-11-10 19:52:58 UTC
HTTP code 503 is a server error. Anyway, can't reproduce on Linux already in 5.3.6 and later releases, seems to be server or a Windows problem or fixed.