Download it now!
Bug 108185 - Incorrect font formatting operations in cells with Prestige Elite font
Summary: Incorrect font formatting operations in cells with Prestige Elite font
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts
  Show dependency treegraph
 
Reported: 2017-05-27 21:31 UTC by Kevin
Modified: 2017-07-26 15:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
file to reproduce bug of same name (12.79 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-05-27 21:42 UTC, Kevin
Details
try this one first (12.90 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-05-27 21:48 UTC, Kevin
Details
screenshot in case you can't repro (92.70 KB, image/jpeg)
2017-05-27 21:54 UTC, Kevin
Details
screenshot 1 after new user profile (12.96 KB, image/jpeg)
2017-05-28 08:34 UTC, Kevin
Details
screenshot 2 after new profile (44.93 KB, image/jpeg)
2017-05-28 08:35 UTC, Kevin
Details
content.xml (10.21 KB, text/xml)
2017-06-05 09:12 UTC, Kevin
Details
screenshot of WinRAR's extraction of .ods renamed .zip (21.79 KB, image/jpeg)
2017-06-05 09:12 UTC, Kevin
Details
prestige elite font (deleted)
2017-06-13 06:36 UTC, Kevin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin 2017-05-27 21:31:37 UTC
Description:
Font and format commands fail to take effect (.ODS file provided)

Steps to Reproduce:
1. open the .ods file attached (name will be the same as the bug number)
2. note that the font is Prestige Elite
3. select one or more cells and try to change the font
4. try to change to bold or italic or superscript

Actual Results:  
None of the commands take effect

Expected Results:
User should be able to select a range of cells and apply formatting.


Reproducible: Always

User Profile Reset: No

Additional Info:
WORKAROUND: You can double click each cell individually and then editing is allowed. Needless to say, this is a crippling limitation when dealing with this bug on a repeated basis.


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36
Comment 1 Kevin 2017-05-27 21:42:00 UTC
Created attachment 133654 [details]
file to reproduce bug of same name

I don't have a way to reproduce this from scratch but it occurs over and over in a large spreadsheet containing many unwanted instanced of Prestige Elite that I wish to change to Courier New and am unable to do so en masse.

I can't remember if these cells were originally set to Prestige Elite in Calc or in Excel before I switched to Calc. I hope you realize that being able to import Excel files is not a minor or trivial feature. The great majority of your user base learned how to use spreadsheets with Excel and have many Excel-created spreadsheets. All that said, it's equally possible that these corrupted cells began life in the release version of Calc I was using prior to switching to 5.3.2.2.
Comment 2 Kevin 2017-05-27 21:48:20 UTC
Created attachment 133655 [details]
try this one first

I think I may be missing a step.

Try this file instead (108185-b.ods) and add these steps at the beginning

1. select all the cells with contents
2. note that while there are superscript characters, the superscript button is greyed out
3. click bold or italic or the font size (nothing happens)
4. the font is shown as Prestige Elite - try to change to Courier New (nothing happens except that now the font is designated as Courier New in the formatting box (while the font shown in the cell continues to be Prestige Elite).

NOTE!: The funny looking superscripts in the spreadsheet when you first open it were NOT entered that way by the user. That was a bit of corruption that occurred at some point in the history of the spreadsheet, probably going from the release version of Calc I was using before 5.3.2.2.
Comment 3 Kevin 2017-05-27 21:54:38 UTC
Created attachment 133656 [details]
screenshot in case you can't repro

this screenshot shows the bug in action

notes: 

1. cell C2640 is selected
2. the Formatting toolbar shows Courier New
3. you can see that the font displayed in the selected cell is not Courier (it's Prestige Elite) - so even before trying to apply formatting you can see that something is wrong - somewhere in the cells internal header or whatever is something that tells the toolbar to display an incorrect font.
Comment 4 Kevin 2017-05-28 08:34:50 UTC
Created attachment 133662 [details]
screenshot 1 after new user profile
Comment 5 Kevin 2017-05-28 08:35:12 UTC
Created attachment 133663 [details]
screenshot 2 after new profile
Comment 6 Buovjaga 2017-06-04 16:49:00 UTC
(In reply to Kevin from comment #2)
> 4. the font is shown as Prestige Elite - try to change to Courier New
> (nothing happens except that now the font is designated as Courier New in
> the formatting box (while the font shown in the cell continues to be
> Prestige Elite).

Something does happen: B and D columns get their font changed.

But I guess this is the same root issue as your bug 108041, right?
Comment 7 Kevin 2017-06-05 08:25:14 UTC
> But I guess this is the same root issue as your bug 108041, right?

I'm not an engineer, but I think the root issues are that: 

1. whatever internal header or xml data or whatever the UI looks at to know what the font and font attributes  gets set to some form that makes the UI display false information

2. however the code is written for the formatting commands, it fails to see that the format is wrong and fails to clear it and rewrite it properly

Based on a comment from someone who is an engineer I tried to view the XML but was unable to do so. If I could see that, I could try each command and see how the UI writes the internal XML (I only say XML because that term was used in the comment). If I could see what happens to that when the bug occurs I might be able to come up with steps to cause the problem without having to use data from the imported Excel file. But to repeat, being able to smoothly handle Excel files has got to be right at the top of the list of things this program needs to do, right?

I looked up XML and found this:

<font face = 'Tahoma' size = '19' hatch = 'largecheckerboard, white, red'>TAHOMA FONT</font>

I'm guessing that Calc is storing something like that for each character, right? And I'm guessing that one part of the UI writes this with bad syntax and the other part of the program doesn't know how to read it so it does nothing or shows the user the wrong info.

What I'm saying is that all this bugs are really happening - over and over - and they're not "trivial" - they're crippling.
Comment 8 Buovjaga 2017-06-05 09:06:54 UTC
(In reply to Kevin from comment #7)
> Based on a comment from someone who is an engineer I tried to view the XML
> but was unable to do so. If I could see that, I could try each command and

I'm not an engineer, but an ordinary user like you. I don't have any higher education, just high school.

You can rename the .ods to .zip and perhaps WinRAR will accept it. 7-zip is smarter in this regard.
Comment 9 Kevin 2017-06-05 09:11:46 UTC
>You can rename the .ods to .zip and perhaps WinRAR will accept it.

very clever - that worked - thanks - I've uploaded a screenshot of what WinRAR shows me. I tried extracting content.xml. I can view it in notepad but I haven't been able to see how the formatting is represented. I'm uploading that file as well.
Comment 10 Kevin 2017-06-05 09:12:19 UTC
Created attachment 133857 [details]
content.xml
Comment 11 Kevin 2017-06-05 09:12:57 UTC
Created attachment 133858 [details]
screenshot of WinRAR's extraction of .ods renamed .zip
Comment 12 Kevin 2017-06-05 09:20:47 UTC
> I'm not an engineer, but an ordinary user like you. 

Maybe you should become one - somebody's got to fix this thing before I lose my mind! I just got so mad that I downloaded Apache Open Office and found the most curious thing - almost all of my Calc bugs behave exactly the same way in Open Office. I guess the bugs are at some deeper level of whatever code base the two share. So then I tried google docs spreadsheets - a total joke - even worse than Excel. There must be some program that will let you make good looking charts. I can't believe how bad all four of these programs are.
Comment 13 Telesto 2017-06-09 20:15:51 UTC
I created two similar reports based on this bug (with steps to create the problem.  See bug 108391 and bug 108394
Comment 14 Alex Thurgood 2017-06-12 07:56:55 UTC
(In reply to Kevin from comment #0)



> Steps to Reproduce:
> 1. open the .ods file attached (name will be the same as the bug number)
> 2. note that the font is Prestige Elite

Only cell D2 is Prestige Elite in the file I downloaded (under the try this one first link).


> 3. select one or more cells and try to change the font

Selected D2 and E2, changed font to Courier New - change successful, cell D2 font was changed to Courier New.


> 4. try to change to bold or italic or superscript

Selected D2 and E2, changed attribute to bold. Both cells individually now have the bold attribute.

Works for me.

Version: 5.3.3.2
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 2; OS Version: Mac OS X 10.12.4; UI Render: default; Layout Engine: new; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group
Comment 15 Alex Thurgood 2017-06-12 08:26:37 UTC
@Kevin : note that if Prestige Elite is a postscript Type 1 font, it is no longer supported. LibreOffice will try and use a fallback font instead, and perhaps this (or a related bug) is causing the issue you are experiencing.
Comment 16 Alex Thurgood 2017-06-12 08:31:44 UTC
@Kevin : please specify which version of macOS you are using, as this bug is reported as affecting macOS, yet your reporting browser indicated WinNT6.1, with Chrome and Safari browsers.

If you are not using macOS, please correct the system hardware dropdown choice.
Comment 17 Kevin 2017-06-12 20:28:49 UTC
(In reply to Alex Thurgood from comment #16)

Sorry - I chose the wrong OS. I use Windows 7 - changed the drop-down accordingly.
Comment 18 Buovjaga 2017-06-13 04:18:00 UTC
Alex: it says here it is from URW++: https://www.myfonts.com/fonts/urw/prestige-elite/
Doesn't that mean it is indeed Type 1?
Kevin: can you please check it by looking at the font properties.
Comment 19 Kevin 2017-06-13 06:36:32 UTC
Created attachment 133994 [details]
prestige elite font

It appears to be an open type font (otf)
Comment 20 Kevin 2017-06-13 06:38:28 UTC
The problem of font types and attributes not being editable happens with all sorts of fonts.
Comment 21 Buovjaga 2017-06-13 06:49:25 UTC
The content of attachment 133994 [details] has been deleted for the following reason:

It is illegal to distribute commercial fonts
Comment 22 Timur 2017-07-26 15:12:42 UTC
I didn't go into this bug, but with what Alex wrote and little search leading to Bug 37453, I'll close as WF.