Bug 108285 - FILEOPEN ODS: The source ODS file opens far slower than the exported XLSX
Summary: FILEOPEN ODS: The source ODS file opens far slower than the exported XLSX
Status: RESOLVED DUPLICATE of bug 108284
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, perf
Depends on:
Blocks: File-Opening
  Show dependency treegraph
 
Reported: 2017-06-01 17:01 UTC by Telesto
Modified: 2020-06-05 17:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Callgrind output from 5.5 (5.47 MB, application/x-xz)
2017-06-09 17:58 UTC, Buovjaga
Details
perf flamegraph (233.68 KB, application/x-bzip)
2020-06-05 11:39 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-06-01 17:01:59 UTC
Description:
The source ODS file opens far slower than the exported XLSX 

Steps to Reproduce:
1. Open attachment 133788 [details] (bug 108284) 
2. Save it as a xlsx file
3. Open both documents and compare the opening speed

Actual Results:  
The opening of the ODS file takes around 16 seconds in Lib0 4.4.6.3
Opening the xlsx is a lot faster (8 seconds)

Expected Results:
Should be similar in my opinion 


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.5.0.0.alpha0+
Build ID: ec79f3453471ee9b6ae32e71ff16ea99d9b7751c
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-28_23:21:44
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Xisco Faulí 2017-06-05 12:37:40 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: ff08e8d5618f84366439c6f48bd7c5f3062905a3
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

xisco@xisco-Latitude-E6220:~/libreoffice$ time OOO_EXIT_POST_STARTUP=1 instdir/program/soffice /home/xisco/Baixades/Untitled\ 8.ods 

real	0m59.194s
user	1m4.688s
sys	0m1.048s
xisco@xisco-Latitude-E6220:~/libreoffice$ time OOO_EXIT_POST_STARTUP=1 instdir/program/soffice /home/xisco/Escriptori/Untitled\ 8.xlsx 

real	0m8.540s
user	0m11.652s
sys	0m0.432s
Comment 2 Xisco Faulí 2017-06-05 12:40:59 UTC
in

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

it's much faster:

real	0m16.434s
user	0m15.892s
sys	0m0.172s
Comment 3 Xisco Faulí 2017-06-05 12:53:48 UTC
in

- Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

it takes

real	0m55.707s
user	0m55.064s
sys	0m0.248s

while in

- Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

it takes

real	0m20.940s
user	0m20.520s
sys	0m0.212s

then it needs to be bisected with bibisect-51max or bibisect-52max
Comment 4 Telesto 2017-06-05 14:51:48 UTC
NOTE: I reported the slow opening of the ODS file separately (bug 108284).

My point with this bug report is that opening the ODS takes still twice as long with the fastest LibO version compared to the opening the XLSX file. 

xlsx with 5.4.0.0.alpha0+
real	 0m8.540s
user	0m11.652s
sys	0m0.432s

ODS with LibO4.1
real	0m16.434s
user	0m15.892s
sys	0m0.172s
Comment 5 Buovjaga 2017-06-09 17:58:41 UTC
Created attachment 133934 [details]
Callgrind output from 5.5

Arch Linux 64-bit, KDE Plasma 5
Version: 5.5.0.0.alpha0+
Build ID: e78d128e3b7bf45990d1f7b27123ccd616665f93
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 9th 2017
Comment 6 Buovjaga 2017-06-09 18:01:01 UTC
(In reply to Telesto from comment #4)
> NOTE: I reported the slow opening of the ODS file separately (bug 108284).
> 
> My point with this bug report is that opening the ODS takes still twice as
> long with the fastest LibO version compared to the opening the XLSX file. 

Didn't notice this while doing callgrind.. What would be different when fixing these 2 reports? I mean why do we need 2?
Comment 7 Telesto 2017-06-09 19:16:52 UTC
(In reply to Buovjaga from comment #6)
> (In reply to Telesto from comment #4)
> > NOTE: I reported the slow opening of the ODS file separately (bug 108284).
> > 
> > My point with this bug report is that opening the ODS takes still twice as
> > long with the fastest LibO version compared to the opening the XLSX file. 
> 
> Didn't notice this while doing callgrind.. What would be different when
> fixing these 2 reports? I mean why do we need 2?

In my hubble opinion there are two issues. 
1. At this point the main problem is the slow loading of the ODT (bug 108284)
2. But even if we are back to normal +/- 16.434s the file opening is still 'slow' compared to the XLSX version. I find that curious. Why should saving to an non native file format be faster?

So: this bug is only useful if the issue gets 'reverted' back to LibO4.1. If the fix would lead to any further optimization (based on callgrind), than I see no point having two bug. Both should be fixed at once :-).

It's your call
Comment 8 QA Administrators 2018-06-10 02:45:35 UTC Comment hidden (obsolete)
Comment 9 kabilo 2018-06-11 14:53:24 UTC
Hello, the same PC, 6.0.5.1 (x64) vs 6.1.0.0.beta1 (x64), same file with 700.000 rows (only data, no formulas, no formats).
6.0.5.1 (x64)
xlsx (47 MB) - the file is opened in 32 seconds
ods (34 MB) - the file is opened in 3 minutes 30 seconds (210 seconds)
6.1.0.0.beta1 (x64)
xlsx (47 MB) - the file is opened in 45 seconds
ods (34 MB) - the file is opened in 4 minutes 10 seconds (250 seconds)
Comment 10 Telesto 2020-06-05 10:18:52 UTC
@Julien
A flamegraph of the opening of the ods would be nice
Comment 11 Telesto 2020-06-05 10:22:17 UTC

*** This bug has been marked as a duplicate of bug 97177 ***
Comment 12 Julien Nabet 2020-06-05 11:39:47 UTC
Created attachment 161648 [details]
perf flamegraph

Here's a Flamegraph retrieved on pc Debian x86-64 with master sources updated today.
Comment 13 Julien Nabet 2020-06-05 11:42:16 UTC
Now this bug has been put as dup, there's little chance someone takes a look at Flamegraph.

Also, I think we should a bit some feedback on already provided Flamegraph before continuing providing others.
Indeed, sources evolve everyday and even if all parts are not involved each day, a Flamegraph which has some weeks or months old may be obsolete.
Comment 14 Xisco Faulí 2020-06-05 17:35:51 UTC
(In reply to Telesto from comment #11)
> 
> *** This bug has been marked as a duplicate of bug 97177 ***

Hi Telesto,
What's the reason why you closed it as duplicated ? 4 minutes before you asked for a framegraph
Comment 15 Xisco Faulí 2020-06-05 17:47:08 UTC
(In reply to Julien Nabet from comment #12)
> Created attachment 161648 [details]
> perf flamegraph
> 
> Here's a Flamegraph retrieved on pc Debian x86-64 with master sources
> updated today.

I'll upload the flamegraph to bug 108284, where it belongs. Sorry for the inconveniences and thanks for taking the time to provide it.
Comment 16 Xisco Faulí 2020-06-05 17:49:04 UTC

*** This bug has been marked as a duplicate of bug 108284 ***