Bug 108284 - FILEOPEN ODS: Opening is slower as it used to be in earlier releases
Summary: FILEOPEN ODS: Opening is slower as it used to be in earlier releases
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
: 108285 (view as bug list)
Depends on:
Blocks: Regressions-1024plus-Columns
  Show dependency treegraph
 
Reported: 2017-06-01 16:33 UTC by Telesto
Modified: 2021-05-04 21:24 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (9.02 MB, application/vnd.oasis.opendocument.spreadsheet)
2017-06-01 16:34 UTC, Telesto
Details
Bibisect log (2.90 KB, text/plain)
2017-10-08 15:33 UTC, Telesto
Details
perf flamegraph from Julien Nabet (233.68 KB, application/x-bzip)
2020-06-05 17:47 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-06-01 16:33:21 UTC
Description:
File-opening is slower as it used to be in LibO4.4.6.3

Steps to Reproduce:
1. Open attached file and take notice of the time needed until opened

Actual Results:  
File opening takes around 30 seconds

Expected Results:
Should be around 16 seconds


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in (33 seconds)
Version: 5.5.0.0.alpha0+
Build ID: ec79f3453471ee9b6ae32e71ff16ea99d9b7751c
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-28_23:21:44
Locale: nl-NL (nl_NL); Calc: CL

and in 
Version: 5.2.5.0.0+ (40 seconds)
Build ID: a4d4fbeb623013f6377b30711ceedb38ea4b49f8
CPU Threads: 4; OS Version: Windows 6.2; UI Render: GL; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-2, Time: 2016-12-24_14:43:55
Locale: nl-NL (nl_NL); Calc: CL

but not in (16 seconds)
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-06-01 16:34:14 UTC
Created attachment 133788 [details]
Example file
Comment 2 Xisco Faulí 2017-06-01 17:31:41 UTC
Confirmed in

Version: 5.5.0.0.alpha0+
Build ID: 9956849c2ea6049582e2ccf04c355542c1ef00a1
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

time

real	1m6.849s
user	1m10.896s
sys	0m1.140s

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

time

real	0m20.337s
user	0m19.740s
sys	0m0.176s
Comment 3 Xisco Faulí 2017-06-01 17:36:34 UTC
Reproduced in

- Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

real	1m13.821s
user	0m57.120s
sys	0m0.360s


but not in

- Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

real	0m20.029s
user	0m19.648s
sys	0m0.184s
Comment 4 m.a.riosv 2017-06-01 22:26:17 UTC
I think the issue with the file, comes from the direct format on the whole sheet cells.
Comment 5 Buovjaga 2017-06-09 18:00:04 UTC
Callgrind output: attachment 133934 [details]
Comment 6 Telesto 2017-10-08 15:33:44 UTC
Created attachment 136853 [details]
Bibisect log

Slowness started with this commit.

author	Dennis Francis <dennisfrancis.in@gmail.com>	2016-02-05 21:42:20 (GMT)
committer	Markus Mohrhard <markus.mohrhard@googlemail.com>	2016-02-10 23:08:04 (GMT)
commit bc20c6d0f397c0c1aef6ef7d6f750c2f81af8db6 (patch)
tree 72d84f3356709b4e4413bf28e40f83b3565a2608
parent 7f02815bf90f4dee5c76f2bdb4fd84f03e27527e (diff)
Refactor ScMarkData for tdf#50916
Made the container for storing multimarks dynamic.
Also let the full row marks to be stored in a dedicated
ScMarkArray object rather than in the multimarks container.

Unit tests for ScMarkData and ScMultiSel will come in a follow up
patch.
Comment 7 Telesto 2017-10-08 15:34:42 UTC
Adding Cc: to Dennis Francis 
Could you possibly take a look at this one? Thanks
Comment 8 QA Administrators 2018-10-09 02:52:42 UTC Comment hidden (obsolete)
Comment 9 Roman Kuznetsov 2018-10-09 07:02:33 UTC
still repro, in 

Version: 6.2.0.0.alpha0+
Build ID: 89a60912bba7ffd6f65ea99f4664f343c5025c95
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-01_01:47:23
Locale: ru-RU (ru_RU); Calc: threaded

it takes 55 sec
Comment 10 QA Administrators 2019-10-10 02:40:44 UTC Comment hidden (obsolete)
Comment 11 Xisco Faulí 2020-06-05 17:47:57 UTC
Created attachment 161662 [details]
perf flamegraph from Julien Nabet
Comment 12 Xisco Faulí 2020-06-05 17:49:04 UTC
*** Bug 108285 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2020-06-05 17:51:46 UTC
it takes

real	0m59,856s
user	1m16,512s
sys	0m4,896s

in

Version: 7.1.0.0.alpha0+
Build ID: 8aee8c0cf1bdda1866594e75b0f9bd4b9a69c724
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 14 Xisco Faulí 2020-06-05 18:16:53 UTC
(In reply to Xisco Faulí from comment #11)
> Created attachment 161662 [details]
> perf flamegraph from Julien Nabet

@Noel, @Luboš, I thought you might be interested in this issue...
Comment 15 Noel Grandin 2020-06-23 07:41:09 UTC
On current master, there is nothing obvious that can be improved without a very large amount of effort.

Specifically, we could import stuff without using UNO e.g. in SCXMLTableRowContext and talk directly to the main calc internal interfaces.

But that is a lot of work with a high likelihood of regressions.
Comment 16 Roman Kuznetsov 2021-05-04 19:27:37 UTC
ohoho, only 9 sec in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 931e264590100c555580c413556e229a0f03316a
CPU threads: 4; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded

Someone else, please retest it on your machines.
Comment 17 Xisco Faulí 2021-05-04 19:36:40 UTC
(In reply to Xisco Faulí from comment #13)
> it takes
> 
> real	0m59,856s
> user	1m16,512s
> sys	0m4,896s
> 
> in
> 
> Version: 7.1.0.0.alpha0+
> Build ID: 8aee8c0cf1bdda1866594e75b0f9bd4b9a69c724
> CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
> Locale: en-US (en_US.UTF-8); UI: en-US
> Calc: threaded

it takes

real	0m15,889s
user	0m20,248s
sys	0m1,403s

in

Version: 7.0.7.0.0+
Build ID: 6ac038c54121ec307ed75f8fb45f591cca9f8519
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

and in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: dff586735b6618d9b011823594a33287d8f7f223
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 18 Xisco Faulí 2021-05-04 19:38:44 UTC
Closing as RESOLVED WORKSFORME