Bug 133619 (Regressions-1024plus-Columns) - [META] Regressions from increasing column limit in Calc (mainly bug 50916)
Summary: [META] Regressions from increasing column limit in Calc (mainly bug 50916)
Status: RESOLVED WORKSFORME
Alias: Regressions-1024plus-Columns
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 108284 124778 124815 124816 124818 124822 124896 124997 125051 126418 126685 126904 126905 128562 128753 128895 128951 129533 129908 130959 131455 131907 132057 132278 133326 133629 134461 134552 134553 135332 140014 140607 144537 146162 146861 147830
Blocks: Calc-large-spreadsheets
  Show dependency treegraph
 
Reported: 2020-06-03 02:27 UTC by Aron Budea
Modified: 2022-03-08 11:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2020-06-03 02:27:42 UTC
This meta bug is for regressions from commits mentioning bug 50916, and other bugs related to the work on increasing the column limit.

The fixed regressions should be removed from bug 50916's see also field, the open ones can stay there.
Comment 1 Justin L 2021-12-08 08:47:24 UTC
> How to enable support for very large spreadsheets in LO7 RC2 Calc?
Via the following steps in Tools -> Options...:
- First under LibreOffice -> Advanced, check Enable experimental features (may be unstable),
- After a restart, under LibreOffice Calc -> Defaults, check Enable very large spreadsheets (16m rows, 16384 cols).
Comment 2 Timur 2022-01-19 10:12:26 UTC
IMO, this bug and those here should be of High_Major, even before bug 133764, because it's not obvious that normal size Calc has bug due to Jumbo sheets. 
Also, I don't know if there's some expected time when this should exit from experimental, it should be.
Comment 3 Timur 2022-02-17 09:36:43 UTC
Thanks to Lubos, no more open dependencies here. 
Should it be closed then?
Comment 4 Aron Budea 2022-02-17 16:20:29 UTC
Let's close this for now, it can always be reopened if another issue is found.