Bug 146162 - JUMBO SHEETS: cannot hide all columns
Summary: JUMBO SHEETS: cannot hide all columns
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-large-spreadsheets Regressions-1024plus-Columns
  Show dependency treegraph
 
Reported: 2021-12-10 11:45 UTC by Justin L
Modified: 2022-02-14 11:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin L 2021-12-10 11:45:00 UTC
This is a follow-up to bug 128895, and it was requested I file this bug report.

Quite a few people like to hide all of the columns / rows they aren't using. That probably would end up being a very bad thing for jumbo sheets, performance wise, but I crashed when attempting to do that.

1.) open attachment 176792 [details]  (from bug 128895 comment 28)
2.) notice that the columns up to 1024 are hidden. Put the cursor in column AMK and press Ctrl-Shift-RightArrow to select to the end column XFD
3.) Right click on the column header and chose "hide columns". CRASH


I tried a "backtrace" in gdb after the crash, but "Couldn't get registers: No such process."
Comment 1 raal 2021-12-25 17:48:19 UTC
Repro Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: c13db6e792cc347ffff4585f23866f195651f21f
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded Jumbo
Comment 2 Luboš Luňák 2022-02-14 10:48:58 UTC
I cannot reproduce with current master. Can you still reproduce this?
Comment 3 Justin L 2022-02-14 11:34:23 UTC
It seems to have been fixed in LO 7.4 by
commit cd50d33fc4af3f2d4ab40de98ecf02f0d832d750
Author: Luboš Luňák on Mon Feb 7 18:57:47 2022 +0100
    MAXCOL/MAXROW -> ScSheetLimits in fillinfo.cxx

It is terribly slow (~20 seconds for me), but it does not crash as before.