Bug 126418 - Crash in: ScColumn::MergeBlockFrame(SvxBoxItem *,SvxBoxInfoItem *,ScLineFlags &,long,long,bool,short)
Summary: Crash in: ScColumn::MergeBlockFrame(SvxBoxItem *,SvxBoxInfoItem *,ScLineFlags...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.1 rc
Hardware: All All
: highest critical
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.4.0 target:6.3.2 target:6.3.1
Keywords: bibisected, bisected, regression
: 127150 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-07-16 01:55 UTC by Mike Kaganski
Modified: 2019-09-02 10:40 UTC (History)
7 users (show)

See Also:
Crash report or crash signature: ["ScColumn::MergeBlockFrame(SvxBoxItem *,SvxBoxInfoItem *,ScLineFlags &,long,long,bool,short)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2019-07-16 01:55:51 UTC
This bug was filed from the crash reporting server and is br-9fa20aba-d485-4bde-9769-4cc1df474e99.
=========================================

Create a new spreadsheet; in this Basic code:

> sub test()
>   r = ThisComponent.Sheets(0).Rows.getByIndex(0)
> end sub

... put a breakpoint to the last line (end sub), and run the macro. When the breakpoint is hit, add "r" to watches, and try to expand. This crashes in Version: 6.3.0.1 (x64)
Build ID: 41ac97386aba908b6db860cfb4cfe2da871886ae
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 1 Mike Kaganski 2019-07-16 06:09:08 UTC
Additionally, adding

> c = r.getCellByPosition(64, 0)

before "end sub", adding "c" to watch list, and trying to expand it, also crashes.
Comment 2 Xisco Faulí 2019-07-16 20:21:24 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=7282014e362a1529a36c88eb308df8ed359c2cfa

author	Noel Grandin <noel.grandin@collabora.co.uk>	2019-02-01 15:15:16 +0100
committer	Mike Kaganski <mike.kaganski@collabora.com>	2019-04-05 13:43:52 +0200
commit	7282014e362a1529a36c88eb308df8ed359c2cfa (patch)
tree	2776ad9601f494330076ac58c08554e719c6ab3a
parent	df30a4515b1303b0891baa53754fa9b3e47e0c02 (diff)
tdf#50916 Makes numbers of columns dynamic.

Bisected with: bibisect-linux64-6.3 

Adding Cc: to Noel Grandin
Comment 3 create0T 2019-07-18 15:16:56 UTC Comment hidden (spam)
Comment 4 Xisco Faulí 2019-08-02 14:57:01 UTC
7 crashes reported for 6.3.0.2 in http://crashreport.libreoffice.org/stats/version/6.3.0.2. Probably we will get much more once we do the final announcement.
Increasing severity
Comment 6 Mike Kaganski 2019-08-06 11:04:56 UTC
https://gerrit.libreoffice.org/75671 is in review for some time; I don't push it, because I am not sure I do it right in all places...
Comment 7 Commit Notification 2019-08-14 07:39:01 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/159db459418a2c831bf00dca5a2c5087d65e9ab6%5E%21

tdf#126418: add some more checks for allocated columns

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 m.a.riosv 2019-08-14 21:25:55 UTC
Seems to work fine with
Version: 6.4.0.0.alpha0+ (x64)
Build ID: d3d13140f0036c53aa74820b41acfeffa3572168
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-14_12:05:15
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL

Really thanks Mike, please could it be backported to 6.3, at least for me makes difficult use it.
Comment 9 Mike Kaganski 2019-08-15 04:22:42 UTC
(In reply to m.a.riosv from comment #8)

Of course; https://bugs.documentfoundation.org/show_bug.cgi?id=126418 is prepared and must be merged as required for all backports: i.e., 1 review from someone other than me [1].

[1] https://wiki.documentfoundation.org/Development/Branches
Comment 10 Mike Kaganski 2019-08-15 04:23:30 UTC
Sorry; the link to backport is https://gerrit.libreoffice.org/77442
Comment 11 Commit Notification 2019-08-19 08:27:03 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/7a42bf4caa46093ced87a4db54b94f6b4c4decd0%5E%21

tdf#126418: add some more checks for allocated columns

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-08-23 18:40:32 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-1":

https://git.libreoffice.org/core/+/effde02da2ec4fed5e9e0552be99bd20ac15566c%5E%21

tdf#126418: add some more checks for allocated columns

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Juergen Klatt 2019-08-23 18:53:13 UTC
Hello,

for your information:

The following crash reports generated by my system and I think that they are the same issue.

This bug is filed with the crash reporting server and is br-96bbb40b-ab35-4b89-b3a8-a7d2fc45d09b.
=========================================

and this is reported by the next crash:
http://crashreport.libreoffice.org/stats/crash_details/e1e26115-d2ce-4cef-b5f3-77ff0c48db16
=========================================


reproduce the crash:
1)
Open Calc and write the following code in a module of the Basic IDE:
Sub Main
oDoc = ThisComponent
oSheet = oDoc.getSheets.getByIndex (0)
Print "Breakpoint"
End Sub
2)
Set a breakpoint before the print statement

3)
Add the object "oSheet" to the observer (Watch window)

4)
When executing the code, the pointer stops at the print instruction and in the observer the variable "oSheet" is shown.

5)
Now double-click on "oSheet" in the observer window. Right now, Calc crashes.

The same thing happens when you use one of the inspection tools (XRAY or MRI) instead of the observer.
XRAY oSheet
or
MRI oSheet
Calc crashes every time.

Version: 6.3.0.4 (x64)
Build-ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: CL

Best Regards

Juergen
Comment 14 m.a.riosv 2019-08-28 20:27:25 UTC
With the file I was having the issue, seems it solved also with:
Version: 6.3.1.1 (x64)
Build ID: e979878b49a48dab15ebe528f238b88125e32c65
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL
Comment 15 m.a.riosv 2019-08-28 20:54:11 UTC
Thanks Mike
Comment 16 Xisco Faulí 2019-09-02 10:40:08 UTC
*** Bug 127150 has been marked as a duplicate of this bug. ***