Bug 127150 - BASIC IDE crashes inspecting objects
Summary: BASIC IDE crashes inspecting objects
Status: RESOLVED DUPLICATE of bug 126418
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: BASIC-IDE
  Show dependency treegraph
 
Reported: 2019-08-25 16:15 UTC by Paolo
Modified: 2019-09-02 11:54 UTC (History)
7 users (show)

See Also:
Crash report or crash signature: ["ScColumn::MergeBlockFrame(SvxBoxItem *,SvxBoxInfoItem *,ScLineFlags &,long,long,bool,short)"]
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo 2019-08-25 16:15:29 UTC
On LibreOffice 6.3.0.4, in my Ubuntu 18.04 (Build ID: 1:6.3.0-0ubuntu0.18.04.1~lo2) basic IDE crashes when I try to inspect object (I was trying to inspecting a sheet object) and, of course, the whole LibreOffice crashes and restarts with recover procedure.
Comment 1 Oliver Brinzing 2019-08-25 16:47:45 UTC
reproducible with:

Version: 6.3.0.4 (x64)
Build-ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: 

REM  *****  BASIC  *****
OPTION EXPLICIT

Sub Main
	Dim oDoc as Object
	Dim oSheet as Object

	oDoc = ThisComponent
	oSheet = oDoc.getSheets().getByIndex(0)
	MsgBox oSheet.getName()	
End Sub


*not* reproducible with:

Version: 6.2.6.2 (x64)
Build-ID: 684e730861356e74889dfe6dbddd3562aae2e6ad
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: 

Version: 6.4.0.0.alpha0+ (x64)
Build ID: ec940941e0bd7db15c5cf7d43df82226e0d849dc
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 2 m.a.riosv 2019-08-26 11:51:42 UTC
Looks like a dup of https://bugs.documentfoundation.org/show_bug.cgi?id=126828
Comment 3 Oliver Brinzing 2019-08-26 12:37:07 UTC
(In reply to m.a.riosv from comment #2)
> Looks like a dup of
> https://bugs.documentfoundation.org/show_bug.cgi?id=126828

I think rather no, cause it seems to be a LO 6.3 issue only.
Comment 4 raal 2019-08-26 14:36:33 UTC
This seems to have begun at the below commit.
Adding Cc: to Noel Grandin; Could you possibly take a look at this one? Thanks
 d53ef167063b0e2c18e7e703af4407b40c664fb2 is the first bad commit
commit d53ef167063b0e2c18e7e703af4407b40c664fb2
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Apr 5 04:58:29 2019 -0700

    source sha:7282014e362a1529a36c88eb308df8ed359c2cfa

author	Noel Grandin <noel.grandin@collabora.co.uk>	2019-02-01 15:15:16 +0100
committer	Mike Kaganski <mike.kaganski@collabora.com>	2019-04-05 13:43:52 +0200
commit 7282014e362a1529a36c88eb308df8ed359c2cfa (patch)
tree 2776ad9601f494330076ac58c08554e719c6ab3a
parent df30a4515b1303b0891baa53754fa9b3e47e0c02 (diff)
tdf#50916 Makes numbers of columns dynamic.
Comment 5 Noel Grandin 2019-08-28 12:05:55 UTC
As of master from this week, this appears to be fixed, not sure when
Comment 6 Xisco Faulí 2019-09-02 10:40:08 UTC
Issue fixed by https://gerrit.libreoffice.org/plugins/gitiles/core/+/159db459418a2c831bf00dca5a2c5087d65e9ab6%5E%21
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 126418 ***