Bug 124816 - CRASH: inserting a new row
Summary: CRASH: inserting a new row
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:7.0.0
Keywords: bibisected, bisected, regression
: 124865 (view as bug list)
Depends on:
Blocks: Regressions-1024plus-Columns
  Show dependency treegraph
 
Reported: 2019-04-18 09:41 UTC by Xisco Faulí
Modified: 2020-06-03 02:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
incomplete_screen_redraw_after_insert_of_row (513.39 KB, image/jpeg)
2020-03-10 23:45 UTC, b.
Details
corrected_display_after_some_scrolling (523.53 KB, image/jpeg)
2020-03-10 23:48 UTC, b.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-04-18 09:41:58 UTC
Maybe it has the same root cause as bug 124815

Steps to reproduce:
1. Open attachment 108569 [details] from bug 85551
2. Go to Sheet - Insert Row - Insert row before

-> Crash

Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: a96167f88aa68651f055aa9096e63c9e48c8e4fa
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-04-18 09:42:54 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=7282014e362a1529a36c88eb308df8ed359c2cfa

author	Noel Grandin <noel.grandin@collabora.co.uk>	2019-02-01 15:15:16 +0100
committer	Mike Kaganski <mike.kaganski@collabora.com>	2019-04-05 13:43:52 +0200
commit	7282014e362a1529a36c88eb308df8ed359c2cfa (patch)
tree	2776ad9601f494330076ac58c08554e719c6ab3a
parent	df30a4515b1303b0891baa53754fa9b3e47e0c02 (diff)
tdf#50916 Makes numbers of columns dynamic.

Bisected with: bibisect-linux64-6.3

Adding Cc: to Noel Grandin
Comment 2 Xisco Faulí 2019-04-18 09:43:50 UTC
Same problem with attachment 81889 [details] from bug 66506
Comment 3 Noel Grandin 2019-04-18 09:51:54 UTC
As of commit ac9aa53d51a4f359342274d107aed6df85658c55 on master, I cannot reproduce this (which means it might have been fixed by the last couple of calc-related fixes I pushed)
Comment 4 Xisco Faulí 2019-04-18 10:03:53 UTC
(In reply to Noel Grandin from comment #3)
> As of commit ac9aa53d51a4f359342274d107aed6df85658c55 on master, I cannot
> reproduce this (which means it might have been fixed by the last couple of
> calc-related fixes I pushed)

Hi Noel,
Indeed the attachment in the description is no longer crashing in

Version: 6.3.0.0.alpha0+
Build ID: 56bc0b1a376f62570a7287e9bb4193e00360c978
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

but the document mentioned in comment 2 still does...
Comment 5 Noel Grandin 2019-04-18 11:25:56 UTC
Cannot reproduce comment 2 either any more, probably because of the fix I just pushed for 
  https://bugs.documentfoundation.org/show_bug.cgi?id=124815
in commit
  https://cgit.freedesktop.org/libreoffice/core/commit/?id=7282014e362a1529a36c88eb308df8ed359c2cfa
Comment 6 Xisco Faulí 2019-04-18 15:31:23 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 5585dfdaf7180c5ab6fb1543ae2b66337c641fd5
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Noel Grandin, thanks for fixing this issue!!
Comment 7 Xisco Faulí 2019-04-22 12:38:23 UTC
*** Bug 124865 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2019-04-27 10:19:35 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/23e88b671ad2f63679a28f767173982292a45843%5E%21

uitest for bug tdf#124816

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-03-10 17:34:20 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/55a97625c56d4b1bf6948628559f7e63d01d8333

tdf#124816: move UItest to CppunitTest

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 b. 2020-03-10 23:45:43 UTC
Created attachment 158584 [details]
incomplete_screen_redraw_after_insert_of_row

no crash but something left odd: 

with ver below and file from comment #c2 after insert of a row the left part of the screen isn#t redrawn correctly, see red ellipsoid on attached pic, 

corrected display after screen redraw in next attachement. 

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 9ed75e2c65544b4f71c73e1c51a68d74e31d544b
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc:
Comment 11 b. 2020-03-10 23:48:49 UTC
Created attachment 158585 [details]
corrected_display_after_some_scrolling

corrected_display_after_some_scrolling
Comment 12 Xisco Faulí 2020-03-11 09:22:46 UTC
(In reply to b. from comment #10)
> Created attachment 158584 [details]
> incomplete_screen_redraw_after_insert_of_row
> 
> no crash but something left odd: 
> 
> with ver below and file from comment #c2 after insert of a row the left part
> of the screen isn#t redrawn correctly, see red ellipsoid on attached pic, 
> 
> corrected display after screen redraw in next attachement. 
> 
> Version: 7.0.0.0.alpha0+ (x64)
> Build ID: 9ed75e2c65544b4f71c73e1c51a68d74e31d544b
> CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render:
> Skia/Raster; VCL: win; 
> Locale: de-DE (de_DE); UI-Language: en-US
> Calc:

Please, create a follow-up report
Comment 13 b. 2020-03-11 17:46:14 UTC
@xisco: 

you mean a new bug report?
Comment 14 Xisco Faulí 2020-03-11 17:48:25 UTC
(In reply to b. from comment #13)
> @xisco: 
> 
> you mean a new bug report?

yes