Bug 147830 - CRASH when apply particular advanced filter in particular document
Summary: CRASH when apply particular advanced filter in particular document
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3 all versions
Hardware: x86-64 (AMD64) All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0 target:7.3.2 target:7.2.7
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks: Calc-large-spreadsheets Regressions-1024plus-Columns
  Show dependency treegraph
 
Reported: 2022-03-07 18:13 UTC by Rainer Bielefeld Retired
Modified: 2022-03-09 21:37 UTC (History)
7 users (show)

See Also:
Crash report or crash signature: 79b1245c-a110-44f2-8676-e04f95faa631
Regression By:


Attachments
Sample Document for CRASH (68.18 KB, application/vnd.oasis.opendocument.spreadsheet)
2022-03-07 18:13 UTC, Rainer Bielefeld Retired
Details
bt with debug symbols (9.35 KB, text/plain)
2022-03-07 19:21 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2022-03-07 18:13:32 UTC
Created attachment 178703 [details]
Sample Document for CRASH

Steps how to reproduce with sample document and Installation of Version: 7.3.0.3 (x64) 
Build ID 0f246aa12d0eee4a0f7adcefbf7c878fc2238db3
CPU threads: 12; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win | Locale: de-DE (de_DE); UI: de-DE | Calc: threaded | ElementaryTheme | My normal User Profile:

0. Launch LibO
1. Open Sample Document from Start Center
3. Menu ˋData → More Filters → Advanced Filter... "Irgendwo" → [OK]ˊ 
   Expected: Only rows containing "Neumünster" remain shown
   Actual: CRASH    😥

Additional Info:
----------------
a) Not a general problem, only with this document
   (but LibO is the most crashing App I use ...)
a1) Problem can simply be healed: Select rows 2 ... 20 → delete rows → 
    <cntrl+z> to restore rows
    Try Step 2 again: no crash
b) Was still ok with Server Installation of Version: 6.0.7.3 (x64) 
Build-ID dc89aa7a9eabfd848af146d5086077aeed2ae4a5; CPU-Threads: 12; BS: Windows 10.0; UI-Render: GL; Gebietsschema: de-DE (de_DE); Calc: CL, Special devUserProfile
c) Already REPRODUCIBLE with Portable Version of  6.4.7.2 (x86) 
Build-ID 639b8ac485750d5696d7590a72ef1b496725cfb5; CPU-Threads: 12; BS: Windows 10.0; UI-Render: GL; Gebietsschema: de-DE (de_DE); Calc: CL, Special devUserProfile
d) Also REPRODUCIBLE with Server Installation of Version: 7.4.0.0.alpha0+ (x64)  Build ID c856f9bec12d98ed49f01578ded79f16ae7be051
CPU threads: 12; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-US  |  Calc: CL  |  Auto Colibre Theme  |  Special devUserProfile
Comment 1 Rainer Bielefeld Retired 2022-03-07 18:18:56 UTC
e) No obvious DUP found with query <https://bugs.documentfoundation.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=DUPs147830&sharer_id=19321>
Comment 2 Julien Nabet 2022-03-07 19:21:08 UTC
Created attachment 178705 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 3 Xisco Faulí 2022-03-08 11:04:03 UTC
not reproducible in

Version: 5.2.1.2
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 8; OS Version: Linux 5.10; UI Render: default; 
Locale: en-US (es_ES.UTF-8); Calc: group
Comment 4 Xisco Faulí 2022-03-08 11:17:49 UTC
Regression introduced by:

author	Noel Grandin <noel.grandin@collabora.co.uk>	2019-02-01 15:15:16 +0100
committer	Mike Kaganski <mike.kaganski@collabora.com>	2019-04-05 13:43:52 +0200
commit 7282014e362a1529a36c88eb308df8ed359c2cfa (patch)
tree 2776ad9601f494330076ac58c08554e719c6ab3a
parent df30a4515b1303b0891baa53754fa9b3e47e0c02 (diff)
tdf#50916 Makes numbers of columns dynamic.

Bisected with: bibisect-linux64-6.3

Adding Cc: to Noel Grandin 

@Luboš Luňák, since you are working on this area right now, I thought you might be interested in this issue
Comment 5 Commit Notification 2022-03-08 14:52:35 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d032b81bbf2ca87114d15749d74166d0ba414972

proper columns range check (tdf#147830)

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2022-03-08 16:04:08 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/b9bdb81f3a9019a4c6c1758d980c5c26653831a3

proper columns range check (tdf#147830)

It will be available in 7.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2022-03-08 21:15:56 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/a03b08319f24c4a8570941460b91678a151ba5a2

proper columns range check (tdf#147830)

It will be available in 7.2.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2022-03-09 21:37:19 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/409371801a6c4ee00d7e55984e746ea9fe942447

tdf#147830: sc: Add UItest

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.