Bug 108289 - EDITING: Toolbar is unresponsive for a few sec after pressing CTRL+A for the first time in a large document
Summary: EDITING: Toolbar is unresponsive for a few sec after pressing CTRL+A for the ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.7.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, perf, regression
: 106647 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-06-01 18:41 UTC by Telesto
Modified: 2018-10-09 09:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (9.02 MB, application/vnd.oasis.opendocument.spreadsheet)
2017-06-01 18:42 UTC, Telesto
Details
Callgrind output from 5.5 (6.42 MB, application/x-xz)
2017-06-09 19:13 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-06-01 18:41:37 UTC
Description:
Toolbar is unresponsive for a few sec after pressing CTRL+A for the first time in a large document 

Steps to Reproduce:
1. Close LibreOffice (if running)
2. Open the attached file
3. Hoover with the mouse above the toolbar
4. Press CTRL+A
5. At nearly the same time hoover over the toolbar (nothing is responding)


Actual Results:  
The toolbar is unresponsive for a few (around 4) seconds

Expected Results:
The impact off pressing CTLR+A should be minimal (as in previous versions)


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.5.0.0.alpha0+
Build ID: ec79f3453471ee9b6ae32e71ff16ea99d9b7751c
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-28_23:21:44
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL

but not in
Versie: 4.2.0.4 
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-06-01 18:42:03 UTC
Created attachment 133791 [details]
Example file
Comment 2 Buovjaga 2017-06-09 19:13:18 UTC
Created attachment 133935 [details]
Callgrind output from 5.5

Repro.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.5.0.0.alpha0+
Build ID: e78d128e3b7bf45990d1f7b27123ccd616665f93
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 9th 2017
Comment 3 Aron Budea 2017-06-11 14:35:39 UTC Comment hidden (bibisection)
Comment 4 Aron Budea 2017-06-11 14:36:03 UTC
The behavior started with the below commit. Adding Cc: to Noel Grandin, please take a look sometimes.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=8d54796bf152499ecbe61788be64c9035f725dfa
author		Noel Grandin <noel@peralex.com>	2014-05-19 08:02:29 (GMT)
committer	Stephan Bergmann <sbergman@redhat.com>	2014-05-20 09:17:22 (GMT)
Comment 5 Xisco Faulí 2017-06-13 15:27:30 UTC
Same commit as in bug 106667
Comment 6 Telesto 2017-10-08 15:49:59 UTC
*** Bug 106647 has been marked as a duplicate of this bug. ***
Comment 7 QA Administrators 2018-10-09 02:52:47 UTC Comment hidden (obsolete)
Comment 8 Roman Kuznetsov 2018-10-09 07:08:32 UTC
don't repro in

Version: 6.2.0.0.alpha0+
Build ID: 89a60912bba7ffd6f65ea99f4664f343c5025c95
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-01_01:47:23
Locale: ru-RU (ru_RU); Calc: threaded

please check it anybody else

WFM or not?
Comment 9 Xisco Faulí 2018-10-09 09:12:02 UTC
(In reply to Roman Kuznetsov from comment #8)
> 
> please check it anybody else
> 
> WFM or not?

@Telesto, would you mind checking it ?
Comment 10 Telesto 2018-10-09 09:46:23 UTC
No repro
Version: 6.2.0.0.alpha0+
Build ID: d9ad59da50c1172fe98f94370221c9c1b688200a
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-08_23:34:44
Locale: nl-NL (nl_NL); Calc: CL