Bug 108292 - CRASH: When copying/pasting a Calc Sheet (multi_type_vector::get_type#1613: block position not found!) (steps in comment 8)
Summary: CRASH: When copying/pasting a Calc Sheet (multi_type_vector::get_type#1613: b...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium critical
Assignee: Eike Rathke
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.0.1 target:5....
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2017-06-01 20:43 UTC by Telesto
Modified: 2017-08-22 17:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of crash error message (194.82 KB, image/png)
2017-06-18 12:42 UTC, Dmtiry Knorre
Details
sample file to test crash (238.62 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-06-18 12:45 UTC, Dmtiry Knorre
Details
stack trace on the location where the exception is thrown. (8.97 KB, text/x-log)
2017-06-21 00:37 UTC, Kohei Yoshida
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-06-01 20:43:33 UTC
Description:
Crash when copying/pasting a Calc Sheet (multi_type_vector::get_type#1613: block position not found!)

Steps to Reproduce:
1. Open attachment 133235 [details] (bug 107770
2. Select sheet S3
3. CTRL+A & CTRL+C
4. Open a new sheet & paste (CTRL-V)
5. Crash

Actual Results:  
Crash dialog: multi_type_vector::get_type#1613: block position not found!

Expected Results:
No crash


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.5.0.0.alpha0+
Build ID: ec79f3453471ee9b6ae32e71ff16ea99d9b7751c
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-28_23:21:44
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL

but not
Versie: 4.2.0.4 
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-06-01 20:45:46 UTC
Step 4 should be: Open a new document
Comment 2 Aron Budea 2017-06-01 21:19:00 UTC
Repro with 4.3.0.4 / Ubuntu 17.04.
Adding regression-related keywords.
Comment 3 Aron Budea 2017-06-01 21:32:33 UTC Comment hidden (bibisection)
Comment 4 Aron Budea 2017-06-01 21:33:15 UTC
The bug started with the commit referenced below. Adding Cc: to Kohei Yoshida.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2bcd18892f1903d2434bc5dc6828841e49bb78a2
author		Kohei Yoshida <kohei.yoshida@collabora.com>	2014-02-20 21:05:51 (GMT)
committer	Kohei Yoshida <kohei.yoshida@collabora.com>	2014-02-20 21:09:01 (GMT)

"fdo#72041: Intern strings in the external ref cache with the host document."
Comment 5 Dmtiry Knorre 2017-06-18 12:42:26 UTC
Created attachment 134108 [details]
screenshot of crash error message
Comment 6 Dmtiry Knorre 2017-06-18 12:45:19 UTC
Created attachment 134109 [details]
sample file to test crash

cut a& paste of the cell CF4 -> BX400 (Sheet SODs_YPD) crashes Libre Office Calc
Comment 7 Dmtiry Knorre 2017-06-18 12:56:32 UTC
Libre office crashes during cut and paste of the cells CF4 -> BX400 on the first Sheet. 

Probably, the problem depends on the functions on the second sheet. The deletion of the second sheet prevent Calc from crashing. 

Copy and pasting for the same cells did not commit the crash. 

Curiously, cut and paste CF4 -> BX399 makes no problems and prevents from further crashing on CF4 -> BX400  

Version: Version: 5.3.1.2
Build ID: 1:5.3.1-0ubuntu2
CPU Threads: 2; OS Version: Linux 4.10; UI Render: default; VCL: gtk3; Layout Engine: new; Locale: en-US (en_US.UTF-8); Calc: group
Comment 8 Xisco Faulí 2017-06-20 16:58:17 UTC
Reproduced in

Version: 6.0.0.0.alpha0+
Build ID: 08f6f9dded1b142b858c455da03319abac691655
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Steps to reproduce ( just for clarification ):

Steps to Reproduce:
1. Open attachment 133235 [details] (bug 107770)
2. Select sheet S3
3. CTRL+A & CTRL+C
4. Open a new document & paste (CTRL-V)
5. Crash
Comment 9 Kohei Yoshida 2017-06-21 00:37:03 UTC
Created attachment 134174 [details]
stack trace on the location where the exception is thrown.

Looks like the problem occurs during VLOOKUP.
Comment 10 Eike Rathke 2017-06-21 19:48:21 UTC
Investigating.
Comment 11 Eike Rathke 2017-06-21 20:55:02 UTC
(In reply to Aron Budea from comment #4)
> The bug started with the commit referenced below. Adding Cc: to Kohei
> Yoshida.
> 
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=2bcd18892f1903d2434bc5dc6828841e49bb78a2

Completely unrelated though, just a bibisect border, and this is *not* bisected, just bibisected.
Comment 12 Commit Notification 2017-06-21 21:45:34 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d3b77628efc72d857c63c8fb91d7ed2b499ac860

Resolves: tdf#108292 WalkAndMatchElements: really limit the match

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Eike Rathke 2017-06-21 21:51:44 UTC
Pending review
https://gerrit.libreoffice.org/39081 for 5-4
https://gerrit.libreoffice.org/39082 for 5-3
Comment 14 Commit Notification 2017-06-22 07:33:59 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6a4343a9925dbc5a75b7aeb5dfd4fde21124492f&h=libreoffice-5-4

Resolves: tdf#108292 WalkAndMatchElements: really limit the match

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2017-06-22 15:41:00 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=23580a95fb5aa5b64d7d767eb0f5a89b0d740460

assert( nX < nC && nY < nR ); cause of tdf#108292

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2017-06-24 09:06:45 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f8f29503cc4fda0a2f3750f82ac5d7f784bdf0f6&h=libreoffice-5-3

Resolves: tdf#108292 WalkAndMatchElements: really limit the match

It will be available in 5.3.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2017-08-21 13:56:22 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=25b3806ac509006573e669acc33643af3bd77380

WalkAndMatchElements: really really limit the match, tdf#108292 follow-up

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2017-08-22 17:49:54 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8d8044d25a6d112854655ef0ad51f1a904350f0f&h=libreoffice-5-3

Resolves: tdf#111943 really really limit the match, tdf#108292 follow-up

It will be available in 5.3.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.