Bug 108654 - CRASH while undoing paste on a new sheet
Summary: CRASH while undoing paste on a new sheet
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All Linux (All)
: highest critical
Assignee: Eike Rathke
URL:
Whiteboard: target:6.0.0 target:5.4.0.1 target:6.2.0
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2017-06-20 17:41 UTC by Xisco Faulí
Modified: 2018-08-09 18:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
gdb backtrace (25.10 KB, text/plain)
2017-06-21 11:06 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-06-20 17:41:56 UTC
Steps to Reproduce:
1. Open attachment 133235 [details] (bug 107770)
2. Select sheet S3
3. CTRL+A & CTRL+C
4. Create a new sheet & paste (CTRL-V)
5. Undo the action twice
6. Crash

Reproduced in

Version: 6.0.0.0.alpha0+
Build ID: 08f6f9dded1b142b858c455da03319abac691655
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 1 Xisco Faulí 2017-06-20 17:43:46 UTC
Regression introduced by:

author	Eike Rathke <erack@redhat.com>	2017-03-07 09:46:12 (GMT)
committer	Eike Rathke <erack@redhat.com>	2017-03-07 09:51:50 (GMT)
commit	73dec49802ef8fc42c5719efaa42a33cde68e569 (patch)
tree	183c172cab6fc8bda2f7b7e1bee0b85e93d8241b
parent	4c8059a3e140171399ac85ceb882d23bb458599d (diff)
a size is a size

Bisected with bibisect-linux-64-5.4

Adding Cc: to Eike Rathke
Comment 2 Xisco Faulí 2017-06-20 17:45:15 UTC
I can't reproduce it on Win 7 x86

Version: 6.0.0.0.alpha0+
Build ID: 9e4502f0e393d2bc2810488b3ebb0a5c23038436
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-16_08:52:00
Locale: es-ES (es_ES); Calc: group
Comment 3 Xisco Faulí 2017-06-21 11:06:38 UTC
Created attachment 134184 [details]
gdb backtrace
Comment 4 Eike Rathke 2017-06-21 15:18:35 UTC
Needs a Linux debug(/dbgutil?) build to reproduce.
Comment 5 Commit Notification 2017-06-21 15:44:25 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=87cbbdc98d78c3c15f7161de6fec93d8680ee1de

Resolves: tdf#108654 check nTabNo against maTabData size

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-06-21 15:52:02 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0fed0829a601aaed6134bbc689b394e38c830605

Assert that nTabNo fits maTabData, tdf#108654 related

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Eike Rathke 2017-06-21 15:57:26 UTC
Pending Jenkins https://gerrit.libreoffice.org/39066 for 5-4
Comment 8 Commit Notification 2017-06-21 21:43:01 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=031bca731e914b309d59cc685839d14786bb615c&h=libreoffice-5-4

Assert that nTabNo fits maTabData, tdf#108654 related

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2017-06-21 21:44:16 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1fa02810cb946733a22519e8df0c8a2608fcd084&h=libreoffice-5-4

Resolves: tdf#108654 check nTabNo against maTabData size

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Eike Rathke 2017-06-28 11:18:15 UTC
*** Bug 108796 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2018-08-09 18:12:02 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d329136dd014941a6cc63f37dc3895bc118798c2

uitest for bug tdf#108654

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.