Bug Hunting Session
Bug 108665 - Inline formula in footnote does not inherit size from surrounding text
Summary: Inline formula in footnote does not inherit size from surrounding text
Status: RESOLVED DUPLICATE of bug 32419
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-20 23:49 UTC by Ben
Modified: 2017-06-27 09:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Formula size in footnote (26.27 KB, image/png)
2017-06-20 23:51 UTC, Ben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben 2017-06-20 23:49:36 UTC
In LibreOffice Writer, an inline formula in footnote does not inherit size from surrounding text. If the text in the main document has font size 12, the footnote font size is 10, then it seems that any inline formula has font size 12. This can only be corrected by equipping every formula explicitly with a size 10 line:

Example:

size 10
{
(L - %lambda sub k I ) u sub k sup " " = 0
}

Even then, the font size of the for mula is sometimes incorrect.

Example:

Using in a footnote the following formula with the same font sizes as mentioned above:

size 10
{
2 times 3 =6
}

gives a font size of the formula somewhere between 10 and 12.
Comment 1 Ben 2017-06-20 23:51:03 UTC
Created attachment 134173 [details]
Formula size in footnote
Comment 2 Regina Henschel 2017-06-21 10:39:38 UTC
In fact each formula is an independent document, which is embedded as OLE. The formula itself does not "know" where it is embedded and therefore cannot adapt itself to the environment.

It would be only possible the other way round, when inserting a formula, then set its font size to the same value as used in the surrounding text. There exists already two enhancement requests for that, bug 54358 and bug 32419.
Comment 3 Buovjaga 2017-06-26 18:10:33 UTC
(In reply to Regina Henschel from comment #2)
> In fact each formula is an independent document, which is embedded as OLE.
> The formula itself does not "know" where it is embedded and therefore cannot
> adapt itself to the environment.
> 
> It would be only possible the other way round, when inserting a formula,
> then set its font size to the same value as used in the surrounding text.
> There exists already two enhancement requests for that, bug 54358 and bug
> 32419.

Ben: shall we close this as duplicate of bug 32419?
Comment 4 Ben 2017-06-26 22:22:57 UTC
Buovjaga,

Bug 32419 is the same is not a complete duplicate. It is the same with respect to the request for inheritance but with respect to the following it may different if not solved as part of 32419: 

Using in a footnote the following formula with the same font size 10 as mentioned above:

size 10
{
2 times 3 =6
}

gives a font size of the formula somewhere between 10 and 12. 

You may want to link the bugs, or should I create another one specifically for the latter issue?
Comment 5 Buovjaga 2017-06-27 09:20:44 UTC
I searched and the inconsistent size issue is reported as bug 104231. I even confirmed it myself :)

I will take the liberty of closing this as duplicate of bug 32419

*** This bug has been marked as a duplicate of bug 32419 ***