Bug 108712 - Source format from data labels inactive
Summary: Source format from data labels inactive
Status: RESOLVED DUPLICATE of bug 95425
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All All
: medium normal
Assignee: Obitanz
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-23 09:37 UTC by Obitanz
Modified: 2017-06-23 11:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Obitanz 2017-06-23 09:37:58 UTC
I have percent data format with one decimal visible. 
When I create a chart with the wizard and I want to add data label, the standard format displays two decimals. 
If I try to change manually Number format and I tick "Source format", nothing happens when I wish that Number format is the same as source format (two decimals visible instead of only one). 

How to reproduce it:
- Open a new Spreadsheet file.
- Create some data with more of three decimals. Store these data vertically.
- Format cells as percent and with only one decimal visible (shortcuts "Format as Percent" and "Delete Decimal Place" from the toolbar).
- Select the first cell.
- Click on the "Insert Chart" button.
- Choose "Column" as "Chart Type" and "Percent Stacked" as model (third of the available models).
- Click on "Finish".
- In edit chart mode (if not, double-click on chart), right-click on one column and choose "Insert Data Labels". 

First analysis: there are two decimals instead of one.

- Select Data Labels.
- Right-click and choose "Format Data Labels..." [it's the same with only one data label select and "Format Single Data Label..."].
- Click on the button "Number Format" and tick "Source Format".
- Confirm the two windows. 

Actual results:
- Number format of data labels display two decimals.
- Source format in cells display one decimal. 

Expected results:
- Number format of data labels display only one decimal, like source format. 

Additional Info:
- This bug is present on 5.2.4.2 (x64) version and on the master version too.
Comment 1 Obitanz 2017-06-23 09:43:31 UTC
It seems to be bind with this bug:
https://bugs.documentfoundation.org/show_bug.cgi?id=95425
Comment 2 Xisco Faulí 2017-06-23 11:42:33 UTC
Hello,
Thanks for reporting the bug. Yes, they seem to be related. Closing this one as duplicated then.

*** This bug has been marked as a duplicate of bug 95425 ***