Bug 108830 - 54rc1 macOS: Auto-names for sheets in localized builds are in English
Summary: 54rc1 macOS: Auto-names for sheets in localized builds are in English
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
5.4.0.1 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-28 10:17 UTC by Martin Srebotnjak
Modified: 2017-10-09 08:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2017-06-28 10:17:39 UTC
Description:
Creating a new spreadsheet a document with an empty sheet opens, that is named "Sheet1" (and not "DelovniList1", as it should be).
Also, adding a new sheet in a spreadsheet adds an empty sheet with English naming (and not a localized naming scheme)

Steps to Reproduce:
1. Create a new Calc document.
2.
3.

Actual Results:  
Sheet "Sheet1"

Expected Results:
Sheet "DelovniList1" (i.e. in Slovenian "sl" version)


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 Alex Thurgood 2017-06-28 11:25:33 UTC
Have seen this discussed already somewhere else, but need to find out where (possibly on French user list)
Comment 2 Alex Thurgood 2017-06-28 11:27:59 UTC
Seems to be longstanding issue - DUP of bug 35912

*** This bug has been marked as a duplicate of bug 35912 ***
Comment 3 Eike Rathke 2017-06-28 12:04:16 UTC
I doubt this is a duplicate, it seems more to be due to the changed .po files that have new context identifiers bu 'sl' is one of the localizations that doesn't use Pootle and the existing .po files aren't adapted. Probably also other strings of translations/source/sl/sc/source/ui/src.po from globstr.src are affected, and a few other localizations as well.

Bug 35912 is about a specific scenario when opening a new document from the desktop.
Comment 4 Martin Srebotnjak 2017-06-28 12:37:15 UTC
Hi, Slovenian uses its own localization system.

For RC1 I updatet po files and fully localized them based on pot files of June 19, which is less than 3 days before the build was built. Did this change in po files happen during those 2 days?

I already updated po files to new pot files from yesterday and none of these strings popped up as fuzzy/untranslated (unless they were reused with pocompendium2 script).
Comment 5 Martin Srebotnjak 2017-10-08 20:53:06 UTC
Seems to have been fixed in 5.4. Closing.