Download it now!
Bug 108865 - Add to window "About LibreOffice" text about open and free distribute any numbers of copies of LibreOffice
Summary: Add to window "About LibreOffice" text about open and free distribute any num...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Roman Kuznetsov
URL:
Whiteboard:
Keywords: difficultyBeginner, easyHack, skillUI
Depends on:
Blocks: About-Dialog
  Show dependency treegraph
 
Reported: 2017-06-29 17:25 UTC by Roman Kuznetsov
Modified: 2020-09-21 21:01 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2017-06-29 17:25:41 UTC
Description:
Add to window "About LibreOffice" text about open and free distribute any numbers of copies of LibreOffice. And direct link to point from license MPL 2.0, that it make allow.

Economic police from Russia don't believe, that LibreOffice can be absolutely free, that it can be installed on any number of computers from one copy.

LibreOffice hasn't translating of text license on Russian
If my offer will be implemented, then this text in window "About LibreOffice"can be translate on any language and they will believe at last

Actual Results:  
window "About LibreOffice" hasn't text about opportunity to free install and use LibreOffice

Expected Results:
window "About LibreOffice" has text about opportunity to free install and use LibreOffice


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 tommy27 2017-07-01 04:34:27 UTC
enhancement request. status NEW.
Comment 2 Adolfo Jayme 2017-10-19 09:21:05 UTC
The About window is cluttered with text already as it is. The place for this enhancement to be done would be the window that pops up with the menu “Help > License Information”.

That dialog is easily modified by editing sfx2/uiconfig/ui/licensedialog.ui (IOW, this is a beginner-level easy hack). Michael Meeks should give his seal of approval to any text we suggest, as this concerns legal stuff.

> Economic police from Russia don't believe, that LibreOffice can be
> absolutely free, that it can be installed on any number of computers
> from one copy.

We use a standard, FSF- and OSI-approved license which explicitly addresses this very question. If they ever get to use the Firefox browser, well, it’s the same license. Somebody at the government should get a crash course over what constitutes Free and Open-Source Software… And not only in Russia. :(
Comment 3 Heiko Tietze 2017-10-19 11:01:23 UTC
I'm on Adolfo's side. => WFM
Comment 4 V Stuart Foote 2017-10-19 17:56:11 UTC
We already translate the Help -> "License Information" panel [1]. And we do not translate the actual license [2] and that is correct.

Not clear we'd gain anything from adding mention of MPL v.2 licensing to the About panel. But the text of the first sentence of [1] could be adjusted to include distribution/copying allowed use.

=-ref-=
[1] https://opengrok.libreoffice.org/xref/core/sfx2/uiconfig/ui/licensedialog.ui#63

[2] https://opengrok.libreoffice.org/xref/core/readlicense_oo/license/LICENSE#26
Comment 5 Roman Kuznetsov 2017-10-19 19:49:06 UTC
(In reply to V Stuart Foote from comment #4)
> We already translate the Help -> "License Information" panel [1]. And we do
> not translate the actual license [2] and that is correct.
> 
> Not clear we'd gain anything from adding mention of MPL v.2 licensing to the
> About panel. But the text of the first sentence of [1] could be adjusted to
> include distribution/copying allowed use.
> 
> =-ref-=
> [1]
> https://opengrok.libreoffice.org/xref/core/sfx2/uiconfig/ui/licensedialog.
> ui#63
> 
> [2]
> https://opengrok.libreoffice.org/xref/core/readlicense_oo/license/LICENSE#26

In Russia often it look very simple for OpenSource:

1. A man know, that it is OpenSource (FireFox, LibreOffice, Postgress or MySQL, etc) and don't have any questions
2. Stupid policeman, that yesterday lived in the mountains and grazed sheep, but today he is already man of power. He don't know, what is OpenSource. He know, that we need buy any soft! Him need just show dialogue "About", where on clean Russian will be write, that it is opensource and free soft. Then he will understand (i hope)
Comment 6 Francesco Gradi 2017-12-08 16:14:27 UTC
Hi there guys! I started working on this, and i have two simple questions:


1. I see that the licensedialog.ui file is an xml file. Can i use and declare the XLink namespace for the direct link to MPL v 2.0?

2. For the license text i added "LibreOffice is also free to install and use any number of copies on any device". As Adolfo suggested, I'm just looking for Michael Meeks' approval for this.


Waiting for your replies!
Comment 7 Mike Kaganski 2017-12-10 17:43:03 UTC
(In reply to Francesco Gradi from comment #6)
> 1. I see that the licensedialog.ui file is an xml file. Can i use and
> declare the XLink namespace for the direct link to MPL v 2.0?

No AFAIK; but we already have a link in About dialog implemented (see bug 103654) - you could find it useful to do likewise.

> 2. For the license text i added "LibreOffice is also free to install and use
> any number of copies on any device". As Adolfo suggested, I'm just looking
> for Michael Meeks' approval for this.

I suppose that you shouldn't wait for someone's approval here or on IRC. The proper way would be to post a proposed change to gerrit, and (optionally) add those who you believe have required knowledge in the field; and also (if required) mail to dev mailing list with your question and a link to the gerrit change, so that developers could share their thoughts and review your patch.
Comment 8 Francesco Gradi 2017-12-11 12:20:28 UTC
(In reply to Mike Kaganski from comment #7)
> 
> No AFAIK; but we already have a link in About dialog implemented (see bug
> 103654) - you could find it useful to do likewise.
> 
Thank you very much, Mike! I'll see what i can do.
Comment 9 Xisco Faulí 2018-01-11 03:32:45 UTC Comment hidden (obsolete)
Comment 10 Xisco Faulí 2018-02-11 03:31:33 UTC Comment hidden (obsolete)
Comment 11 Xisco Faulí 2018-03-14 03:36:24 UTC Comment hidden (obsolete)
Comment 12 Xisco Faulí 2018-04-14 02:32:51 UTC Comment hidden (obsolete)
Comment 13 Xisco Faulí 2018-05-15 02:29:37 UTC Comment hidden (obsolete)
Comment 14 Xisco Faulí 2018-06-15 02:42:59 UTC Comment hidden (obsolete)
Comment 15 Xisco Faulí 2018-07-16 02:40:17 UTC Comment hidden (obsolete)
Comment 16 Xisco Faulí 2018-08-16 02:35:58 UTC Comment hidden (obsolete)
Comment 17 Roman Kuznetsov 2018-09-04 14:57:38 UTC
Back to NEW, because a man nothing do
Comment 18 Roman Kuznetsov 2018-10-19 14:32:36 UTC
I'll try make a patch myself
Comment 19 V Stuart Foote 2018-10-19 16:01:45 UTC
@Roman,

As in comment 4, my suggestion remains to place your strings in the licensedialog.ui [1]

But it you insist, the Help -> About dialog entry you'd need to edit is here:

https://opengrok.libreoffice.org/xref/core/cui/uiconfig/ui/aboutdialog.ui#191

It would be translated, but *please* keep it short!  

And if you wanted to get fancy, you could make use the fixedhyper.hxx--already available in about.hxx--to add a hyperlink definition for the MPL v.2, and assign that text to a GtkLinkButton in the aboutdialog.ui

=-ref-=
[1] https://opengrok.libreoffice.org/xref/core/sfx2/uiconfig/ui/licensedialog.ui#63
Comment 20 Roman Kuznetsov 2018-10-21 20:30:20 UTC
https://gerrit.libreoffice.org/#/c/61940/
Comment 21 Michael Meeks 2018-11-07 12:18:10 UTC
I'm up for changing the about dialog to make it more helpful - but I'm generally against something that encourages enterprises to use LibreOffice without contributing to our community.

Any "you have the right to use it for free" needs to have a matching "but it is utterly irresponsible as an enterprise to save money and invest nothing in the future of the product" =) So that would need a link to some sensible TDF hosted page that helps to explain this in some detail - I guess and one that we can translate.

So I don't think the proposed change gets this important balance right.

Providing a non-authoritative translation of the MPLv2 might perhaps be a good idea, no idea if that is available somewhere, I assume the LGPLv3 already has a non-authoritative translation.
Comment 22 Michael Meeks 2018-11-07 12:20:47 UTC
Also, IANAL - but my take is that the MPLv2 allows people to distribute their binaries under arbitrary (Russian) licenses - as long as they contribute their modifications back. So it should be possible for (paranoid) companies to buy Russian versions with Russian licenses without too much of a problem. My hope is that they then contribute to the project.
Comment 23 Mike Kaganski 2018-11-08 12:13:33 UTC
I suppose that the mention of the redistribution terms in the dialog is not important in Russia nowadays. It used to be in the past, though, when our police just started to work with copyright infringement in the SW area.
Comment 24 Heiko Tietze 2018-11-09 10:22:21 UTC
The current solution is a good compromise. And actually a localization is not needed in Russia.
Comment 25 Óvári 2020-07-04 21:22:25 UTC
The current solution is a bad compromise.

"The Personal edition is supported by volunteers and intended for individual use." would make people concerned in English speaking countries too.

It also gives the impressions that its features have been retarded. The "Professional edition" has more than the "Personal edition".

"LibreOffice is Free Software and is made available free of charge.
Your donation, which is purely optional, supports our worldwide community.
If you like the software, please consider a donation."

"Personal" and " and intended for individual use" should be removed.
"The" should be replaced by "This"

If the string is required
"The Personal edition is supported by volunteers and intended for individual use."
should at most be:
"This edition is supported by volunteers."

There could be a "Donate" link where "Credits  Website  Release Notes" are shown.
Comment 26 Gerry 2020-07-05 07:57:47 UTC
I fully agree to Ovari's suggestion:

If the string is required
"The Personal edition is supported by volunteers and intended for individual use."
should at most be:
"This edition is supported by volunteers."
There could be a "Donate" link where "Credits  Website  Release Notes" are shown

Does anyone open a new bug report suggesting this change?
Comment 27 Heiko Tietze 2020-07-05 08:02:14 UTC
(In reply to Óvári from comment #25)
> "The Personal edition is supported by volunteers and intended for individual
> use." would make people concerned in English speaking countries too.
> ...
(In reply to Gerry from comment #26)
> Does anyone open a new bug report suggesting this change?

Off-topic here. Please add your opinion on bug 134486
Comment 28 Narax Smith 2020-08-01 10:38:37 UTC Comment hidden (spam)