Bug Hunting Session
Bug 108989 - Add contextual UNO commands for name ranges and data validity to context menu
Summary: Add contextual UNO commands for name ranges and data validity to context menu
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: All All
: medium enhancement
Assignee: Gülşah Köse
URL:
Whiteboard: target:6.1.0
Keywords:
Depends on:
Blocks: Context-Menu UNO-Command-New Cell-Validity Cell-Name
  Show dependency treegraph
 
Reported: 2017-07-06 12:28 UTC by Thomas Lendo
Modified: 2018-01-26 12:43 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
3 example features that should be acessible in the context menu (10.39 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-07-06 12:33 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-07-06 12:28:22 UTC
If the users clicks at a cell with that Calc features are linked (like Names/Name ranges, Conditional formatting, Validity) now it's not visible what features are already used in that cell.

I would suggest to give the user the possibility to see and use the available features in the context menu.

In the attached file, 3 features are used:

1. A2-A4 are cells that have the cell range name "numbers". If clicking at one or all of the cells, then it should be possible to open the "Sheet > Names Ranges and Expressions > Manage" dialog with the context menu.

2. Cell B2 contains the validity feature with cell range "numbers". If clicking at the cell, then it should be possible to open the "Data > Validity" dialog with the context menu.

3. Cell C2 contains conditional formatting. If clicking at the cell, then it should be possible to open the "Format > Conditional Formatting > Condition..." dialog with the context menu.

I open only this bug and not a bug for every Calc feature that I would like to have in the context menu because I want a discussion with UX team which feature can be and is worth to be in the context menu. If any.

I think this would improve the usability of Calc features.
Comment 1 Thomas Lendo 2017-07-06 12:33:23 UTC
Created attachment 134516 [details]
3 example features that should be acessible in the context menu
Comment 2 Heiko Tietze 2017-07-18 12:08:16 UTC
Sounds like a very helpful enhancement. But is such a context dependent function feasible, Timur, Eike, Moggi?
Comment 3 Yousuf Philips (jay) (retired) 2017-07-18 17:20:18 UTC
(In reply to Thomas Lendo from comment #0)
> 3. Cell C2 contains conditional formatting. If clicking at the cell, then it
> should be possible to open the "Format > Conditional Formatting >
> Condition..." dialog with the context menu.

Already suggested in bug 87357.
Comment 4 Thomas Lendo 2017-07-18 19:17:13 UTC
The 3 examples of features I mentioned in my initial post stand for all possible features that could be promoted to the user. I don't know more so it's to others to bring them up - here or in another bug(s).

Ist it ok to have both features (validity and name ranges) in this bug? I hear the devs rant in my thoughts. :)

And for the record, there are some use cases (collaboration with others, forgotten use of a feature in a cell, short mouse ways, overview what is applied to the selected cell ...) where a context menu entry would help to find and to (re)use a feature that is applied to a cell or cell range.
Comment 5 Gülşah Köse 2018-01-15 23:05:37 UTC
https://gerrit.libreoffice.org/#/c/47925/ solves only named ranges part. The other two patches are on the way.
Comment 6 Heiko Tietze 2018-01-16 08:05:30 UTC
(In reply to Gülşah Köse from comment #5)
> https://gerrit.libreoffice.org/#/c/47925/ solves only named ranges part. The
> other two patches are on the way.

Happy to review when all is complete.
Comment 7 Gülşah Köse 2018-01-16 09:43:58 UTC
Thanks Heiko, i will send seperate patches for validation and conditional format issues. fyi.
Comment 8 Gülşah Köse 2018-01-23 13:57:16 UTC
@Heiko completed

https://gerrit.libreoffice.org/#/c/48067/ for validity
https://gerrit.libreoffice.org/#/c/48417/ for conditional format
https://gerrit.libreoffice.org/#/c/47925/ for named range
Comment 9 Commit Notification 2018-01-24 12:30:24 UTC
Gulsah Kose committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=844c92793c1399e2f14f671f964ea35e1bce24ac

[Pardus] tdf#108989 Add contextual validity command.

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2018-01-25 11:05:22 UTC
Gulsah Kose committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a626e249033fb9a7ac117e28f3152cedf98b61fc

[Pardus] tdf#108989 Add contextual manage names command.

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Gülşah Köse 2018-01-25 11:11:50 UTC
(In reply to Yousuf Philips (jay) from comment #3)
> (In reply to Thomas Lendo from comment #0)
> > 3. Cell C2 contains conditional formatting. If clicking at the cell, then it
> > should be possible to open the "Format > Conditional Formatting >
> > Condition..." dialog with the context menu.
> 
> Already suggested in bug 87357.

Because of request 3 has seperate bug report, reported by Yousuf, and request 1(named ranges) and 2(validity) is completed, i'm moving that bug as RESOLVED FIXED. Feel free to change it if there is a problem.

Request 3 is solved by https://gerrit.libreoffice.org/#/c/48417/ waiting for code review.
Comment 12 Timur 2018-01-26 09:33:30 UTC
Useful. 
Deserves to be put in https://wiki.documentfoundation.org/ReleaseNotes/6.1.
Comment 13 Gülşah Köse 2018-01-26 10:12:19 UTC
(In reply to Timur from comment #12)
> Useful. 
> Deserves to be put in https://wiki.documentfoundation.org/ReleaseNotes/6.1.

Done :) Thank you all for supporting.
Comment 14 Commit Notification 2018-01-26 12:43:51 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=707e0f4e6b6e36432c0f04f22719428a7e1a50ee

coverity#1428613 check IsValidReference() return value, tdf#108989 follow-up

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.