Bug 87357 - Contextual manage conditional formatting context menu entry
Summary: Contextual manage conditional formatting context menu entry
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Gülşah Köse
URL:
Whiteboard: target:6.1.0
Keywords:
: 111574 (view as bug list)
Depends on:
Blocks: Context-Menu UNO-Command-New Conditional-Formatting
  Show dependency treegraph
 
Reported: 2014-12-16 11:09 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-05-23 15:57 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-12-16 11:09:37 UTC
When you right-click on a cell which has conditional formatting assigned to it, there isnt any context menu entry to edit the conditional formatting. A user must go into Format > Conditional Formatting > Condition... in order to do so. So i'd like to suggest the addition of three context menu entries.

1) Edit Conditional Formatting... - Shown when right-click on a single cell or a group of cells that all part of the same conditional formatting data range.

2) Delete Conditional Formatting - Appears whenever the edit entry appears and makes it easy to delete a conditional formatting range.

3) Manage Conditional Formatting... - Shown when right-clicking on a range of cells that contain one or more conditional formatting data ranges in it.
Comment 1 Joel Madero 2014-12-16 15:49:45 UTC
Sounds completely reasonable.
Comment 2 Joel Madero 2014-12-16 17:43:28 UTC
After talking to Markus this won't be implemented. The reason being that the new method of conditional formatting is applied per range, not per cell, so it makes no sense to allow edits to a cell if the condition is applied to a range.

@Jay - for additional info feel free to ping Moggi and he'll explain.
Comment 3 Yousuf Philips (jay) (retired) 2014-12-17 05:28:33 UTC
(In reply to Joel Madero from comment #2)
> After talking to Markus this won't be implemented. The reason being that the
> new method of conditional formatting is applied per range, not per cell, so
> it makes no sense to allow edits to a cell if the condition is applied to a
> range.

Yes the bug is about detecting the conditional formatting range that a cell is part of and showing the context menu entries accordingly, so a user can edit the condition applied to the range.
Comment 4 Joel Madero 2014-12-17 05:36:22 UTC Comment hidden (obsolete)
Comment 5 Yousuf Philips (jay) (retired) 2014-12-17 05:47:35 UTC Comment hidden (obsolete)
Comment 6 Markus Mohrhard 2014-12-17 16:11:43 UTC
I don't like the request and if I have to decide it would not be implemented. Conditional formats are complex especially when it comes to handling the different corner cases. For range based conditional formats we have some dialogs to help with that problem that don't fit into the context menu.

Personally I would prefer if everyone would just go through "Manage Formats" as it is the only way to understand what is going on in your spreadsheet.

The context menu becomes a bit confusing if entries appear or disappear based on things that the user does not see/understand. One thing that I learned from Christoph is that the context menu should be simple and intuitive.
Comment 7 Joel Madero 2014-12-17 16:54:10 UTC
Sounds like this needs UX-advise as there are definitely some different opinions here.
Comment 8 Adolfo Jayme 2014-12-18 12:51:07 UTC
The addition of those three elements (suggested in comment 0) is just too much clutter. I don’t think it’s an enhancement as it would add redundant ways to enter the same dialog, which in any case would be better served in a context toolbar, but not in a context menu.
Comment 9 Yousuf Philips (jay) (retired) 2014-12-18 13:53:15 UTC
(In reply to Markus Mohrhard from comment #6)
> Personally I would prefer if everyone would just go through "Manage Formats"
> as it is the only way to understand what is going on in your spreadsheet.

So how is Format > Conditional Formatting > Manage... different than Context Menu > Manage Conditional Formatting..., as i see one as easy access and one as menu digging. I dont see any difference to this than the context menu giving us Edit Hyperlink... rather than going to Edit > Hyperlink or the context menu giving us Delete Pivot table rather than going to Data > Pivot Table > Delete.

> The context menu becomes a bit confusing if entries appear or disappear
> based on things that the user does not see/understand. One thing that I
> learned from Christoph is that the context menu should be simple and
> intuitive.

If conditional formatting data bars, color scales, and icon sets are set on a sheet, these are somethings that a user would see and understand. I do believe in small and simple context menus, and it is something that i've been pushing for in all modules (bug 81132, bug 86614), but do believe that the context menu should give access to features a user right-clicks on rather than having them dig through menus to modify that feature. If space is an issue for these 3 entries, then we could easily have a 'Conditional Formatting' submenu with entries for Edit, Delete and Manage.

Maybe my 3rd entry suggestion (Manage Conditional Formatting...) isnt the best possible implementation and maybe it should only appear when entries 1 and 2 appear.
Comment 10 Yousuf Philips (jay) (retired) 2014-12-18 14:29:10 UTC
(In reply to Adolfo Jayme from comment #8)
> The addition of those three elements (suggested in comment 0) is just too
> much clutter.

I have suggested reducing it down with a submenu and if that isnt ideal, we can limit it to just entries 1 and 3, as delete is available in entry 3, and in the worst case scenario, even just entry 3 is fine.

> I don’t think it’s an enhancement as it would add redundant
> ways to enter the same dialog, which in any case would be better served in a
> context toolbar, but not in a context menu.

How is something redundant if you only have access to it from one way. Having a context toolbar to provide easy access to these 3 entries is a waste IMHO.

If others in the UX-team agree with Adolfo on this issue, then i would be happy to drop it.
Comment 11 V Stuart Foote 2014-12-18 14:56:36 UTC
Back to UX-advise, and NEW.  @Jay, a markup please.

@Marcus, Adolfo in the context presented is there a reasonable UI adjustment to be made?
 
Opened as an item on the http://pad.documentfoundation.org/p/design for next Design hangout.
Comment 12 Cor Nouws 2015-05-04 09:29:23 UTC
I would say: don't do it.
We don't have all in the context menu, and especially when there are good reasons for a more generic entrance of the function, pls don't..

I suggest: WontFix.
Comment 13 Robinson Tryon (qubit) 2016-08-25 05:26:49 UTC Comment hidden (obsolete)
Comment 14 Cor Nouws 2016-09-09 09:36:37 UTC
no further reply from the people that gave technical advise, which I think is wise to advise that they simply stay with the initial response > WontFix
Comment 15 Yousuf Philips (jay) (retired) 2016-09-09 13:32:12 UTC
@Eike, @Bubli, @Samuel: Do you think this is worth implementing?
Comment 16 Heiko Tietze 2016-09-10 08:17:19 UTC
(In reply to Yousuf Philips (jay) from comment #15)
> @Eike, @Bubli, @Samuel: Do you think this is worth implementing?

My 2 cents: Taking Moggi's No into account and, on the other hand, the fact that we should give access to all relevant functions in the context menu, I would show "Manage Conditional Formatting" in all variants with a formatting.

Sounds maybe like a redundancy but users explore functionality using the context menu and will miss this option.
Comment 17 Thomas Lendo 2017-07-18 19:21:06 UTC
I think there are some use cases (collaboration with others, forgotten use of a feature in a cell, short mouse ways, overview what is applied to the selected cell ...) where a context menu entry would help to find and to (re)use conditional formatting that is applied to a cell or cell range.
Comment 18 Yousuf Philips (jay) (retired) 2017-08-15 03:49:02 UTC
*** Bug 111574 has been marked as a duplicate of this bug. ***
Comment 19 Richard Léger 2017-08-15 05:53:24 UTC
I agree that not all cell functionalities are meant to be listed in context menu but for 'Conditional Formatting'(CF) it does make sense.

The already existing 'Format > Conditional Formatting' entry (allowing access to sub menu) could simply be copied/duplicated in the context menu of cell. Providing the exact same functionality.

It would simply make it quick, easy and intuitive to access without clutering the menu (only one additional entry in context menu).

(...)
-------------------------
Format Cell
Conditional Formatting >
-------------------------
(...)

I would expect a lot people do righ-click + format cell so it becomes natural to look at the same location and expect right-click + conditional formatting on a cell.

A possible alternative could be to merge conditional formatting windows as tabs of format cell windows... perhaps... providi g the two functionalities (Format Cell and Conditional Formatting) within the same setting window...and only one entry in cell the context menu.

The first option would have my preference though...as it may be much easier to implement.
Comment 20 Commit Notification 2018-01-26 09:32:23 UTC
Gulsah Kose committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1a8aac875ffb0a8c7b4161ff62807c1fb3e3e4a4

[Pardus] tdf#87357 Add contextual Conditional Format command.

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.