Bug 109128 - FILEOPEN: DOCX - Incorrect width of square in figure
Summary: FILEOPEN: DOCX - Incorrect width of square in figure
Status: VERIFIED DUPLICATE of bug 84399
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2017-07-14 17:45 UTC by Marco A.G.Pinto
Modified: 2020-09-14 12:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample/example (52.90 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-07-14 17:52 UTC, Marco A.G.Pinto
Details
sample (22.11 KB, application/wps-office.docx)
2017-07-14 19:12 UTC, Yousuf Philips (jay) (retired)
Details
how it looks in Word (15.97 KB, image/png)
2017-07-14 19:16 UTC, Yousuf Philips (jay) (retired)
Details
Screenshot of the example document in Word and Writer 6.5 (63.33 KB, image/png)
2020-04-21 16:14 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco A.G.Pinto 2017-07-14 17:45:37 UTC Comment hidden (obsolete)
Comment 1 Marco A.G.Pinto 2017-07-14 17:52:26 UTC Comment hidden (obsolete)
Comment 2 Yousuf Philips (jay) (retired) 2017-07-14 19:12:50 UTC
Created attachment 134641 [details]
sample

Steps:
1. Open attached file
2. Notice that red square's width isnt the same width as the triangle

Version: 6.0.0.0.alpha0+
Build ID: 0686abc10aa729c8768b06249dbf7e57f4e56ae5
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 3 Yousuf Philips (jay) (retired) 2017-07-14 19:16:27 UTC
Created attachment 134642 [details]
how it looks in Word
Comment 4 QA Administrators 2018-07-15 02:42:43 UTC Comment hidden (obsolete, spam)
Comment 5 NISZ LibreOffice Team 2020-04-21 16:14:20 UTC
Created attachment 159797 [details]
Screenshot of the example document in Word and Writer 6.5

It looks good (even after save&reload) now in current master, since:

author
Miklos Vajna <vmiklos@collabora.com> Mon Mar 02 20:23:04 2020 +0100 
committer
Miklos Vajna <vmiklos@collabora.com> Tue Mar 03 07:57:05 2020 +0100 

tdf#84399 VML import: map <v:shape o:spt="202"> to TextShape
Comment 6 NISZ LibreOffice Team 2020-04-21 16:14:32 UTC

*** This bug has been marked as a duplicate of bug 84399 ***
Comment 7 NISZ LibreOffice Team 2020-09-14 12:15:31 UTC
Verified in:

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 34a09c9c61bff30e8c4d16132bb47b2b1b16e422
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded